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Preview
Preview

Dear Customer,

We are pleasure to see you purchasing Minato Gang Programmer MODEL308.
This manual explains how to use MODEL308 correctly, so please read this manual
before operation.

Register for Warranty
MINATO ADVANCED TECHNOLOGIES will implement support for our products,
please register all the information on our web.

Before register please check below 3 items about the programmer:
MODEL

Serial Number (see Rear Panel)

Version (see operation manual CD-ROM)

The warranty does not apply to some problem, please read ”Warranty terms” for
detail.

MINATO ADVANCED TECHNOLOGIES INC. (Home Page)

http://www.minato.co.jp

M308-020A-K2
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PC Requirements for control MODEL308
PC Requirements for control MODEL308

OS requirements
* Windows Vista
*  Windows 7 ( 32bit, 64bit )
* Windows 8, 8.1 ( 32bit, 64bit )

Recommended PC requirements

 CPU Pentium4 1GHz or Higher

* RAM 512MB or Higher

e Hard disk 1GB or Higher free space
* Interface USB2.0 or Higher
 USB More than 1
e CDDriver CD-ROM

The free space of Hard disk depends on the target device which should be
programmed. Please prepare enough space for large capacity device programming.
First time connecting MODEL308 to PC, please read below notice items.

[Notice for first time connecting to PC |
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MODEL308 Packing list
MODEL308 Packing list
Before installing your programmer, please carefully check that your package include

all next mentioned parts. If you find any discrepancy or if any of these items are
damaged, please contact distributor or Minato directly.

[Packing list]
e MODEL308

e MODULE ( SU308-48DP/3v )
2¢The MODULE number for the MODEL 2pcs

* Power Cable
» USB Cable
e CD (MODELS3O08 control software, USB driver, Operation manual )

MODEL308 Programmer
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Warranty Terms
Warranty Terms

Minato gives a guarantee on programmer for one-year from the date of purchase (Just
for customer who has registered their programmer). The warranty does not apply to
products on some conditions, so please read below contents.

Warranty Period
One-year from the date of purchase.

Warranty ltems

Less than one-year after purchasing.
Having registered your programmer.
Does not caused by abnormal operation.
MODEL308 Hardware is defective.
This warranty is valid only in Japan.

OO R

Pay for repair

Even during warranty period, warranty is invalid for below items:
1. Programmer has not been registered.

2. Have not registered the full information.

3. Damage caused by inappropriate use.

4. Damage caused by natural disaster.

Exempt of Warranty

Minato is not liable for:

IC and data to program.

Direct and indirect cost due to damage of programmer.

Programmer be used oversea (not in Japan).

Damage caused by using third party items(example: adapter, software).

Repair or modification by unauthorized party.

Damage caused by inappropriate use or handling.

Version up of MODEL308.

VerS|on -up for new device is not free. Please see ”maintainance of MODEL 308 for
detail.

NoOkodPE

Special note

1. Register will be ok after you sending all the informations to Minato.
2. You should pay for the transportation fee from you to Mianto.

M308-020A-K2
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o ok

Warranty Terms

Please keep the box provided by Minato which can be reused while transportation
for repair. Please make sure the package is strong, otherwise you should pay for
the damage of programmer.

Minato will pay for the transportation fee after repairing.

This manual will be updated without notice.

Any incomprehension please contact us.
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Maintainance of MODEL308
Maintainance of MODEL308

To ensure that your programmer continue to meet good performance and your request.

Warranty of MODEL308

One-year warranty from the date of purchase from Minato (Just for customer who has
registered their programmer). Please see “warranty terms* for detail.

Version up for MODEL308 (IC/software support)

New IC can be supported by updating the software of programmer. Version-up to add
new IC support is not free of charge even within warranty period.
If there’s defective of our software, the update is free.

Calibration

MODEL308 is mass production equipment, please maintain the programmer every
day and calibrate the programmer per year.

About repair, calibration and version up

Minato does not provide on-the-spot service no matter free charge or not. And we can
not provide spare programmer, please understand. Customer should pay for the
transportation fee from you to minato for repair, calibration and version up. Minato
will bear the transportation cost for return.

M308-020A-K2
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Safety Precaution

Safety Precaution

Warning and Cautions

This operation manual includes safety precautions for safely use MODEL308
programmer. To prevent the operator or others people from injury and property
damage, please following below pictographs to operate.

Before reading this manual, fully understand these pictographs and the meanings.
Keep this manual at hand and refer to it while necessary.

Explaination of Pictographs

Indicates a potential hazardous situation in which
the operator would be killed or seriously injured

Warning | unless this precaution is observed.

Indicates a potential situation in which the operator
] would be injured or property would be damaged
Cautions unless this precaution is observed.
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Safety Precaution

N\ ARNING

Making sure to follow warnings and cautions while operation the
Compulsion ~ Programmer.

Do not disassemble or modify the programmer. It may cause a fire or
electric shock.
Do Not Disassembled

2

When finding a smoke, abnormal smell or sound, please remove the
power plug immediately. Otherwise it may cause a fire or electric
shock due to short-circuit.

Unplug Power Cord

If the programmer is dropped or shocked, please remove the power
plug immediately. Otherwise it may cause a fire or electric shock due
to short-circuit.

Consult with Minato or distributor.

&

Unplug Power Cord

If any liquid or foreign matter enters the programmer, please remove
the power plug immediately. Otherwise it maybe will be caused a fire
or electric shock due to short-circuit.

Consult with Minato or distributor.

Unplug Power Cord
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Safety Precaution

PXCautions

e & &

Compulsion

S ¢

Compulsion

The operator should fully understand the manual before operation.
Miss operation may damage the programmer or ICs.

Compulsion

Before touching the programmer, please touch a nearby large metal to
remove static electricity from your body.

Static electricity may damage the programmer or ICs.
Compulsion

Please clean the surfaces, the socket and the air filter screen of
programmer.

Dusts may cause a fire or breakdown, so please clean them at regular
intervals.

Do not program IC when Empty Socket (red LED) is indicated. It means
the contact check is failed and programming maybe damage the ICs or
programmer caused by the heat.

Compulsion

Please confirm the CheckSum for PASS/FAIL.
Avoiding NG ICs are mixed with OK ICs.
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Safety Precaution

Caution for accessories
0 Standard power cable complies with Japanese regulation.

If you will use this programmer in others country, please follow the
local safety Standard.

Compulsion

adapters or the Ics.

Do not execute the self-test of the programmer without removing the
0 It may damage adapters or ICs.

Compulsion

M308-020A-K2
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Outline

Outline

Outline

MODEL308 is Gang Programmer which can be controlled by PC (windows OS)
software through USB Port and supports large capacity devices. MODEL308 is

equipped with 64GByte (512Gbit) microSD Memory and provide high performance
for mass programming .

Features

Specification

Improved for Operating environment.
High programming speed.
Equipped with 512Gbit microSD Memory.
Supporting various devices.
Sharing the adapters with another MODEL.

Item MODEL308 Note
Simultaneous 8
programming
Buffer Memory | 512Gbhit Option
1024Gbit(max.)
Interface USB Rev.2.0
Operating 5—35[°C]
Temperature
Operating —
Humidity
Power/Frequency | AC100-240[V]
50-60 [HZ]
Power dissipation | 200[VA](max.)
Fuse 3[A]
Size 380(W)x390(D
)x120(H) [mm]
Weight 9.0 [ko]
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MODEL308 Element and Function
MODEL308 Element and Function

In order to operate MODEL308 properly, please understand the function of each part
and its name.The details are described in following pages.

When used, MODEL308 of products shall be accompanied by dedicated control
software and socket unit. Please note that the startup would fail if software other than
special control software is used. For further information about detailed description of
special control software, please refer to the Operation Instructions for “Control
Software of MODEL308” in this manual. Please refer to “About socket unit” for
detailed description of socket unit.

Figure) MODEL308 Rear Panel

Status LED

Start

MINATO 308 GANG PROGRAMM:R

MINATO

Module Position
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Module Position

Module Position

Figure) MODEL308

L

5

1

I © i
L T

THTH
/

Module Connector

—

(¢]

(@)

SOCKET Number (#1~#8)

Module

SOCKET Number

Each SOCKET has a corresponding number. And we use “#+number” to express it in
this manual.

Example)
17
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Module Position
SOCKET 2 is described as ”#2”

Module Connector
Module Interface Connector

Socket LED (Indicating PASS/FAIL)

Different color means the operating result.
PASS Green
FAIL Red

308 GANG PROGRAMMER

MINATO

MINATO

M308-020A-K2
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Rear Panel

Rear Panel

USB Connector Air Vent
@ @
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/ v

- Serial Number Power Switch

Revision Number

[ MODEL 308 |
[

Power Connector

Power Connector
AC power supply connector with (3A)FUSE.

Power Switch

USB Connector

Air vent
Air vent is designed for the external air sucked for cooling the interior of MODEL 308.

Please keep the vent unblocked. Please use dust collector etc. to remove apparent dust
(if any) in air filter.

Serial Number
Each programmer has a unique Serial Number and it will be required for service.

Revision Number
Revision Number of Hardware and it will be required for service.
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Optional Items
Optional Items

MODEL308 of products are supplied with standard socket unit.

In addition to standard socket unit, user may optionally use the following adapters.
Please make sure the adapter are matched with the device used.

Adapter

*Special adapters for Aute handler
Please contact with our sales department for detail.

M308-020A-K2
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About Module
About Module

There are various Modules. Here just introduce several typical modules and describe
how to install them on MODEL308.
For others Module installation, please contact with Minato or distributor.

>¢Never fail to mount socket unit in the body. No operation would be activated even
if the product is mounted when the power supply for body is turned on.

To this end, please properly mount the socket unit before the power supply for body is
turned on.

Please note that the device would not run if out socket unit is not mounted when
operating the body with our special control software.

Types of Module
There is one type of the Module for MODEL308.

(1 SU308-48DP/3v
Special purpose module for 3V,
Many different adapters can be used on this module.

Various Adapters

All the adapters for M1940 and M1950 also can be used on MODEL308. And above
Modules are necessary.

s<Please see “About Module” for detail.
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About Module
Module Position

Describe the direction of Module installation.

SU308-48DP/3v

KET .
SOSNIT SU308-48DP/3V MINATO

IC Socket

Lock Lever
(Open/Close)

PASS/FAIL LED

Lock lever (open/close)
Before inserting device, push up the lever (open)
After inserting device, push down the lever (close)

IC SOCKET

Most modules (TSOP, BGA, etc) except DIP can be opened or closed by pressing the

socket.

M308-020A-K2
MINATO ADVANCED TECHNOLOGIES INC.
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About Module
Direction of Module installation

MINATO 308 GANG PROGRAMMER

MINATO

In the case of socket unit with locking rod, the locking rod shall be mounted at
a neighboring point.

As for socket unit with base plate notch, the notch shall be mounted at a
neighboring point.

PASS/FAIL indication LED shall be mounted at a neighboring point in the
case of locking unit without locking rod and base plate notch.
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About Various Adapters
About Various Adapters

This chapter describes adapters for MODEL308

1. Just adapters which have been supported by MODEL308.
2. Some others adapter can be supported by MODEL308 after version up. (Not all)
3. Due to too many types adapters, we call them “Various Adapters”

Notice!

Module SU308-48DP/3v is necessary for adapters. And SU308-48DP/3v is between
the adapter and MODEL308.

DIPIC Except DIP IC
IC v

Various Adapters

SU308-48DP/xx
Is necessary.

Module

'

SU308-48DP/3v

[°)

I

o

I

o

. ..
°)
0
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About Installation

(Software and Hardware)

¥ Matters needing attention when connecting MODEL 308 of products to PC for the
first time
(Important )

25
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Installation
Installation

The CD-ROM contains MODEL308 Control software (Universal Control Program),
USB drive and operation manual.

In order to control the programmer by software, you must correctly install the USB
driver and software first.

X The software must be installed before connecting the programmer with PC.

Installation of Software
Please insert the CD-ROM to install below software.

=M308 installer.exe ( MODEL308 Control software)
*M308_USB_driver32_v200.exe ( USB Driver for 32bit-0S)
*M308_USB_driver64 v200.exe ( USB Driver for 64bit-OS)

It will start to install after double click above software.
For MODELS308, all above software must be installed before operation.
Please follow below installation method to install software.

[Installation Method ]

Example) Installation for application program
Double click “MODEL308 installer.exe”

HEN] ip rgbadled
Pugh (b Hra reak (1]

=

&

Coyreemht 201T-2017 HRATO Dercee Campuarny

Click next [next (N) >]

M308-020A-K2
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Installation

g s o R gl T W
A Ak =1Ly
G s lerah sk iop WM 110rcisliss san
A A=l
CeiPrelr s el IS s el

FF I B - R TR T

I'_I_:'
|

R LU0 | Bl B Bt e

] I

Creating a short-cut on the desktop after selecting M

AL IR T
[ et | | B e T B

I'_I_i'
-

This screen means the installation has been fininshed.
Please click (finish)

X Installing the USB driver.exe by the same method.
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Installation

X Note X
When running the applications developed by using [Visual C++ 2010], the installation packet is
required. If your PC cannot install [Visual C++ 2010] or above, please install [vcredist_x86.exe].
For smooth installation, the following OS are required.
Windows XP Service Pack3 or above
Windows Vista Service Pack2 or above
Windows 7

Or download the packet from the following URL.
http://www.microsoft.com/ja-jp/download/details.aspx?id=8328

o J
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Installation

Installation for Hardware

Before start the Universal Control Program, please connecting MODEL308 to
PC by USB cable.

Windows will detect new hardware, please follow below method to install the driver.
MODEL308 will be detected by windows and installation will start automatically.
Please insert the CD-ROM.
Setupl Connecting the USB cable to programmer
Setup2 Connecting the USB cable to PC

(Recommand High-Speed USB 2.0)
Setup3 Power on the MODEL308 and make sure the buzzer and status of LED

are correct.

Setup4 Windows will start with “ Found New hardware Wizard”

LA - FOTPORE L - |

HLON-FOT7 ORI —FORLE

S =BT RON - FOI PR BRI TR LA - L3S

1408 Programmer

() A—FYIPCHBOAYAR-) GD FEIFOE— Fo
S AMFESBAU. WALTEESD,

A VA= AEERATIE

O —~EFEIREMRRNSA LA M- 13 GHDE

FEATEBEL. [RA] B LTS,

| TR ! |

Selecting “Install the software automatically (Recommended)
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Installation
Wizard start searching programmer and install driver automatically.

YFRIIFE AR RLTOE S, ISR .

(3 M408 Programmer

- L

AT LTI U MESE L. Fas 2T WO BB D
SEERATE LI IO Py PR ERR LT,

S e |

Confirming the installation.

A ZOP—EOTT

408 Programmer

i

TERF RN A =L LEDE LTS PP, Windows KP =)
g kgt T e ) Wlndows)l:lj TAHCSHELTLER A
QT A M BT DI

i

=

{2A R NESTLERS. Y AT LOBIEMEEDIED, Y AT A
I EECRDRY . BARRERA | ERCTERF RS0 s
Fd, A2 )L P, Windows 0T FAM-SHELEYY
FOT PR AT 30, N—FIrP A CREZENSC R,
Microsoft (ISR EEIOLET,

| BTG | [ T
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Installation
After successfully installing you will see following window:

FHLLON-FOI PRI -FDFET

FRON =B IPOUINITPOA AR ISE T L3

(3 M408 Programmer

BET] &M e0F e - R,

Click “Finish” button to finish the setup.

(X Notice % A

In addition, MODEL 308 of products will detect the new hardware in the connected

unit (COM port), and programmer MODEL308 will perform hardware installation for
2 times, respectively.

\. J
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Notice for first time connecting to PC
Notice for first time connecting to PC

After installing the hardware driver

Please perform the following operations after hardware installation. Where the
following operation is not performed, PC would be unable to identify MODEL 308 of
products.

[For Windows XP (SP3) ]

@ Copy file “usbser.sys” in below folder.
“C:\Windows\ServicePackFiles\i386”
or “D:\Windows\ServicePackFiles\i386”

@ Paste “usbser.sys” to below folder.
“C:\Windows\system32\drivers”
or “D:\Windows\system32\drivers”

@ Power on the programmer. Perform hardware installation again. Check if
programmer has been identified upon the completion of installation.
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Notice for first time connecting to PC

@ [Start] — [ Setting] — [ Control Panel] — [ System] — [ Hardware] —
[ Device Manager |

If you can find the the Model of MODEL308,
it means the Programmer has been recognized

and please remember the USB port. oy TAAR (T

» B T2 TA FETE—

. B Asb7-5 FEA-

BE -V fA-TI{ A FIAA

= -

FIUE HEER ERENY ~LTH)
e m| Hml &

Please click the icon to run the control Software.

T M08 Programmer [COMG)

f - 1 [ =
T ML Programma [O0MT]
T H4LS Programmer [OOME]

- [ FPArIoEsad LT T2

- B T

- i SN AP 0 3 HI-5-

- o ETRId 2-

- iF IEREELFD-T-

[ For Windows 7 ]

@ [Start] — [ Computer ] — [Search] to serach “usbser.sys”.

Keyin “usbser.sys”

56503 VOSTRO_Q32
FFaA> b

EoFv

a-Jvo

s e

2> bO—)L L

FIARET U S~

BEDTOIS A

ANLTESR—
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Notice for first time connecting to PC
@ usbser.sys” will be found and copy this

file to below folder. e e -

C:/Windows/system32/drivers
or D:/Windows/system32/drivers

@ Power on both the MODEL308 and the PC

[Start] — [Setting] — [ Control Panel ] — —
— [System] — [ Hardware ] e o Hm &
— [ Device Manager] T

. ¥ Bab7-H PEIR—
R 1= =TT FIA T

If you can find the the Model of MODEL308, s 5
it means the Programmer has been recognized
and please remember the USB port.

T MAL5 Programimer [DOME]

Please click the icon to run the control Software. P TSR R FAT
. B Eob-
N | A== AP LR 3 -3
+ i BRI -
. IPm -3

Program
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MODEL308 Control Software
(Universal Control Program)
Operation Manual

This chapter explains how to use this Universal Control Program of MODEL308. This
Control Software will be updated without giving notice due to improvement. Any
effects will be fixed by new software.
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MODEL308 Control Software (Universal Control Program)
MODEL308 Control Software (Universal Control Program )

Outline

MODEL308 Control Software is suitable for MODEL308.
Main features:

(D MODEL308 can be controlled by the same software.

@ All the informations of programming can be found on the main screen.

(3 According to the GUI, you can easily program IC, edit buffer and set the parameter
including the Partiton for NAND.

@ You can quickly reload all the programming settings by project file.

® You can set the lot number and get the report by lot function.

® You can clearly confirm the operation status by log function.

(@ With newly-developed 'Con-current programming method' start to program
devices per site. Programming time is significantly shortend by this method for
auto handler.

% Operating Environment %
Please follow the “Recommanded PC Requirments” to use this software, otherwise we
can not guarantee all the function is correct.

2¢ Notice
(D Please close the control software before power off the programmer while the job is
finished.Otherwise the communicating will be failed and maybe cause a wrong
operation.
@ Please install the suitable Module before running the control software and the
Modules must be same for MODEL308 to avoid breakdown.
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MODEL308 Control Software (Universal Control Program)
Start Running the Universal Control Program

After installation was finished, please double click the icon on the desktop.

|

) WmeHander

[Eena |

[ Connect a programmer Dialog box ]

Automatically detect and connect the programmer (Online mode)

On the dialog box [Connect a programmer], choose [Connect] and click [Select]. If the
programmer already has been connected to PC correctly, it will be automatically
detected and the main screen of software will show [ONLINE], otherwise it will be

In Demo mode, control software performs simulation operation with
programmer not connected. Do not activate Demo mode when operating
programmer.

Demo mode for MODEL 308

On the dialog box [Connect a programmer], choose [Model 308] and click [Select],the
control software will be forced to MODEL308 Demo mode and [DEMO] will be
showed on the main screen of software.
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MODEL308 Control Software (Universal Control Program)

AutoHandler mode

On the dialog box [Connect a programmer], choose [Use handler] and click [Select],
the control software will be forced to handler mode and the status of programmer is
[OFFLINE] until you start the Autohandler software to control it.

Do not connect programmer
On the dialog box [Connect a programmer], click [Cancel], the control software will

force to [OFFLINE] mode.

M308-020A-K2
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MODEL308 Control Software (Universal Control Program)
Description of the main screen

Here will introduce the function of the main screen and the sample is MODEL308

Description of the main screen (MODEL308 Main Screen)

MDTitle bar 3)Tool bar

2Menu bar 1 ®)Data file ®Device information

File Edit ogrammer Device Operation mode Vie Help

P EHR Y YLD ES ?

Load Save

py Blank Verify Prog H Cont

r Project information ——— Data file Device information \
File name | test512M 0306 W Device | 529GL512P10TFIRL [ Spans*n ]
File size | 4000000h Package | TSOP 14mmx20mm
STM DSBGDACLh Rdaptor | HOSOT-2004A [ SU400-4BDF/3V ]
CRC32 2361CFF1h Code

Hote | *ksskekxds
r Yrogress conditions

Lot size [i]

Programmer state —
Pass a
soop BLANK ONLINE
- . o Start
Fail Clear Statistics AVG. Time 0 sec

~ Log window

Site #2

[0-3FFFFFFh] cr§-ccitt=0000EBCCh -
[2017/03/15 1&:53:58]
Checksum in range of [0-3FFFFFFh] sug=D9B6DAC1h crc32=2361C

[0-3FFFFFFh] crg-ccitt=0000308Rh

[2017/03/15 16:54:10]
File loading succesaful.
[2017/03/15 16:54:32]
Saving file : [C:\programmerimél4\supfortidataitest5laM 030€
Saving file successful!
[2017/03/15 16:54:57]
Loading file : [C:\programmer\m404\supporti\data\test512M 03C
File format : Binary

Buffer is erase with value FFh.

Swap bytes switch : OFF
\ y N [2017/03/15 16:55:08]

| o3 File loading sucgksaful. iv
£

174 \ Device size: 4000000h(§4.0MB)

@Project informations \ ©@Log window
@Progress conditions @Control panel
®Socket status {DStatus bar

@ Title bar
Display the version of the software.

@ Menu bar

There are below 7 menus, [File], [Edit], [Programmer], [Device], [Operation mode]
[View], [Help].

Each menu contains many functions for operation, example you can select IC by click
[Select device...] under [Device] menu.
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MODEL308 Control Software (Universal Control Program)

[File]
» [Load Project..]

» [Save Project..]

e [Load file to buffer]

» [Save buffer to file]

» [ConfigJ(Initial setup for system and password is required)
» [ Control of a log file]( Setting of log file)

» [Pass/Fail counter ](setting of counter)

» TVerify check sumJ(confirm the checksum)

» [Deletion of the data file

» [Open log file]

» [Recent File]

o [Exit]

[Edit]
o [Edit buffer]

[Programmer]

o [Buzzer]

o [Self test]

o [Clear data] (clear the BufferData of programmer)

o TFilelist] (File list in buffer)

e TLED check]

» [Handler position](For Auto Hadler :Number the programmers)

[Device]

e [Select device]

» [Operation options.. ]

o T'Writing of unique IDJ(For Auto Handler)

o [Copyl,IBlank check],l'Verifyl,TProgram],lErase],l Cont]

[Operation mode]
For mass production and the function can be changed by click [Copy], [Blank check],
[Verify], [program], [Erase], [cont].

[View]
e [Toolbar]

40
M308-020A-K2

MINATO ADVANCED TECHNOLOGIES INC.



MODEL308 Control Software (Universal Control Program)

» [Status Bar]

» [Function progress bar ](Special : Show the progress at the time point when error
occurs)

» [Contact check NG mark](Show/hide error mark in the case of Contact error)

» [Handler NG code](For Auto Handler: OFF state normally)

« [SUM](Display method of SUM)

[Help]
» [ About UniversalControl Program....]

o [V _upl (Version up) (Password is required)
« [Choice of the language ]
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MODEL308 Control Software (Universal Control Program)

@ Tool bar
17 tools were divided to 6 groups [Project], [Data], [Device], [Operation],
[Connection], [Version].

[1] Project

Lgad | oad Project

P> Open the Project file which already exists.
Sgve  Save Project

>  Save all the setting to a new Project file.

[2] Data

ar Load file
Load | oad the programming file to the buffer of programmer.

H Save file
save  Save the contents from the buffer to PC as a file.

Buffer Editor
Open Buffer Editor

[3] Device

@e SelectIC
Eﬁtgct Select the IC P/N

&+ Option
Option  Custom-tailor the operation of device

Access Method

[4] Operation

48 COPY
copy  Copy data from IC to buffer.

Wl BLANK
il
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Verify

QYE
Prog

e

Erase

]

Cont

MODEL308 Control Software (Universal Control Program)
Check whether the IC is empty.

VERIFY
Compare the data of IC with Buffer.

PROG
Write the data of Buffer to IC.

ERASE
Clear all the contents of IC

CONT

It’s a continuous function of ERASE, PROG and VERIFY.

[5] Connection

Connect
Connect the programmer with to PC.

Disconnect
Force the programmer be offline.

[6]Version

? Version
Show the version and copyright of software.

@ Project information
They are useful for project management.

Project information

Proj File name | minato
Project ID project_001
Note

Test Version

® Data File
Show the file name, size, CheckSUM and CRC.
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MODEL308 Control Software (Universal Control Program)

(CheckSUM and CRC are calculated according to the buffer not file, so they will be
changed after loading another file or editing the buffer)

Data file

File name | test512M 0306
File size | 4000000h

SUM DSB6DAC1h
CRC32 2361CFFlh

® Device Information
Show the P/N and package of Device, and the adapter P/N which should be used.

Device information
Device S29GLS12PxxTFx01 [ Spansion ]
Package TSOP 14mmx2Omm

Adeptor | HOSOT-2004A [ SU400-48DE/S3V ]

Note HEHE T R R T E

@ Progress Condition

Show the counter of Pass/fail/total and all the numbers can be cleared by click [Clear
Statistics] button.

Clicking [lot size] button you can set all the parameter about the lot.

Progress conditions

ass 5

4
Fail 1 Clear Statistics AVG. Time 0 sec

Socket status
Show the Site number and the status of each socket.

MODEL308 is showed 2 site (8 Sockets).

Site #1 Site #2

Il
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MODEL308 Control Software (Universal Control Program)

The Progress bar shows the status of every operation.
Example: while you run PROG, it will show PROGRAMMING 0—100%,
VERIFYING 0—100%.

@ LogWindows

Log window contains the flow-control progress information about almost every
operation and the log information will be saved automatically. (You can define where
or how long it will be saved)

r Log window

Site #1 Programmer is connected. -

[2011/03/31 20:05:20]

Site #1 ERR send[C:\programmer\M404%\support\proséCBE2.bin]

[2011/03/31 20:05:21]

& dewice isn't chosen!

[2011/03/31 20:08:09]

Selected device : Spansion 329GL512F10TFIRI.

[2011/03/31 20:08:11]

Checksum in range of [0-3FFFFFFh] sum=FCO000000h crc32=18F&:
[0-3FFFFFFh] crc-ccitt=EBCCh

m

[2011/03/31 20:09:08]

Checksum in range of [0-3FFFFFFh] sum=D9B&DAC1h crc32=2361C
[0-3FFFFFFh] crc-ccitt=306Rh

[2011/03/31 20:09:10]

Checksum in range of [0-3FFFFFFh] sum=D9B&DAC1h crc32=2361C
[0-3FFFFFFh] crc-ccitt=306Ah [

a4 m L3

Control Panel

Additionally, the in-service operation mode will be displayed in ONLINE state during
operating process, and the normal display status would be restored upon the
completion of operation.

Programmer atate Running Programmer state
stop ‘ st ‘ ONLINE :> ONLINE
Start

You can confirm whether it is running by not only the “Programmer state” but also the
“Socket status”.

@ Status bar
It's a simple description of menu or function and it will be displayed by moving mouse
to certain button. It also can be hided by selecting [View -> Status Bar]
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Basic Operation
This chapter will describe below operatios.

Power Setting

Selcet device

Copy

Erase

Blank check

Program

Verify

Cont

Contact and ID check

For MODEL308 you must use the special control software to operate.
Here just describe the operation of MODEL308.

M308-020A-K2
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Basic Operation

Basic Operation

Power setting

Here will describe the sequence of power on.

You should avoid the noise caused by other machine like electric generator
and welding machine.

»¢ Notice

Making sure to put MODELZ308 at a level palce, no shocking

Using dedicated plug seat as AC power

Recommended using 3P plug seat which contains GND

Making sure the power switch are off, then connect the power cable to plug seat.
No IC and Adapter inserting the programmer while power on. (Avoiding be
damaged)

R E

Power on sequence

(@ Making sure no IC is in the SOCKET, then turn the power switch to on.

@ About 1 minute later the status LED will turn green and it’s ready for connecting to
PC.

® Click the icon of MODEL308 control software. Normally choose[Connect] to
automatically connect to PC.

@ The IC which is selected last time will be called out automatically on the basic
screen.

® Basic Screen

Ele Edt Programmer Dewica Opération mode Xiew Help
e o @ @ Al | o 3 =
SEEHRYELS YRBNVERERX S
T a5 0% 1 Dan 1

12

Dot
Sevd
-
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Basic Operation

Select Device

Click [ Select device ] to choose target IC.
You can select device by choosing [Device] — [Select device] or click below button

on the tool bar.
,-o'\-
B

The window for selecting device

Tab (D ANl @ Only selected type @ Only selected manufacturer)

e

I 5. 10 Only selected type ] "N Only selected manufacturer
Titlefbar ~_ ‘

Manufacturer | Name Type | Package Spec Adapter ‘ Pin | Veo S_Ver. P Ver. ‘ -
Im El&J32M Flash 32M-bit (x16) * — * * 27-38Y V10000 W1.04 1o
IR ELPDA EHEO1C031PB NAND 512M-bit (x8) FBGA 14mmee14mm -0.85 HO60T-2322 215 1.7-1.85V V13600  W1.04 (|
D- ELPIDA EHEOD1C021PB NAND 512M-bit (x8) FBGA 14mmx14mm -0.85 HO60T-2322 215 1.7-185V V13800 V1.04
1B ELPDA EHFD1CO31MA NAND 512M-bit (x8) FBGA Smmx&mm -0.85 HO60T-2228 130 1.7-185V V13600 V104
I ELPIDA EHEO1E031MA NAND 512M-bit (x8) FBGA 9mmx&mm -0.65 HO60T-2223 130 17195V V136800 V104
D- ELPIDA EHEQTCOTTHA NAND S12ZM-bit (x8) FBGA Smmx&mm -0.65 HOE0T-2228 130 1.7-1.95v  V136.00 V1.04
IRl ELPDA EHFD1COZZMA NAND 512M-bit (x8) FBGA Smmx&mm -0.85 TES551 HO60T-2228 130 1.7-185V V13600 V104
1B ELPDA EHFO1CO21MA NAND 512M-bit (x8) FBGA 9mmx&mm -0.65 TES551 HO60T-2223 130 17195V V136800 V104
1Bl ELPDA EHFOO20A1MA NAND 512M-bit (x8) FBGA 13mmee10.5mm -0.8 TES551 HO60T-16934 137 17185V V13800 V104
D- ELPIDA EHFO030ATMA NAND 512M-bit (x8) FBGA 13mmx10.5mm -0.8 TES551 HOS0T-16834 137 1.7-185v V13600 V1.04
1B ELPDA EHFO1CO11MA NAND 512M-bit (x8) FBGA SmmxBmm -0.65 TES551 HO60T-2228 130 1.7-185V V13600 V104
1Bl ELPDA EHEO1C041PB NAND 512M-bit (x8) FBGA 14mmee14mm -0.85 TES551 HO60T-2322 215 1.7-1.85V V13600  W1.04

I C I i St D- EON ENZBGLZ58L-xZIP Flash 256M-bit (x16)  TSOP 14mmx20mm — HOS0T-20044 56  3.0-36V V1.36.00 V1.04
[kl eon ENZ9LVE40Bx-x BT Flash B4M-bit (x16) 4BTFBGA Smmx8mm — H35C3-15574 45 3.0-38V V13200 V104
Bl Eon EN29LVE40Tx-xxB ot Flash B4M-bit (x16) 4BTFBGA Smmx@mm — H35CS-15574 48 3.0-38V V13200 V104 -
Select: MXIC MXZSGL128ELTZx-0xx Flash 128M-bit (x16) TSOP 14mmx20mm — HOS0T-2004A 56 2.7-3.6V V1.00.00 V1.04

S h
carc | cancel
= - e ——— |

Key in the IC P/N OK

Show devices in order
Clicking title bar the device will be put in alphabetical order.

Scroll bar for device list
You can find all the supported devices by moving the scroll bar on the right sidebar.

Cancel selecting
Clicking [Cancel] button to give up your selecting.

M308-020A-K2
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Basic Operation

Confirm the device
While you clicking the device, all the informaitons will be displayed for your
confirming.

WA I -1 MUD- 203,
529 =01 ash M-boit (21 6) TSOP 14mmx20mm HOS5-20042
SPAG! 51 PP TR TEOP 1dmmyNmm

o4 au-aov
30-35Y

HAA-20N4 4, R AN-FARV

All the informations of the device you have selected ar;\

displayed.

Select: Spansion S29GL312PxTFx02 Flash 512k-bit (x16) TSOP 1dmmx20mm HO5-20044 56 3.0-36%

&
«

Clicking [OK] button to confirm your selected device and then the device will be
called out and all the settings are updated.

> Notice>
The buffer memory will be initialized after selecting device.

Methods for searching device

@

Wanufacturer Name Type [ Package Spec. Adapter [ pin [wee S _Ver. PVer |~
- ElAJ2H Flash 321-bk (16) ¢ — . + o 273ev vioooo vied [
[T EHEO1C031PB NAND 5121t (8)  FBGA 14mmctdmm -0.65 TESSS1 HOBOT-2322 25 1748V VI V104 I
[m[ EHEO1C021PB NAND 512W-bit (8)  FBGA 14mmctamm -0.65 TESSS1 HOBOT-2322 215 17495V V13600 V104

[m[ " L EHFO1CO31HA NAND 512161 (x8)  FBGA Smmeamm -0 65 TESSS1 HOBOT-2228 130 17495V V160D VI0s

M epoa EMEQTEOS1MA NAND 5126 (x3)  FBGA 9m TESSS1 HOBOT-2228 13017495V V60 ViD4

M EPA EHEQ1CO11MA NAND 5121t (x3)  FBGA O TESSS1 HOBOT 2228 120 17495V VIGO0 VI04

[ L EHFO1C022HA HAND 5121061 (xB)  FBGA o 065 TESSS1 HOBOT 2228 10 174985V V600 Vi04
[T EHFO1C021MA NAND S12U-bit (<8)  FBGA SmmiBmm -0.65 TESSS1 HOBOT-2228 130 17185V V13600 V104

[m] L EHFO020A1MA NAND 512468 (x8)  FBGA 13mme10.5mm 0.8 TESSS1 HOBOT-16334 137 17-195V V13600 V104

[m] " L EHFO030A1MA NAND 512068 (x8)  FBGA 13mmx10.5mm -0.8 TESSS1 HOGOT-1633A 137 17-195V V13600 V104

M epoa EHFO1COTTMA NAND 512061 (x8)  FBGA 9mmeEmm -0 65 TESSS1 HOBOT-2228 13017495V V160 ViD4

M EPA EHEQ1C041PB HAND S12W-61 (x8)  FBGA 14mmxidmm 065 TESSS1 HOB0T 2322 215 17495V VI3600  VI04
Ceeon EN29GLIS6LAZP Flash 25614-bi (x16)  TSOP 14mmc20mm — HOSOT-20044 56 3036V V13600 V104
CIkeon EN2SLVB40Bx-oxBToc  Flash B4M-bit (x18)  48TFBGA BmmxBmm — HISCSISSTA 48 3036V V13200 VI04
[CIMeon EN29LVB40Ti-cxBTxx  Flash 64M-bit (x16)  48TFBGA 6mmkgmm — HISCSISSTA 48 3036V V13200  VI04

® Select: MXIC HX29GL12BELT2x00c Flash 128-bit (x16) TSOP 14mmy20mm — HOSOT-20044 56 2.7-36V V1.00.00 V1.04

1 BT ‘ !K Cancel

@ Key in part of the device name
Key in the device P/N in [Search] Box, the searching will be narrowed down.
(example: key in”29GL” then just ICs containing ”29GL” will be listed)

Search | 290L

[Search] Box is suitable for all Tabs ([All] [Only selected type] [Only selected
manufacture]) and it’s case insensitive.

@ Only selected type
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Basic Operation

Click the tab of [Only selected type], you can more easily find the device by select the
[Type] and [Sub type], because just the type you have defined will be listed.
(example: Set [Type] as”Flash”,and [Sub type] ”512M-bit (x16)”, then just 512Mbit
Flash will be listed)

™ an &3 Only selected type l ¥ Only selected manufadurer]

Type | Flash j Subtype | Flash 512M-bit (x16) j

If there is no device being displayed, it means this type has not been supported.

@ Only selected manufacturer
Click the tab of [Only selected manufacture], you can choose the manufacturer of
device, and then just devices produced by this manufacturer will be listed.

» AIl] "N Onlyselected type . ® Only selectsd manufacturer l

Manufacturer |5pansiun j

> If there is no device being displayed, it means Device for this manufacturer has not
been supported .

@ Close the Select device window
Click [Cancel] button or =] to close this window and no device has been selected.
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Basic Operation

COPY
Using the COPY button to copy data from IC to buffer of MODEL308.

Notice before COPY !

1. Please calculate the checksum before copy to confirm whether it is correct.
2. Just #1Socket can be used for COPY and make sure no IC in others Socket.
3. If the direction of IC is not corrected, the device may be damaged.

The operation Sequence for COPY
1. Select the correct device

2. Put IC into #1Socket gf
3. Click COPY button “

Click START (COPY) button, then it will run and while it’s fininshed the LED turn
green or red (Copy ok: Green; Copy fail: Red).

MINATO 0 8cANG PROGRAMMER

MINATO

In regard to unused, from #2 to #8 sockets, the red LED goes ON.

o1
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Basic Operation
Flow chart of COPY

Select device

»
)
A

y

Put IC into
SOCKET#1

h 4

[ Push down the Lock Lever ]

|

N

Copy

|

| copy |
v
| VERIFY |

| PASS/FAIL LED

A

[ PickupIC |

M308-020A-K2

Supplement

To modify the setting in "Device operation
option™, skip the VERIFY after COPY. When
doing so, please be sure to perform data
validation using SUM and CRC32.

MINATO ADVANCED TECHNOLOGIES INC.

52



Basic Operation

ERASE

For EEPROM and FLASH devices, the data can be erased by click ERASE button.

Notice before ERASE !
The device which is failed by contact checking or ID checking must be removed from
the module before ERASE, otherwise may damage.

The operation Sequence for ERASE

1. Select the correct device
2. Put the device into#1~#8Socket,

e ]
3. Clickbutton e

> This function will start automatically if you have put devices into all the

#1~#8Socket. If there is no IC in some socket, the warning message “contact fail”
will display and the SOCKET LED turn red, the operation is discontinued.

4. If you want to continue this operation, Please click button again.

5. While it’s fininshed the LED turn green or red (PASS: Green; FAIL: Red)

6. Upon the replacement of device connected to socket, the ERASE Start button on
screen or the START button on the body of programmer could be used in addition
to above-noted toolbar buttons when performing ERASE operation again. Please
use appropriate operation method.
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Basic Operation
Flow chart of ERASE

[ Select device ]

»
)

h 4

Put IC into Socket

|

[ Push down the Lock Lever ]

l Fail Stop
Empty socket is in existence. Fail Socket is
] »| detected
Erase throuah connection

l All sockets are connected with device.

<
<

| ERASE |
v

| BLANK |

| PASS/FAIL LED |

- ! Supplement
[_PickuiC ] To modify the setting in "Device operation
| option™, skip the BLANK after ERASE.
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Basic Operation

BLANK

Click BLANK button to confirm whether the content of I1C is empty.

Notice before BLANK !
The device which is failed by contact checking or ID checking must be removed from
the module before blank check, otherwise maybe be damaged.

The operation Sequence for BLANK

1. Select the correct device.
2. Put the device into#1~#8Socket.

3. Click BLANK]|button Blank

2 This function will start automatically if you have put devices into all the #1~
#8Socket.

If there is no IC in some socket, the warning message “contact fail” will display and
the SOCKET LED turn red, the operation is discontinued.

4. If you want to continue this operation, Please click button again.

5. While it’s fininshed the LED turn green or red (PASS: Green; FAIL: Red)

6. Upon the replacement of device connected to socket, the BLANK Start button on
screen or the START button on the body of programmer could be used in addition
to above-noted toolbar buttons when performing BLANK operation again. Please
use appropriate operation method.
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Basic Operation
Flow chart of BLANK

[ Select device. ]

»
P

A4

[ Put IC into Socket. }

\ 4

[ Push down the Lock Lever. ] Fail Stop

Fail Socket is detected
through connection
inspection.

l Empty socket is in existence.
b | >

Blank

<
<«

l All sockets are connected with device.

BLANK

v

PASS/FAIL LED

[ Pick W IC |
|

M308-020A-K2
MINATO ADVANCED TECHNOLOGIES INC.

56



Basic Operation

PROGRAM

Write the data from buffer to IC.

Notice before PROGRAM !
The device which is failed by contact checking or ID checking must be removed from
the module before program function, otherwise may be damaged.

The operation Sequence for PROGRAM

1. Select the correct device

2. Put the device into#1~#8Socket
¢ E
Prog

3.Clickbutton L

2 This function will start automatically if you have put devices into all the #1~
#8Socket.

If there is no IC in some socket, the warning message “contact fail” will display and
the SOCKET LED turn red, the operation is discontinued.

4. If you want to continue this operation, Please click button again.

5. While it’s fininshed the LED turn green or red (PASS: Green; FAIL: Red)

6. Upon the replacement of device connected to socket, the PROGRAM Start button
on screen or the START button on the body of programmer could be used in
addition to above-noted toolbar buttons when performing PROGRAM operation
again. Please use appropriate operation method.

About the PROG operation supported by MODEL308.

MODEL308 enables programmer user to designate appropriate linkage operation
function.

This function could be designated with "Device->operation option" selection menu.
Example 1: BLANK->PROG->VERIFY

Example 2: ERASE->PROG->VERIFY

(Initial setting of PROG operation is
BLANK->ERASE->BLANK->PROG->VERIFY)

Please establish the setting following the operating instruction on Page 105.
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Basic Operation
Flow chart of PROGRAM

[ Select device. ]

»
>

h 4

[ Put IC into Socket. }

h 4

[ Push down the Lock Lever. ]

Fail Stop

l Fail Socket is detected
Empty socket is in existence. through connection
28 o :

& L inspection.

<
<«

l All sockets are connected with device.

| BLA¢NK —

| ERASE |
v
| BLANK |

t All the devices are blank.

| PROGRAM |

| VERIFY |
v

| PASS/FAIL LED |

_ ' Supplement
[ Pickupic ] To modify the setting in "Device operation
‘ option”, skip the BLANK and ERASE before

PROGRAM and the VERIFY after PROGRAM.
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Basic Operation

VERIFY

Compare the data between IC and buffer of MODEL308.

Notice before VERIFY !
The device which is failed by contact checking or ID checking must be removed from
the module before verify function, otherwise maybe be damaged.

The operation Sequence for VERIFY

1. Select the correct device
2. Put the device into#1~#8Socket

3. ClickVERIFY|button  Verits

> This function will start automatically if you have put devices into all the #1~
#8Socket.

If there is no IC in some socket, the warning message “contact fail” will display and
the SOCKET LED turn red, the operation is discontinued.

4. If you want to continue this operation, Please click button again.

5. While it’s finished the LED turn green or red (PASS: Green; FAIL: Red)

6. Upon the replacement of device connected to socket, the VERIFY Start button on
screen or the START button on the body of programmer could be used in addition
to above-noted toolbar buttons when performing VERIFY operation again. Please
use appropriate operation method.
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Basic Operation
Flow chart of VERIFY

[ Select device. ]

»
P

A4

[ Put IC into Socket. }

\ 4

[ Push down the Lock Lever. ]

Fail Stop
o ] Fail Socket is detected
Empty socket is in existence. through connection
» | inspection.

Verify

<
<«

lAII sockets are connected with device.

VERIFY
v
PASS/FAIL LED

( pick up IC |
|
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Basic Operation

CONT

After clicking CONT button, programmer will carry out ERASE -> BLANK ->
PROGRAM -> VERIFY automatically. The operation flow is different between
EEPROM & Flash and EPROM which can not be erased electrically.

Notice before CONT !
The device which is failed by contact checking or ID checking must be removed from
the module before cont function, otherwise may be damaged.

The operation Sequence for CONT

1. Select the correct device
2. Put the device into#1~#8Socket

s

3. ClickCONTputton ~ Cont

> This function will start automatically if you have put devices into all the #1~

#8Socket. If there is no IC in some socket, the warning message “contact fail” will

display and the SOCKET LED turn red, the operation is discontinued.

4. If you want to continue this operation, Please click button again.

5. While it’s fininshed the LED turn green or red (PASS: Green; FAIL: Red)

6. Upon the replacement of device connected to socket, the CONT Start button on
screen or the START button on the body of programmer could be used in addition
to above-noted toolbar buttons when performing CONT operation again. Please
use appropriate operation method.
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Basic Operation
Flow chart of CONT (For FLASH/EEPROM)

[ Select device. ]

»
»

\ 4

[ Put IC into Socket. }

A 4

[ Push down the Lock Lever. ]

Fail Stop

Fail Socket is detected
.| through connection
£ L inspection.

Cont

l Empty socket is in existence.

l All sockets are connected with device.

<
<«

| BLA¢NK —

| ERASE |
v
| BLANK |

ki

| PROGRAM | All the devices are blank.

v
| VEI%IFY |

| PASS/FAIL LED |

v
[ PickupIC ]
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Basic Operation
Flow chart of CONT (for EPROM)

[ Select device. ]

»
»

\ 4

[Put IC into Socket. }

A 4

[ Push down the Lock Lever. ]

Fail Stop

l Emot ket is i ot Fail Socket is detected
B mpty socket is in existence. | through connection

o | inspection.

l All sockets are connected with device.

P

<«

| BLANK |
v

| PROCiRAM |
| VEF\LIFY |

| PASS/FAIL LED |

v
[ Pick up IC ]
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Basic Operation

Contact check, ID check

Contact check

Contact check is to detect whether the position (direction) of device is correct or the
device is not damaged ,and this function is carried out before others operation. Since
there are various specifications of devices, some devices including microcontroller
does not allow carrying out a contact check, we will define it according to IC and there
IS N0 menu setting or button for Contact check.

ID check

ID check is to judge whether selected device is matches the actual device. For standard
device which has ID, this function will be added automatically and there is no menu
setting or button for ID check.
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Protect

Protect

Protect
The case, selected device has the lock-bit / sector-protect etc..., is able to set by
[Device operation options].

How to use PROTECT
[Device operation options] is opened by clicked [Device] -> [Operation option...] or

4

opies 0N toolbar.

Then, Display on the [Device operation options] window.

Device operation options x|

Device Rddresses
Device start Rddressibyte/hex):

Device end 2ddress{byte/hex)

Buffer start Address(byte/hex):

Insertion test

Contact check
ID check
Contact check STOF set

ID check STOP set

Command executicon
BLANK before PROGRAM
ERASE before PROGREM
BLANKE after ERASE
VERIFY after PROGREM

VERIFY after COPY

Sector Protection

Prutect:lncn

OE | Cancel 1

1. Protection checkbox I 2. Setting Protection Editor
3. Select Ruitton

O protect/Unprotect

=

Check the checkbox of [Protect/Unprotect] in Sector Protection.

2. Write the sector number you want to protect in the Setting Protection Editor.([non]
is default and protect sector is nothing)
Example: when you want to protect the sector number 2,3,15,16,17, you write
[2,3,15-17] in the setting protection editor.

3. Push [OK] Button.
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Function Description

Function Description

This chapter will describe below functions.

Load file

Save buffer

Buffer editor (Edit)
Project management

Lot management

Status of operation
Setting of programmer
Operation of programmer

The performance of MODEL308 is excellent due to below functions.

Here will introduce the operation and functions of software for MODEL308.
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Function Description

Load file

You must edit the data of PC and programmer before operation and device must be
selected before loading data.

Load file

Choose menu [File] -> [Load file to buffer] or click [Load] button = , then below
dialog box will be displayed.

Click [Browse] button, you can choose the file for operation and the file name will be
displayed.

The data will be loaded to buffer by clicking [Load] button.

Operation for Load file dialog box

| MDFile Name

| @Format Type File name | | Browss
Fumﬁhlmllhln Format (* BN} '| I

~ Agkditional operation

~——dp.| | [] swopbytes

[#] Eraze butfer betore londing
Ergse value | FF h

| @Buffer Offset I = Butfer offzet for bading ———————————————— |
(=) hone
L 4

- For Binary and Hex fis formats

O Posttive offzel

- For Hex file formads onby

) Megathe ofizet

) Automatic negative offset

@Additional Option
(Swap,Buffer Clear)
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Function Description

@ Select file name
Set the file name to [File name] Box by clicking [Browse] button.

> Default folder
The folder which you choosed last time will be set as default.

2 Format type
Indicate the file format which you will load to buffer by drop-down list of [Format

type].
You can choose Motorola (*.MOT), Intel HEX (*.HEX) and NO format (*.Bin).

® Additional operation

- Swap bytes

Before File loading the data will be swapped by bytes. (Both WordSwap and Bit Swap
are developing)

- Erase buffer before loading
Clear all the contents of BufferMemory (PC) before loading file and you can set the
value which you need to clear (The default value is FF)
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Function Description

@ Buffer Offset [Default as (None)]

Use buffer offset function to specify the offset address for adding the data read from
the file to buffer zone. The standard setting is "None". User needs to set the
compensation value when in use. The following settings are available. To specify the
start address of loading file by set the [buffer offset for loading].

None: The red file will be put into buffer memory without offset.

Positive offset: Store the data to buffer address where the read file address is provided
with offset.

Buffer address = Formatting address + Offset address

Negative offset: Store the data to buffer address where the offset is subtracted from
the read file address.

Buffer address = Formatting address - Negative offset

Automatic negative offset: Offset could be detected from the read file automatically
when this setting is enabled.

Buffer address = Formatting address - Negative offset

Additional for File Load

After loading file, the value of SUM and CRC32 will be updated on the main screen
and a message will be displayed for whether transfering the data to programmer
[Yes]/[No].

For SD buffer Memory, the data file can be saved as history and also can be cleared.
So there will be 2 kinds message:

>¢ Minato has no warranty for the data be saved in BufferMemory.
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Function Description
2 kinds message about Data File Load

The file is not in the history(not ever be used before).
o

UniversalControlProgram

&y OISR I ANEELETH?
' " [C:¥Programmer¥m404¥support¥data¥minato_8M.bin]

BN | wnam

= =1 = W

The message means this file did not been used before and you want to transfer the data
to programmer, please click [yes] button.
This message will also be displayed while you want to clear the history.

The file is in the history (ever be used before).
E)

UniversalControlProgram

f ) . [C:¥Programmer¥man4¥support¥data¥minato_8M.bin] [ERIC#F
& BLFET!

TOASTCI7AIVEEALETH?

(SUMBH —S LIRSS IEBESF THELFT )

LRV LNE(N) ‘

The message means this file had been used before and please click [No] button
without loading data to programmer again. So it will save the setting time. If you want
to transfer again, please click [Yes] button.

Close the Load file window
Click [Cancel] button or =] to close this window without change of the data.
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Function Description

Save buffer

The data in buffer editor or copyed from IC can be saved to PC as a file.

Choose menu [File] -> [Save buffer to file] or click [Save] button =l ,then the
dialog box will be displayed as below.

Click [Browse] to set the file name and folder to save.

According your request to set [ File name ], [ Fomat type ], [ Advanced save options ],
[ Additional option ].

Save buffer dialog box

Save buffer

® File name File name | 512_0306 BIN Elrowsel

Format type |No Format (* BIN) j

@ Format type

Advanced save options

. - Additioral option
®Add |t|0na| Ope ratl on Buffer start | 0000000000 h |7D Swvap hytes AH Save

\ Buffer end | 0OO04001FF h

Cancel

@ File name
Set the file name in the [File name] Box by clicking [Browse] button to a folder.

> The folder which you choosed will be set as default.

(2 Format type
Indicate the format of file which will be saved by drop-down list of [Format type].
You can choose Motorola (*.MOT), IntelHEX (*.HEX) and NO format (*.Bin).

(3 Additional operation

Swap bytes

Before saving File the data will be swapped by bytes.(Both WordSwap and Bit Swap
are developing)

Buffer start/end
If you just want to save part of the buffer data to a file, you should set the address of
[Buffer start] and [Buffer end]. And the address should be byte address.
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Function Description

Save buffer

Click [Save] button to save file and the (SUM.”CRC32) value will be updated on
the main screen.

A message will be displayed for whether transfering the data to programmer
[Yes]/[No].

And there will be 2 kinds message about the history.(Refer to Load file)

Close the Save buffer window
Click [Cancel] button close or == to this window without change of the data file.
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Function Description

Buffer Editor (Edit)

By clicking Editor button you can choose various tool including Intialize buffer, find
text and edit, etc.

Menu [Function] [View] [Help]
Toolbar [Initialize] [Edit] [Find - Replace] [Jump] [Mode] [Check SUM]
[Version]

Notice about data transfer

Buffer Editor is a tool of Buffer Memory operation. During actual operation of device,
it's essential to transfer the data to the body of programmer upon the completion of
buffer edition.

Please referring tol COPY | or l'Load File].

Editor Window

MDMenu bar

@& — BufferEditor
\ BFunction  Miew Help
_— EREREREER
@TOOI bar € Program Memary l O Data Mgmnry]

0000000000 03 06 OC 18 30 60 CO 03 06 OC 18 30 60 CO 03 06 PP TR s B i‘
Qooooooo10 0C 18 30 6D CO 03 06 OC 18 30 60 €O 03 06 0OC 18 [P R A B A

i

i

B
<3

Qoooooo0z0 30 60 CO 03 06 OC 18 30 60 CO 03 06 0OC 13 30 60 0°h....0d....0°
Qoooooo030 CO 03 06 OC 18 30 60 CO 03 06 OC 18 30 60 CO 03 J N D RN S
Qooooooo40 06 OC 18 30 60 CO 03 06 OC 18 30 60 CO 03 06 OC I A SR S
Qoooooo0s0 18 30 60 CO 03 06 OC 18 30 60 CO 03 06 OC 18 30 s R s R
W CO 03 06 OC 18 30 60 €O 03 06 OC 18 30 60 CO P PR R PN A |

ooo70 03 06 OC 18 30 60 CO 03 06 0OC 18 30 60 €O 03 06 Y B RN | R T
@Data area Qooooooos0 0C 18 30 60 CO 03 06 OC 18 30 o0 €O 03 05 0C 18 L0t he . 0the.
Qooooooos0 30 60 CO 03 06 OC 18 30 o0 CO 03 06 0C 18 30 &0 0'h....0%h.. .00
Qooo0000AD CO 03 06 0OC 18 30 60 CO 03 06 OC 18 30 s0 CO 03 ho...0vh... 00 h.
Qoo00O000ED 06 OC 18 30 60 CO 03 06 OC 18 30 60 CO 03 06 OC R B SR B SR
Qooooooo0Co 15 30 60 CO 03 06 OC 18 30 60 CO 03 06 OC 18 30 RS PR T S ]
Qooooo0o0D0 60 CO 03 06 0OC 15 30 60 CO 03 06 0OC 18 30 60 CO A PR R PN A |

00000000ED 03 06 OC 15 30 &0 CO 03 06 OC 18 30 60 CO 03 06 [P 'B SRR B
oDoooo0oFo 02 18 30 60 CO 03 06 0OC 18 30 60 €O 03 06 OC 18 P R s o -
Ready / Buffer size: 4096.0 kBytes

—
@ Status bar
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Function Description

@ Menu bar
There are 3 menus about Buffer Editor: [Function], [View], [Help] and each menu are
defined as group.

[Function]
Contains all the related tools

[View]
To change the Toolbar, status bar, Byte&Word displaying status.(Toolbar can not be
changed)

View as Byte
Using byte as the unit to view the content of buffer by choosing [View] -> [Byte] and
the data will not be changed.

The default unit of Buffer Editor is byte.

[Fglwaginlg] 1Ly He
» |oolbar
- atus ar
« Byte
o hen or
| ooo0o00o0000 03 06 OC
View as Word

Using word as the unit to view the content of buffer by choosing [View] -> [Word]
without changing the data. It will return byte mode while you open Buffer Editor
again.

000000000s 150C 6030 03CO OC

@ Tool bar ( EditWindow )
There are total 13 tools be divided into 7 groups. The groups are [Initialize], [Edit],
[Find-Replace], [Jump], [Mode], [CheckSUM], [Version].

[1] Initialize

B> Erase
The data of BufferMemory will be cleared as“FFh”.

Fill random data
To fill random data to Buffer Memory.
Fill block

74
M308-020A-K2

MINATO ADVANCED TECHNOLOGIES INC.



Function Description
Using indicated data to fill the Buffer Memory of block.

[2] Edit

Copy block
Copy data from one block to another block.

Move block
Cut data of Buffer Memory from one block to another block.

[8] Swap data in block
Swap the data of Buffer Memory.
[3] Find=Replace

] Find text
To search certain content.

[ Replace text
To search certain contents and change them with other contents.
[4] Jump

Go to Address
Jump to indicated address.

K
|

i

[5] Mode

Edit buffer
The data can be changed in Edit mode.

View buffer
The data can not be changed in View mode.

[6] Checksum

Check SUM
To calculate the SUM-CRC .
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Function Description

[7] Version

? About
Indicate the version and copyright.

@ Data area ( Editor Window )

Display the contents of BufferMemroy and the default unit is Byte. There are at most 3
Tabs according to IC type. Clicking Tab to switch and the data of each Tab is
independent.

& Program Memory l € Data Memary

oooooooo00 O3 06 OC 18 30 60 CO O3 06 0OC 18 30 60 CO 03 06
Qoo0o00o10 OC 18 30 60 CO 03 06 0OC 18 30 o0 CO 03 06 0OC 18
oooo0o000z0 30 60 CO O3 06 OC 18 30 60 CO 03 06 OC 18 30 &0 u] .
Q000000030 €O 03 06 OC 18 30 60 CO 03 06 OC 13 30 60 CO O3 i....0°
oooooo0040 06 0OC 18 30 60 CO 03 06 OC 18 30 60 CO 03 06 OC
Q000000050 18 30 o0 <O 03 06 0C 18 30 60 CO 03 06 0C 18 30 u]
ooooooo0060 60 CO O3 06 OC 18 30 60 €O O3 06 0OC 18 30 &0 CO “h....00
Q000000070 03 06 OC 18 30 60 CO 03 06 0OC 18 30 &0 CO 03 06
ooooooo0o0s0 OC 18 30 60 CO 03 06 OC 18 30 &0 CO 03 06 0OC 18
Qooooooo20 30 60 CO 03 06 0OC 18 30 o0 CO 03 06 0C 18 30 60 [u]
Qooooo00AD CO 03 06 OC 18 30 &0 CO O3 06 OC 18 30 60 CO O3 L.o...00
Q0000000ED 06 OC 18 30 60 CO 03 06 OC 18 30 60 CO 03 06 0OC
ooooo000co 18 30 &0 CO 03 06 OC 18 30 60 CO 03 06 OC 18 30 u]
Qooo0ooooDo &0 CO 03 06 0OC 18 30 60 CO 03 06 0C 18 30 &0 €O “ha...00
O0000000ED O3 06 OC 18 30 60 CO O3 06 0OC 18 30 60 CO 03 06 P
Q0o00000OFD OC 18 30 60 CO 03 06 OC 18 30 o0 CO 03 06 0OC 18 A R s

@ Status bar

It’s a simple description of menu or tool and it will be displayed by moving mouse to
certain button. It also can be hided by selecting [View -> Status Bar] .

Description of tool bar

Erase BufferMemory (Editor window)
Clear the contents of BufferMemory by choosing [Function] -> [Erase buffer] or

[Erase] button Z

Then click [Yes] button to continue this operation and
all the data will be cleared as FF. (7 Jati
Click [No] button to cancel this operation .

) VIVE(N) ‘

Fill random data
Replace Buffer Memory by Random Data by choosing [Function] -> [Fill random
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Function Description

data] or clicking [RandomData] button :

Then click [Yes] button to continue this operation and
all the data will be replaced with Random Data.

Click [No] button to cancel this operation.

\9\ SV RT—STTEELETH?

HL(Y) LILAE (M)

Fill block with indicated data .
Initialize BufferMemroy with indicated data by choosing [Function] -> [Fill block] or
clicking [Fill block] .

button . And the buffer memory will be initialized by clicking [OK] button .

Fill block |
&) @ Indicate the address
CI: Elock start 0 hex OE | @ Fi” Strlng (ASCI I)
Block end | 3FFFFFF hex Cancel @ Fill string (HEX)

Fill =tring (Max le)
@ Aseii |Lgfo- Lgflo-i I
@ Hex |l2|3l2|6DClSSDSDDSDSDClSBDGDCDl I

You can indicate the address and data (ASCII or Hex) for filling on the Fill block
dialog box.

@ Indicate the address

Key in the address at [Block start] and [Block end]Box.
@ Fill string(ASCI)

Key in the ASCII data at [ASCII] (Max 16)

@ Fill string(Hex)

Key in the Hex data at [Hex] Box (Max 16)
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Copy
Copy data from one block to a indicated address.

Choose [Function] -> [Copy block] or click[Copy block] button and the operation
will start by clicking [OK] button.

Gopy block

Elock start | Z000 hex

EBlock end 3FFF hex
Destination IlDDDDD hex
he———

(D Block area
Indicate the address at [Block start] and [Block end] box.

(@ Destination address

Indicate the start address at [Destination] Box.

Close [Copy block] dialog box.

Click [Cancel] button to close this box without changing the buffer data.

> The data beyond buffer capacity cannot be copied.
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Function Description

Move
Cut Buffer data from one block to another block by choosing [Function] -> [Move
block] or clicking.

=

[Move block] button =* and data will be moved by clicking [OK] button.

Move block

Elock start 0 hex (1):4 |
® EBlock end FFFF hex Cancel

® Destination | Z0000 hex

The block area and address should be indicated before operation and the block data
will be replaced by FF.

(DBlock area
Indicate the address at [Block start] and [Block end] box.

(2Destinaton address
Indicate the start address at [Destination] Box and the unit is byte.

Close [Move block] dialog box
Click [Cancel] button to close this box without changing the buffer data.

2 The data beyond buffer capacity cannot be copied.
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Function Description
SWAP
Swap buffer data due to different request of byte order.

Choosing [Function] -> [Swap data in block] or clicking [SwapData] button &i .and
the operation will start by clicking [OK] button.

Swap data in block @

-
@ Elock start | E hex L1):4
Elock end JFFFFFF hex Cancel

FEWED Loos

@ Swap EZ-bytes inside 1l6-bit words

@ O Swap 4-bytes inside 3IEZ-bit words

O Swap nibbles inside bytes

@ Indicate the block area at [Block start] and [Block end] box.

@ Swap mode

Byte mode (change the byte order)

Exchange the data in buffer memory in Byte by choosing [Swap 2-bytes inside 16-bit
words]

Example:[A],[B], [C],[D] = byte swap—-> [B],[A], [D],[C] :[]ByteSize

Word mode (change the byte order)

Change the order of data in buffer memory with 4 bytes as a unit by choosing [Swap
4-bytes inside 32-bit words]

Example:[A],[B], [C],[D] =word swap—> [C],[D], [A].[B] :[]Byte Size

Nibble mode (Four-bit bytes exchange)
Swap of high- and low- nibbles inside each byte by choosing [Swap nibbles inside

byte].
Example:[00101101] ->swap nibbles—> [11010010] :[] Byte Size

Close [Swap data in block] dialog box
Click [Cancel] button to close this box without changing the buffer data.
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Function Description
Find text

Search data by choosing [Function] -> [Find text] or clicking [Find text] button
and it will start to find by clicking [Find] button.

Find text EI

r Text to find

® Hex 0308
Cancel
scii

irectico: rigi: ode
@ @ Forwar d O From cursor o A1l
r ire scope

You can indicate the text (Hex or ASCII) to find, direction and origin.

@ Find text

Enter retrieval data.

To Hex-side dialog box: Enter the data to be retrieved using hex data column.

To Ascii-side dialog box: Enter the data to be retrieved using Ascii character strings.

@

Direction

Indicate the search direction by choosing [Forward] or [Backward].
Forward Search from top address to bottom address.

Backward Search from bottom address to top address.

Origin

Indicate the start address by choosing [From cursor] or [Entire scope].
From cursor, From current cursor to search

Entire scope, Search all the buffer from top to bottom address.

Close [Find text] dialog box
Click [Cancel] button to close this box without searching.
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Function Description

Replace text
Search some data and replace them by indicated data.

Choosing [Function] -> [Replace text] or clicking [Replace text] button@' and
clicking [Replace] button to replace the text.

Replace text g]
r Text to find
Deplace
DFind Text IL —
Azeoii
Beplace with
H |anss]
@Replace text rseis [0
Direction Origin =] —
{2) Forvar d (& From cursor Qa1
0 Backward 0 Entire =sco pe @ Next
@Direction/Origin @ Mode

@ Find text

Enter retrieval data.

To Hex-side dialog box: Enter the data to be retrieved using hex data column.

To Ascii-side dialog box: Enter the data to be retrieved using Ascii character strings.

@ Replace text

Enter replacement data.

To Hex-side dialog box: Enter the data to be replaced using hex data sequence.

To Ascii-side dialog box: Enter the data to be replaced in the form of Ascii character
string.

@ Direction / Origin

Direction

Indicate the search direction by choosing [Forward]or[Backward].
Forward Search from top address to bottom address.

Backward Search from bottom address to top address.

Origin

Indicate the start address by choosing [From cursor] or [Entire scope].
From cursor : From current cursor to search.

Entire scope : Search all the buffer from top to bottom address.

@ Mode
Next : Display the confirmation screen once for every round of replacement.
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Function Description

the message reading "start next replacement?" will be displayed at the end of each

round of replacement. To proceed with the replacement, click [Yes]; to stop the
procedure, click [No].

All : Full replacement is to be performed without confirmation message.

Close [Replace text] dialog box
Click [Cancel] button to close this box without changing the buffer data.
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Function Description

Jump
Jump to a indicated address by choosing [Function] -> [Go to Address] or clicking

[Go to address] button £ and after clicking [OK] button it will go to the indicated
address.

Go to address

Indicate the address.
Key in the address at [Current address] Box and the Unit of address should be byte.

M308-020A-K2
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Function Description

EDIT MODE
Change the Buffer Editor to Edit mode by choosing [Function] -> [Edit buffer] or

clicking [Edit buffer] button £ .
The [Edit buffer] menu and button will be locked and the data at the cursor can be

edited. The data should be Hex (0-9, A-F)

The cursor can be moved by [ T][ | ] [«<] [—] button or mouse directly and the data
will be changed directly after editing without confirming message. The default mode
is [view] while opening [Buffer Editor] again.
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Function Description

View mode
Change the Buffer Editor to view mode by choosing [Function] -> [View buffer] or

clicking [View buffer] button .
The [View buffer] menu and button will be locked.

The default mode is [view] while opening [Buffer Editor] again.

M308-020A-K2
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Function Description

Check SUM , CRC and XOR

There are 7 types about SUM or CRC.(ByteSUM. WordSUM (L.ittle endian). Word
SUM (Big endian), CRC16, CRC32, CRC-CCITT. XOR)

SUM , CRC and XOR are useful to confirm whether the data loaded to buffer or write
to IC is correct.

Choosing [Function] -> [Check sum] or clicking [CheckSum] button to open the
calculate window and clicking [Calculate] button to calculate.

. - - -
Checksum

From address | 0 hex [x8
® CaICUIate range To address TEFFFF hex [xu8
Sum 1's Com. Z2"s Com.
Byte 1B36DACL E4C3Z53E E4C3Z53F
Wordi(Little endian) RS02D555 SEFTZRRE SEFTZRRT
1 Word(Big endian) A508Ces8E 58F735597 5E&F73558
@ SUM, CRC or XOR display

CRCz3Z T235B952

(2]
W
=]
[¥]
o
[

CRCl& 00004BOF
CRC-CCITT 0000REET

HOR 00000011

><¢ The calculate range must be indicated first.

@ Calculate range
Key in the address at [From address] and [To address] Box. Default address is for
whole range and you can calculate them directly by clicking [Calculate] button.

@ SUM, CRC and XOR display

After indicating the calculate range, clicking [Calculate] button to calculate the SUM ,
CRC and XOR.

> Default address is whole range.

Close [Checksum] dialog box
Click [Cancel] button or =] to close this box.

Close [BufferEditor]
Choosing [Function -> Exit] or clicking [Alt]+[F4] button to close this window.

Only Buffer Edit
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Function Description

After Buffer editing please pay attention to below message:

“A buffer memory is being updated! Do you do data transmission?” It means
whether you will update the data to programmer after edit. And the data will be saved
in Editor before you load another file.

Please note that the data displayed for buffer edition would be inconsistent with the
data imported/written into the device from programmer if such data are not transferred
to programmer. Imported/written-in data from programmer is the data acquired before
edition (transferred to programmer).

Save data to file
If you want to save the data to a file after edit, please Choose menu [File] -> [Save

buffer to file] or click [Save] button = :

((Save buffer))
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Function Description

Project Management

You can save IC P/N, data and settings to a project file for MODEL300 control
software and you can reload all of them for next operation.

Load Project File
Load project file to software by choosing [File] -> [Load project] or clicking [Load

Lpad
project] button=>
Then click [Open] button to load Project File.

Filename extension
It’s xxxx. ppf for project file.

Save as Project file

Save all the settings as a project file by choosing [File] -> [Save project] or clicking
Save
[Save project] button®>  and a [Project information] dialog box will be displayed.

The current programmer operation mode, device name, data file name and check sum
value etc. will be displayed in "Project->Confirmation" dialog box.

Protection of the file inthe SD : When the file is written into programmer, the
previously read files will be deleted if there is not enough SD memory capacity in
programmer. However, no file would be deleted if I'Protection of the file in the SD |
is enabled.

Project [ﬁj
Confirmation
Mode  BLANK
Device |W25Q64CVSFAP [Winbond ]
File minato_&M
Size 2000000 [ Protection of the file in the SD
SUM 1B36DAC1h
CRC32 |7235B952h
Cancel |

Please click on "OK" button after the confirmation of content.

The "Project information™ dialog box will be displayed.

The procedure for operation of "Project information™ dialog box screen is described as
follows.
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Function Description

[Project information] dialog box

Project information ﬁ'

Praj File name |Project_ppf Iﬂrowse |

@ Project file name || -
@ Project ID —
@ Note —

Save Cancel

@ Project file name

Key in the Project file name at [Proj file name]Box and it will be saved in the default
folder.The default folder is ”C:\programmer\m308\support\data”. And the default
folder will be changed as you selected last time.

@ Project ID

Key in Project ID at [Project ID] Box and it’s useful to confirm the project
information.

Max 16 Half-width characters is acceptable.

@ Note
Key in Note at [Note] Box and it’s useful to confirm the project information.
Max 28 Half-width characters is acceptable.
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Function Description

Lot Management

It’s easy to confirm the quantity and others status of operation according to Lot
management and a report can be created.

Lot Size
Click [Lot size] button to open [lot information] dialog box.

" Progress conditions

Lot size 10 ‘

Lot information

@ Lot S|Ze Lot size |20
@ Lot number Lot number |L0t=DDl @Re ort
@ Operator Operator operatorl p
@ Note Note 3rd Lot. (20pcs)<<Laser Markine=> I
@ Mode Programmer mode |[VERIFY ll
x| = | ®) Lot Start End
D Lot size

Enter the PASS number of devices (target value of operation batch) into [Lot size]
dialog box under "Lot information" dialog box.

@ Lot number
Additional confirmation of Lot. Key in it at [Lot number] Box. Max 23 Half-width
characters is acceptable. And the Lot Number will be used as the name of report.

@ Operator
Operator information for confirmation. Key in it at [Operator] Box. Max 23
Half-width characters is acceptable.

@ Note
Additional note for confirmation. Key in it at [Note] Box. Max 35 Half-width
characters is acceptable.

® Programmer mode
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Function Description
Choose the operation mode of operation programmer from "Programmer mode" in
batch management mode.

® Lot Start & End

[1] Lot Start

Click [Lot start] button to begin and a message “Are you sure to rest statistics
counters” will be displayed, accrording to you request to choose [Yes] or [No].
And except [Lot end]&[Report] button, all others item be locked.

X Notice

@ Upon the start of "Lot Start”, the
menu option/tool buttons would get
into "unable-to-select” (selection
prohibition) state. Programmer
operation is performed through the
[Start] button in operation board set
of main screen or the "Start" button
of programmer body.

@ All the tools button will be locked
while the operation is running, until it
is finished or clicking the Lot end]
button.

When the number of PASS devices reaches the batch size as set forth in "Lot
information” dialog box, the operation will come to an end; in such a case, the counter
dialog box turns pink to indicate that the number of batches is reached.

Lot end ——

r Progress conditions —

Pass 9 -

1a

Fail 7 Clei e |
[2] Lot End T =
Click [Lot End] button to stop Lot function and a —— =
message Lot mmber [Lot_001 e
“Do you deal with an end?” will be displayed. If perator  [operararl
you choose yes then a report will be created e ra v [ipcs)<closer Nerking>
automatica”y_ Programmer mode |VERIFT -
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Function Description
Close [Lot information] dialog box

Clicking =] to close this dialog box.
If you close this dialog box while Lot function is running, then except [Lot End]
button all others item are locked while you click [Lot Size] again.

Report

A report will be created automatically after a Lot is finished. The data and
programmer will be created in one report and different operation will be saved in the
same report for same day.

The folder for log report ”C:\programmer\m308\support\log”

Report name ” (Lot No).Log”

Single report during operation

Clicking [Report] button to create single report.

The folder for log report”C:\programmer\m308\support\log”

Reprot name (Lot No) repXXX.log” (XXX is consecutive numbers start from 000)
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Function Description

Operation Status

The counter and Progress can be checked easily.You also can check the elapsed time
of operation.

Count
You can find the PASS, FAIL, TOTAL counter on the Progress Condition Window.
And the count will be added up.

Progress Condition Window

r Progress conditions

Lot size 20

Pazs 9

D Count =

Fail ElliE AVG. Tine 0 sec

The counter shows the number of IC which have been Contact/ID check passed before
operation, otherwise the counter will not update. And just count for indicated
operations as your setting.

Clicking [Clear Statistics] button to clear the counter and confirming information will
display. [Yes] or [No].
You also can clear the counter for indicated operation.

Indicated counter

According to your request to set the counter for indicated operation by choosing [File]
-> [Pass/Fail counter].

Pass/Fail counter dialog box.

Pass/Fail counter dialog box

Enable Y BLANK VERIFY PROG ERASE CONT Total

Clear Clear | Clear | Clear ‘ Clear | Clear |

Operation Mode
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Function Description
Select the operation mode at <Enable> bar by corresponding CheckBox.

Add up the counter

When the operation value selected in dialog box after the <Enable> operation is
checked, the total would be displayed in both "Total" counter section and the
PASS/FAIL/Total in main screen.

Example: Cancel the checkbox of Blank

Page/Fail counter, E|
B : v
Enahle COPY O L VERIFY PROG ERALSE CONT Total
Pass ] El ] 1} i} ] ]
Fail a 3 a a a a a
Total ] 1z ] 1} i} ] ]
Clear | Clear | Clear | Clear | Clear | Clear |

After canceling the checkbox of BLANK Check, the [Total] quantity will be changed
to 0 and they will be 9, 3, 12 while you choose the checkbox again.

(DClear the counter individual
Clicking the corresponding [Clear] button to
clear the counter individually.

Enable CoPY ELANK VERIFY DROC ERASE CONT

@Clicking [All clear] button to clear all the
counter.

Close Pass/Fail counter dialog box
Clicking [Cancel] button or =i to close this dialog box and no setting is changed.

Others information

Showing on the main screen while operation is finished.

While the PASS quanity exceed the LotSize, the PassBox will turn to pink
automatically. And the operation still can be continued with Pink PASSBOX until the
statistics is cleared.
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Function Description

@Turn to pink @Progress bar
r Progress copdition
|1 Lot size 20
Pazs 21
32
Fail 11 Clear Statisticsé‘ L¥G. Time 1 sec

@Average elapsed time

The progress bar shows the status of operation on the Progress Conditon Window. It
Is composed by Pass quantity and Lotsize and while the Pass quantity equal to Lotsize,
the percentage will be 100% until statistics is cleared.

The average elapsed time will be showed at [AVG. Time] Box and the unit is (s)and it
will be cleared while the mode is changed.

Every operation elapsed time
The single operaton elapsed time will be showed as “time: xx s”on the LogWindows.

Log Record
All the information of operation will be showed on the LogWindows and the default

folder of saving the record is:
“C:\programmer\m308\support\log” or ”D:\programmer\m308\support\log”

(@ If you change the folder, the new folder will be set as default.
(@ Retention period of Log file

You can chage the retention period of log file by choosing [File] -> [Control of a log
file] -> [file retention period] Box. From left to right is [Month] .~ [Day].
Example) you hope to save it 10days, you should key in [0]/[10].

File name, "multp(XXXXXX).log” (XXXXXX is 6 number of the

year.month.day )
The default retention period is 7days.

[Control of a file

@Retention period
MDLog file path
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Close [Control of a log file] dialog box
Choosing [File] -> [Control of a log file] and clicking [OK] button on Control of a file
dialog box to save settings and close the dialog box.
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Function Description

Auto Start

"Automatic startup™ means that the operation would be automatically started without

pressing START button upon the completion of device setu
without pressing START button helps to prevent such error
semi-manufactured goods.

< Note

p. Recovering the device
as ingression of

Please have adapter mounted or removed after removing the device, or the

device may be damaged.

Version
UniversalControlProgram --+V2.06
MODEL308 Firmware -+-V1.25

1. Mount adapter and choose device in the same way as routine operation.
2. Select operation mode. Please choose operation mode from the list of [Operation

mode] in menu.

UniversalControlProgram

Help

| W T O
EBlank Verify Prog

File Edit Programmer Devife [ Operation mode | View

Lpad Save u H Copy =

2 e @ ) 4

e~ F Load Save E Elank Ops

- Project information —— Verify 1le
Proj File name | ***ssxkiisy Program Wit=
Project ID Doyl gl Erase L 26
Hote | #**xsssssxs ¥ Cont

EDIT DATA
1000000
07F61610h

LR S

BATAIAODh

r Progress conditions

Lot size g

Dzas= e. |

3. Choose auto start mode ON. Please make choice in the menu —[Programmer] —

[Auto Start]- [Mode] - [ON].

M308-020A-K2

98

MINATO ADVANCED TECHNOLOGIES INC.



Function Description
UniversalControlProgram

File Edif | Programmer | Device Operation mode View Help

Buzzer »

Auto start 3 Mode | v ON
Projfd

. OFF

Self test -
Proil z Self test Response time 3
Projk g e e e L il atoe Jooaools

4. Once the adapter is properly mounted, the socket LED would flash red. The failure
to flash red after the installation of adapter may be the result of poor contact.
Please re-install the adapter. If it doesn’t work, please confirm version about
“Universal Control Program” and MODEL308 firmware.

»¢Where auto start mode is TON |, the START key of programmer body is
disabled.

5. Set response time. The so-called response time refers to ['the time required to
achieve stabilization after the loading of devicel, lthe time required to remove the
device], and lthe time required to remove adapter |. Please make choice in the
menu —[Programmer] - [Auto Start]- [Response time] - [ON].

UniversalControlProgram —— -
File Edit | Programmer | Device Operation mode View Help
Buzzer 2
Auto start 3 Mode 3 |L
r Projed £
Self test i
Proj Self test Response time 3 Fastest
Projec Clear data | File size | 10001 Faster
Note ' STIM 07Fg) ¥ Normal
File list |
CRC32 BA7A] Slower
LED checl Slowest |
r Progrg —
o Default
Handler position
[

6. Set the device on adapter. Upon the completion of setting, LED would stop
flashing red but flash green.
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Function Description

10.
11.
12,

‘ (Flash) Please set the device.

‘ (Flash) The device has been set.

If the device flashes red upon the completion of device set up, the cause
may be poor contact. Please set the device up again.

Auto start would be performed if "red flashing" turns into "green flashing" for each
site.

If there are a small number of devices, please take down the adapter that is not in
use or press the START button on screen.

Upon the completion of read-in, LED would turn green (PASS) or red (FAIL).

@ «eoon FAIL

@ eporp PASS

Remove the device.
Please go back to "6." when the following device is used for operation.

Cease the auto start mode. Please make choice in the menu —[Programmer] —
[Auto Start]- [Mode] - [OFF].
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Programmer Setting
Programmer Setting

Buzzer
Switch the buzzer of programmer to ON/OFF and the setting will be saved.

> If you choose DEMO or OffLine MODE, the buzzer will not work.

Open Buzzer
Choosing [Programmer] -> [Buzzer] -> [ON] to open.

:El_ ¥1.34 — UnmiversalGontrolProer
Ei

%
= 5

il Edit BEGEEERTGES Device  Wiew

Clear data

Close Buzzer
Choosing [Programmer] -> [Buzzer] -> [OFF] to close.

Tirms T lm ammms | EEEEEELEEE

Clear Buffer
You can clear the contents of buffer (SD) by choosing [Programmer] -> [Clear data].

‘0. ¥1.34 — UniversalGontr
Eile  Edit Dreve ic
Eq?d San  Buzzer 3 T
I;}h‘} I;h‘ Clear data ]
| raterr infarmarion —

And for next operation you should load file to buffer
again.

Programmer
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Programmer Setting

Buffer Setting of PC

You also can change the Buffer memory
of PC( Default driveris C: or D:)

Log file path C:\programmer'm404'\ supporthlog Browse |

The working drive which operates data in the buffer memory |C: v

D Slave mode

If the space of C: or D: is not enough for IC, you can use removable device as buffer
memory.

(Recommend to use C: or D: as buffer memory.)

X Notice

@ Do not remove the removable device before changing to C: or D:, otherwise the
data maybe be damaged.

@ If you will use removable device, you must sure this device has been detected.

Slave Mode
e o S~
Transfer data to programmer Buffer (SD) Fiie zevension period | 0 /[ 7 Momsh / ey
directly (ignore Buffer Memory). Log file path |C:'\pzcgram&r'\m404'\suppc:l:t'\lc:g Browse
The working drive which cperates datz in the buffer memory m
Example) -

Normally we transfer data through PC Buffer to programmer buffer (SD) for large
density IC. If you choose Slave Mode, the data will be transfered to Programmer
buffer (SD) directly. (Save time)

(Recommend to use normal mode)

> Notice

* The Buffer Editor can not be viewed or edited.

* The Copy function of Buffer editor can not be used.

* Making sure you understand slave mode before using this mode.

102
M308-020A-K2

MINATO ADVANCED TECHNOLOGIES INC.



Operation

Operation

(@ Operation Mode

You can check the operation mode at the box of
SOKET Status Window. If no operation is running,
it shows [TEND].

@ Progress Status

The progress status of operation is showed as % at
the ProgressBar on the Socket status window. And
last status is showed while no operation is running.

Check operation/SOCKET Status/ End Result

Site #1

@

II_®E_I

Check the operation and result by SOCKET Status and LogWindow.
The end result also can be checked by buzzer and LED of programmer.

> Buzzer does not work on DEMO and OffLine mode.

> The colour of socket is gray while contact checking is ok and white contact

checking is falil..

Site #2

-

— nm]m]m — mm]m

Not connect (SOCKET colour is white)

Site #1

I |
1l

,me

Connect (SOCKET colour is gray)
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Operation

I

Site #1

SOCKET on Progress

While running, the Site #1 is flashed on and off with orange color and
baby blue while operation is finished.

Site #1

iy
.

Green: Pass
Red: Fail gg éé
© Q
100%
]
Check by LogWindow

You can check the operation mode, site number, time, etc on log window.

Other status

According to the menu /Tool bar to check the status of operation.

While operation is running the menu/tool bar is locked and will be released till
operation is finished.

Check by buzzer

Using buzzing to indicate the result.

Single long pi (—)  :PASS(Socket colour is green or gray)
Short pi pi pi(==+--) :Fail(Socket colour is red)

»No buzzing on DEMO or Offline mode.
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Others operation
Stop

Clicking J button to stop an operation and below status can be checked.
Socket colour : All red

Buzzer : short pi pi pi(==+*)

LED cloure:All red

Counter : No change

Recommend not to stop operation while running, because IC may be demaged.
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Operation
Operation options

It's possible to designate the operations for "option yes/no" and "write-in" to the
device.

To preset the operation, please choose "Device->Device operation options™ menu
option.

[ Device Address ] { e
Device start Address (Word/hex) (fixed value) (oyce/hex) - [1reee:
Device end Address  (Word/hex) (fixed value) suffer ste e ————
Buffer start Address (byte/hex) (fixed value) O concace

ID check

|

[ Insertion test ]
Contact check
ID check

ID check STOP set

ELANE before 1-‘21:::14 B
ERLSE before DROGEAM

BLANK after ERASE
Contact check STOP set [ VERIEY afes Roca
While Contact check Fail the operation will
STOP. The operation will continue if you do not

choose it.

[0 vERrIFY after copy
Verify count: |Default

O | i Cance

ID check STOP set
While ID check Fail the operation will STOP. The operation will continue if you do
not choose it.

[ Command execution ]
BLANK before PROGRAM

ERASE before PROGRAM
BLANK after ERASE
VERIFY after PROGRAM
VERIFY after COPY

VERIFY COUNT
Default=======x=x- VERIFY twice ¢ Depends on the IC type
Once=========r==- VERIFY once
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Operation

[ Programming parameters ]
Set the part/s which should be programmed

[ Erase parameters ]
Set the part/s which should be erased.
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Help

Help

Language

You can choose English or Japanese for this control software. And all the information
& error message will be displayed using this language.

> Default language is English.

Set as English
Choosing [Help] -> [Choice of the language] -> [English] and the main screen will be
English.

108
M308-020A-K2

MINATO ADVANCED TECHNOLOGIES INC.



Quick Start
Quick Start

Install software and USB driver

Run the installation program in the CD:
e Ma308installer_vxxxx.exe ( MODEL308 Control Software )
e M308_USB_driver.exe ( USB driver)

Install them one by one according to the prompt message.
Install the programmer -hardware

Connect the programmer to PC by the USB cable.

> The software must be installed before connecting.

Start the control software

Double click the icon on the desktop #i== and the software will detect the

programmer.

Change the language
Clicking TOP menu Help - > Choice of the language -> English or Japanese
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Quick Start
IC Operation (Program)

(DSelect device. click ---- > &

(@Load data to buffer. g
a) From file click----- > ot
b) FromIC ----- >Put IC into ZIF SOCKET and click Covy

@Put IC into the DIP Socket.

@click----->_font
a) Unwritten status (BLANKING) is selected.

b) Delete (ERASE) data from the device to which the data have been written.

c) Write data (PROG) into the device.
d) Compare the read-in data with buffer data (VERIFY).

M308-020A-K2
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Troubleshooting
Troubleshooting

Q.1

The programmer can not be recognized by PC or USB connecting is fail.

Al

Confirm below items:

@ Whether MODEL308installer and USB_driver are installed correctly ?
@ Whether the USB and power cable are connected correctly ?

@ Whether the programmer is recognized by PC?

@ s it first time connecting the programmer to PC?

For WINDOWS XP
[ Start ] —» [Control Panel ] — [System] — [ Device Manage ] — [ Port ]Jto
check the connecting status and if you find below item it means the connecting is ok.

Example) MODEL308
»*1It’s just a example because there will be different Port number .

If you changed the usb port number, please restart the programmer.
Still can not be connected, please contact with minato.
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Message

Message
Number message guide  “error | Note
Number message Gdidaoficerror 4 | [Note
ndi§pege dispose
001 C:\ no enough space dispose
The blank space of harddisk is not
Current space: ***MB enough, please increase it.
Required space:
***MB
002 Site # connecting fail | error Communication fail
Please close the software and
power off the programmer. Then
power on programmer again and
open the software.
003 Communication  fail | error Communication fail
with programmer Please close the software and
power off the programmer.Then
power on programmer again and
open the software.
004 Communication  fail | error Communication fail
between software and Please close the software and
programmer. power off the programmer.Then
power on programmer again and
open the software.
005 Load file fail error Load file again.
006 Read data from SD | error Read again
fail
007 SRAM MemoryCheck | error Error occurred for Memory
fail Please close the software and
power off the programmer.Then
power on programmer again and
open the software.
008 Read CRC fail error Read CRC fail
Please read it again
009 Clear SD fail error Please clear it again.
010 Illegal command error Command again
011 Communication  fail | error Communication fail

between software and
programmer.Please set
programmer again.

Please close the software and
power off the programmer.Then
power on programmer again and
open the software.

M308-020A-K2
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Message

012 Read setting fail error Read setting again
013 Contact check Fail of | error Please check IC.
Socket, If you want to continue the
operation, please take the IC
SOCKET: Red from SOCKET.
014 ID check Fail of error Please check IC.
Socket If you want to continue the
ﬁ operation, please take the IC
|!j. from SOCKET.
015 error Please restart the software and
programmer.
016 LogFile  path is | error Please check the folder
invalid.
017 LotSzie is illegal notice LotSize  setting IS not
correct,please check it.
018 Communication error | dispose Communication is interrupted
and transfer bin Please follow the prompt.
data again?
019 Overcurrent error Please remove the IC from

W

socket and check it.
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Version

Confirm the version
You can confirm the version of control software by clicking Help -- > About
Universal Control Program Version.

Version up
Minato will release new version software while new device is added and you just need
to install the new software.

Please contact with minato for the new version MODEL308 Control software
(Universal Control Program.)
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Connecting mode

Connecting mode

. Status
(Connecting Mode)
Start
Softwere

rding i

( @ Cotnec

£ Mg e

O UmeHander

ETT

e S e e
\
Detect fail o
y Yy
) interrupt ( interrupt
MODEL308 > MODEL308 MODEL308 -
Online mode -t Offline mode Demo mode
. ) reconnect | reconnect

i

X Can not be switched

X O X

[ Connecting request from autohandler }

115
M308-020A-K2

MINATO ADVANCED TECHNOLOGIES INC.



Buzzing situation

Buzzing situation

Note

Power ON

UniversalControlProgram Strart finished

Changed the device

Operation selected

Operation finished

Different buzzing due to operation result

Items saved in Project File

Clear option ENA

Cleared data

Type Items description Save note
Project 1D Confirmation of Project | o Key in before saving
Project Note Confirmation of Project | o Key in before saving
IC IC P/N o
Package o
Adapter o
DATA File path-file name o
data Binary data X
File format o
Buffer range Start-End address X
Byte SUM o
Word SUM(Little) Little endian X
Word SUM(BIg) Big endian X
CRC32 o
CRC16 X
CRC-CCITT X
SWAP X
X
X
X
(©]
(©]
X
X
X

Offset option
Operation | Operation Select operation
Option
Counter | Counter value Pass, Fail, Total
Setting Reacord which counter
Time Average elapsed time Cleared by blank
function
Operation elapsed | Operate once X
time
Lot LotSzie X
System Data folder Browse folder X
Log file folder Browse folder X

Log file
period

keeping
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Buzzer ON / OFF X
Tool bar Lock/Unlock X
Status bar Display or not X
language Displayed language X
Items saved in log file
Type Item Description Save | Note
Title Version UniversalControlProgrammer o
Model 308 o
Programmer P/N X
Lot number Lot information o Key in before
operation
Operator Lot information o Key in  before
operation
Note Lot information o) Key in before
operation
IC Maker IC P/N o
Package o
Adapter o
Project File name o
Data file File name o)
Byte SUM o
CRC32 o
Start time o
End time o
Operation | mode Select the mode o
Select Address range setting o
Counter | Setting Count X
Time Average elapsed time X
Result LotSize o
Pass number o
Fail number o
Total number o
Yield PASS+Pass Fail total 0 Not +LotSize
Main menu
Menu select Tool button | Description
File Load project--- 08 Load Project file
Save project--- € Save Projectfile
Load file to buffer [ Load file
Save buffer to file = Save file
Config System modification (accessible only to
designer)
Control of a log file Log file management
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Pass/Fail counter

Counter setting

Verify check sum

Comparison between check sum and
expected value.

Deletion of the data
file

Deletion of data files for operation.

Open log file Open log file
(Recent file) Recent project file
Exit Exit
Edit Edit buffer Buffer Editor
Programmer | Buzzer Buzzer setting
Self test Check programmer
Clear data Delete the data.
File list Summary of files in buffer data of
programmer
LED Check LED check
Handler position Programmer number cannot be set unless
the operator performs the operation.
Device Select device:-- = Select IC
Operation options--- N Operation setting
Writing of unique ID The write-in of unique ID is available only
when operator performs the operation.
Access method Operation mode
Copy & COPY
Blank check = BLANK
Verify VERIFY
Program b PROG
Erase =] ERASE
Cont = CONT
View Toolbar Toolbar display.~ not
Status Bar Status bar display.~ not
Function progress bar Special : Show the progress at the time point
when fault occurs.
Contact check NG Showr/hide fault mark in the case of contact
mark error.
Handler NG code Only when operator is performing the
operation: OFF normally
SUM Display method of SUM
Help About Universal--- 7 Version
V_up Update

Choice of the lang---

Set the language

Main Menu(Buffer Editor)

M308-020A-K2
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Menu select Tool Description
button
Function | Erase buffer E Clear Buffer
Fill random Clear buffer with random data
data
Fill block = Intianalized the buffer with indicated data
Copy block Copy partial data
Move block = Move partial data
Swap data in Bl Swap
block
Find text Search data
Replace text = Replace data
Go to Address | Go to indicated address
Edit buffer Edit mode
View buffer View mode
Check SUM Check SUM / CRC
Exit Quit the editor
View Toolbar Toolbar display/not
Status Bar Status bar display.~ not
Byte View as Byte data
Word View as Word data
Help About ? Version display

BufferEditor

Choice of the
Iang. .

Select language

MINATO ADVANCED TECHNOLOGIES
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Terminology

Terminology

Endian

For device which data is more than 9bit, which order will be used to write BufferData
(Byte=8bit) to IC?

Refer to Little endian and Big endian

> Default is Little endian.

<L.ittle endian>

"Little Endian" means that the low-order byte of the number is stored in memory at the
lowest address, and the high-order byte at the highest address.

> Default is Little endian.

<Big endian>
"Big Endian" means that the high-order byte of the number is stored in memory at the
lowest address, and the low-order byte at the highest address.

SUM
A number that results by adding up every element of Buffer data and it is a quick way
to identify data. Below is the description of SUM

Byte sum
The number by adding up Byte (8bit) by byte.

> It’s a simple adding at Buffer Edit [CHECKSUM]

Word sum (Little endian)

The number by adding up Word (2Byte) by word. It’s a Little endian SUM.
Example: Buffer Data is 01,02,03,04(hex), and the sum is 0201+0403=0604(hex)

Word sum (Big endian)
The number by adding up Word (2Byte) data. It’s a Big endian SUM.
Example: BufferData is 01,02,03,04(hex), and the sum is 0102+0304=0406.
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Terminology

XOR
As one of the logical operations, it is used to check if the data for which the mean
value is the same as the value obtained from buffer data through this operation.

CRC ( Cyclic Redundancy Check, CRC)

It is another quick way to identify data. CRC is different for endian and SUM maby is
the same for different (1+2 = 2+1).

It will be safer by checking SUM and CRC.

Below is the description of CRC.
> Displayed at Buffer Editor [Check SUM]

CRC16
Method :X16+X15+X2+1
Result :2Byte

CRC-CCITT
Method : X16+X12+X5+1
Result :2Byte

CRC32
Method  : X32+X26+X23+X22+X16+X12+x11+X10+X8+X7+X5+X4+X2+X1
Result :4Byte

File format

MOT, HEX, NO Format (BIN)

< Motorola (*.MOT)>

It's a Motorola file format containing Record Type, Address, SUM, etc.
S4, S5, S6 have not been supported.

<Intel HEX (*.HEX)>

121
M308-020A-K2

MINATO ADVANCED TECHNOLOGIES INC.



Terminology

It’s a Intel file format containing Record Type, Address, SUM, etc.

<NO Format (*.BIN)>
Just binary data.

Swap
Swap a high- and low- order of byte in current buffer

Buffer offset
Normal the start address of IC is 0,but some Micro tool creates a file from another
address, so we should set the offset for some file format.

One Time<OTP>
One-time programmable. The characteristic of device that can be programmed once
but cannot be erased.

<Protect>
One function of IC to prevent changing the content by abnormal operation.

<Security>
One function of IC to avoid reading out the contents.

<Configuration>
One function of IC and You may set any options that are available for a specific
device.

<Partition>
It’s main for NAND IC to divide the data and IC space to some parts.

<Bad block>
The standard specification for the NAND allows for the existence of bad blocks in a
certain percentage.

<ECC>
The use of an error correcting code is essential in order to maintain the integrity of
stored code. And ECC code will be written to IC too.
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Terminology

<Site>
Every 4SOCKET as one site for MODEL308 programmer.

<Lot>/Lot size
The unit for production quantity.
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Revision
Contacts

MINATO ADVANCED TECHNOLOGIES INC.

Address :

- Headquarters  (Origin: Yokohama office)

4105, Minami Yamata-cho, Tsuzuki-ku, Yokohama-shi, Kanagawa, 224-0026, Japan
TEL: +81-45-591-5611 / FAX: +81-45-591-6451
E-mail: et-sales@minato.co.jp

+ Osaka sales office

9F, Kotera Plaza, 2-5-23, Kitahama, Chuo-ku, Osaka-shi, Osaka 541-0041, Japan
TEL: +81-6-6575-7641 / FAX: +81-6-6575-7642

- Fukuoka sales office

2F, PS-Bldg., 4-22-16, Shimizu Minami-ku, Fukuoka-shi, Fukuoka 815-0031, Japan
TEL: +81-92-553-2540 / FAX: +81-92-553-2541

* Minato(Shanghai)Co.,Ltd

2F, Building I, Plainvim Industrial Park, 76th Zhen'an East Road, Xiaobian’Community, Chang'an
Town, Dongguan City, Guangdong Province, China

TEL: +86-137-1218-5385

E-mail: C-assistant@minato.co.jp

+ (Minato Holdings Inc.) Headquarters

7-2, Nihonbashi-Kodenmacho, Chuo-ku, Tokyo, 103-0001, Japan
TEL: +81-3-5847-2030 / FAX: +81-3-5847-2040
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Revision

Revision
Rev DATE Contents
Revl |2017/04/11 | Initial Release
Revl.1 | 2017/06/29 | Changed the name of the business establishment.
Rev2 [2017/09/22 | Added the note about the running controle software.
Added the Protect in the contents.
Rev2.1 |2018/05/07 | Changed the name of the business establishment.
Rev2.2 |12018/10/01 | Changed the name of the company.
Rev2.3 |2022/06/28 | Update the Safety Precaution.
Changed the name of the sales office
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