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＜必ずお読みください＞ 
～安全上のご注意～ 

ＰＲＯＭプログラマを正しく安全にお使いいただき、人体への危害や財産への損害を未然に防止する為に、

必ず守っていただきたい事を「警告」と「注意」の２つに区分して説明しています。 

内容をよく理解されてから本文をお読みください。 

 

［警告］：ここに書かれていることを無視して誤った取り扱いをすると、人が死亡 

      または重傷を負う可能性が想定される内容を示しています。 

１．正しい電源コ－ド及びコンセントをお使いください。 

● 本製品に附付されている電源コ－ドをご使用になり、電源コ－ドのプラグ（接地端子付３ピンプラグ） 

は接地端子付きの３ピン電源コンセントに接続してください。不適切に接続した場合や不適切な電源

コ－ド、電源コンセントの使用により、本製品の金属部分に触れた時、感電、誤動作する恐れがあり

ます。 

●電源コ－ドは感電、火災の原因となりますので、無理に曲げたり、引っ張ったりしないでください。 

また、電源コ－ドに圧力がかかったり、潰れたりしないような場所に設置してください。 

  ●本製品に付属する電源ケーブルは、本製品専用です。他の製品には絶対に使用しないでください。 

 

２．正しい電源電圧でお使いください。 

●本製品はＡＣ９０～２６０Ｖ（５０Ｈz／６０Ｈz）の範囲でお使いください。 

規定外の電圧で使用すると、感電、火災、故障の原因となります。 

 

３．次のような場所での使用、保管はしないでください。 

● 湿気の多い場所、水などの液体のかかる場所、埃の多い場所、腐食性ガスの発生する場所、急激な温 

度変化のある場所、以上のような場所での使用、保管は感電、火災、故障の原因となります。 

 

４．煙がでる、異臭がする、異音がする場合は、すぐに電源スイッチを切って、電源コ－ドを 

  コンセントからはずしてください。 

●このまま使用すると感電、火災の原因となります。すみやかに当社のサ－ビス部門にご連絡ください。 

 

５．通風孔などから、導電性のゴミ、異物などが入らないようにしてください。 

● 製品内部に導電性のゴミ、異物などが入ると、感電、火災、故障の原因となります。もし異物などが 

入ってしまった場合は、電源スイッチを切り、電源コ－ドをコンセントからはずして、すみやかに当

社のサ－ビス部門にご連絡ください。 

 

６．本製品のカバ－をはずしたり、内部を改造したりしないでください。 

●製品内部には、高圧の部分がありますので、触ると感電の原因となります。 

また、内部を改造すると、感電、火災、故障の原因となります。 

 

７．変換アダプタは弊社指定の製品をご使用願います。 

  ●書き込みに使用する変換アダプタは弊社製または、弊社が指定する製品をご使用願います。 

   他の製品は使用しないでください。 
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［注意］：ここに書かれていることを無視して誤った取り扱いをすると、人が障害を 

     負う可能性または機器が破損する可能性が想定される内容を示しています。 

１．電気的雑音が多く発生する機器（エアコン、複写機など）のそばでの使用は避けてください。 

●電源に雑音が入り誤動作の原因となり、書き込み中のデバイスを破損する原因となる場合もあります。 

 

２．電源コ－ドに付属しているグランド端子をア－スしてください。 

●感電、誤動作等の防止に有効です。 

 

３．本製品は、周囲温度５℃～３５℃の範囲でお使いください。 

●それ以外の温度でご使用になると誤動作、故障の原因となります。 

 

４．電源を入れる前に、ソケット内を確認してください。 

● ソケット内に異物などが付着したり、混入したりしているとセルフチェックが正常に終了せずに、故 

障の原因となることがあります。 

 

５．電源のＯＮ／ＯＦＦは、５秒以上たってから行ってください。 

●短時間内の電源ＯＮ／ＯＦＦは、誤動作、故障の原因となります。 

 

６．ソケットにデバイス、変換アダプタを入れたままでの電源のＯＮ／ＯＦＦを行わないでください。 

●ソケットに高圧電源が加わりデバイスを破損する場合があります。 

● 変換アダプタを入れたまま電源を入れるとセルフチェックが正常に終了せずに、故障の原因となる事

があります。 

 

７．デバイスを挿入する際は、ご注意ください。 

●ソケット内に異物などが付着、混入していないことを確認した後に、デバイスの挿入方向（１番ピン） 

に注意してから挿入してください。ソケット内に異物などが付着、混入していたりデバイスの挿入方

向を間違えたりすると、書き込み不良の原因となる場合があります。 

●使用するデバイスがＵＶ－ＲＯＭ等の場合、消去が不十分だと、書き込み不良となる場合があります

ので、よく消去してからご使用ください。また、新しく購入されたＵＶ－ＲＯＭ等も初期消去される

ことをお勧めします。 

 

８．デバイスの書き込み中は、リセット操作は避けてください。 

● 書き込みが不十分となる場合があります。リセット操作をした場合はイレ－ズ可能なデバイスは一度 

イレ－ズを行ってから使用してください。 

 

９．Ｉ／Ｆケ－ブルの脱着は、必ず電源を切ってから行ってください。 

●本製品だけでなく、接続先の機器も破損する原因となる場合があります。 

 

１０．筐体の上に直接デバイスを置かないで下さい。 

●デバイスを直接筐体の上に置きますと、静電気によってデバイスが破損する原因となります。 

 

１１．本製品は丁寧に取り扱ってください。 

●本製品を落としたり、ぶつけたりして強い衝撃を与えますと故障の原因となります。 

● 本製品の汚れは、水または、薄めた中性洗剤を含ませた柔らかな布で拭き取ってください。シンナ－ 

等は使用すると筐体の変形、変色の原因となります。 

 

１２．ＩＣソケットは定期的に交換してください。 

●ＩＣソケットがいたんでいる場合、デバイスの書き込み不良の原因になることがあります。 

● ＩＣソケットは消耗品です。修理等の場合、交換は有償となりますので、予めご了承願います。 
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無償修理保証規定（持ち込み修理） 
無償修理保証期間：１年間（弊社より製品出荷後） 

本製品は当社の厳密な製品検査に合格したものです。お客様の正常なご使用状態のもので万一故障した場合

には、本保証規定に従い故障個所の修理をさせていただきますので製品に添付されている保証登録はがきに

必要事項をご記入の上当社宛返送願います。保証登録が行われないと例え無償保証期間中であっても有償に

なりますのでご注意願います。ただし、保証対象は本製品のハードウェア部分（当社規定による）に限らせ

ていただきます。 

本製品の故障またはその使用上生じた直接または間接の損害につきましては、弊社はその責に任じません。 

なお、保証期間内であっても、次の各項に該当する場合には、有償修理となります。 

１．保証登録はがきを当社宛返送されていない場合。 

２．保証登録はがきの所定事項に未記入の箇所がある場合。 

３．お客様による輸送・移動・移設時の落下、衝撃等、お客様のお取り扱いが適切でないために生じ 

  た故障・損傷の場合。 

４．火災・地震・水害・落雷等の天災地変および異常電圧による故障・損傷の場合。 

５．当社以外で修理・調整・改良した場合、あるいは修理・調整・改良しようとした痕跡が認められ 

  る場合。 

１． 本製品の説明書に記載された使用方法および注意事項に反するお取り扱いによって生じた故障の場合。 

特記事項 

１．本保証規定は、本製品が日本国内で使用される場合に限り有効です。 

  This warranty is valid only in Japan. 
２．無償修理保証期間は、弊社より本製品出荷後１年間とさせていただきます。 

３．修理品を弊社宛発送していただく場合、その梱包及び輸送に関わる費用はお客様のご負担で 

  お願いいたします。修理完了品を弊社よりお客様に返送する場合は、弊社にて輸送費を負担い 

  たします。梱包材がない場合は、ご購入になられた代理店までご相談願います。 

４．書き込み対象 ROM に対してその ROM の製造メーカが仕様を変更（生産ロットの特性違いも 

  含む）した場合に対応するため本体ハード／ソフトの改造・改良をおこなう場合、および新規に 

  ハードウェアの追加が必要になる場合は別途有償になります。 

５．弊社製以外のハードウェア／ソフトウェアを組み合わせて使用した場合に生じた不具合につい 

  ては、保証いたしません。 
デバイス対応ソフトウェアサポ－ト 

当社プログラマのデバイス対応ソフトウェアについては、製品納入後半年間の無償サポ－ト期間があ

ります。この期間内に、サポ－トしているデバイス対応ソフトウェア等に支障が生じた場合、その部

分に対し無償にてサポ－ト致します。但し、この期間内においても新規デバイス対応のためのソフト

ウェアのバ－ジョン・アップ及びデバイス仕様変更によるソフトウェアの変更に対しては、別途費用

がかかりますので御了承願います。 

 
 

 

＜Copyright Notice（著作権について）＞ 
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この文書は２００５年、ミナトエレクトロニクス（株）によって作成されたものです。 

このマニュアルの著作権、およびその他の権利はすべて著作者に帰属します。 

また製品の改良のためにこのマニュアルを予告なしに変更することがあります。 

このマニュアルの内容の全部、もしくは一部を複写、複製、コピ－、翻訳することはミナトエレクトロ 

ニクス（株）の許可なしに行う事を堅く禁止いたします。 

ミナトエレクトロニクス（株）は、この製品の使用によって生じるいかなる第三者の権利の侵害や責任 

を負うべきものではありません。 

 

 

＜Acknowledgments＞ 
ＩＢＭ、ＰＣ／ＡＴ、ＶＧＡはインタ－ナショナルビジネスマシン社の商標です。 

ＭＳ－ＤＯＳ、ＭＳ－Ｗｉｎｄｏｗｓはマイクロソフト社の商標です。 

 

 

＜How to use this manual（このマニュアルの使用法）＞ 
ユニバ－サルプログラマ「ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰ」をお買いあげいただきまして誠に 

ありがとうございます。このマニュアルはお客様が簡単かつスピ－ディ－に 

１８８１ＸＰ/ＵＸＰのセットアップを行い、使用していただけるように書かれています。 

 

※質問、疑問点等があれば、弊社までお気軽にご連絡下さい。 

 

 

＜Packing list（梱包品リスト）＞ 
１８８１ＸＰ/ＵＸＰのインスト－ルを始める前に、下記のものが揃っているかどうか確認して下さい。 

・１８８１ＸＰ/ＵＸＰユニバ－サルプログラマ １台 

・パラレルケ－ブル １本 

・WINDOWS 版 CD ソフトウェア  １枚 

・電源ケ－ブル １本 

・取扱説明書（本書） １冊 

・ユーザ登録ハガキ  １枚 

 

 

これらの製品が同封されていない、又は損傷がある場合は直ちに販売店・代理店へご連絡下さい。 
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Ｃｏｎｔｅｎｔｓ（目次） 
 

＜概要＞ 
・Features（特徴）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．７ 

・M1881XP/UXP Diagram（１８８１XP の外観図）．．．．．．．．．．．．．．．．．．．．．．．．８ 

・Using the M1881XP/UXP Software（ソフトウェアの使用）．．．．．．．．．．．．．．．．．．．９ 

 

＜操作＞ 

（１）Installation（インスト－ル） 
・Minimum System Requirements（最小限必要なシステム構成）．．．．．．．．．．．．．．．．１０ 

・Installing the M1881XP/UXP（１８８１XP/UXP のインスト－ル）．．．．．．．．．．．．．．．１０ 

・Installing the M1881XP/UXP Software（ソフトウェアのインスト－ル）．．．．．．．．．．．．１０ 

（２）Operation（操作） 

File Commands（ファイルコマンド） 
・Save（バッファデータの保存）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．１２ 

・Load（ファイルの読み込み）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．１４ 

・Exit（終了）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．１６ 

Project Commands（プロジェクトファイルコマンド） 
・Project File Saving and Loading（プロジェクトファイルの読み込みと保存）．．．．．．．．１７ 

Device Commands（デバイスコマンド） 
・Change Device（デバイスの変更）．．．．．．．．．．．．．．．．．．．．．．．．．．．．１８ 

・Auto Select EPROM（EPROM の自動選択）． ． ．．．．．．．．．．．．．．．．．．．．．．１９ 

・Mass－production Mode（マスプロダクションモ－ド）．．．．．．．．．．．．．．．．．．．１９ 

・Editing the Buffer（バッファの編集）．．．．．．．．．．．．．．．．．．．．．．．．．．２０ 

・Blank check a device（ブランクチェック）．．．．．．．．．．．．．．．．．．．．．．．．２４ 

・Reading a device（読み出し）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．２４ 

・Program a device（プログラミング）．．．．．．．．．．．．．．．．．．．．．．．．．．．２４ 

・Verify a device（ベリファイ）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．２５ 

・Erase a device（イレ－ス）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．２５ 

・Comparing a device（デバイスの比較）．．．．．．．．．．．．．．．．．．．．．．．．．．２５ 

・Modify Vector（ベクタの変更）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．２５ 

・Secure device（デバイスの保護）．．．．．．．．．．．．．．．．．．．．．．．．．．．．２５ 

・Function Test（機能テスト）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．２５ 

・Configuration（環境設定）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．２５ 

・Memory Protect（メモリ保護）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．２５ 

Options Commands（オプションコマンド） 
・Parameters（アルゴリズムパラメ－タの変更）．．．．．．．．．．．．．．．．．．．．．．．２６ 

・Operation（デバイス操作オプション）．．．．．．．．．．．．．．．．．．．．．．．．．．２６ 

・Parallel Port（パラレルポートの選択）．．．．．．．．．．．．．．．．．．．．．．．．．２９ 

・Statistic（統計）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．２９ 

Diagnostics Commands（診断コマンド） 
・Self Test（自己診断）．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．．３０ 
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＜概要＞ 
ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰはパラレルポートを利用してパソコンで操作する高性能ユニバーサル 

プログラマです。 

フラッシュＲＯＭをはじめとしてＥＰＲＯＭ、ＰＬＤ、ワンチップマイコン等のプログラマブルデバイス 

に対応しています。特に大容量フラッシュＲＯＭに対応するため、書き込み時間の大幅な短縮を実現 

しました。 

・Features（特徴） 
（１）ユニバ－サル変換アダプタ 
ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰは、汎用的に使用されている４８ｐｉｎＴＳＯＰ、４４ｐｉｎＰＬＣＣ、 

４０ｐｉｎＴＳＯＰ、３２ｐｉｎＴＳＯＰの各パッケージ用にそれぞれユニバーサル変換アダプタを 

用意していますので（別途有償）メーカ、容量等が異なっていても同じパッケージであれば変換アダ 

プタは共通で使用することが出来ます。 

   

（２）高速書き込み 
 ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰは大容量フラッシュに対応するために書き込み時間の大幅な短縮を図り 

 ました。１Ｍｂｉｔあたりおよそ２．５秒で書き込む能力を持っています。開発設計部門での書き込みも 

 時間の短縮化が図れ効率の良い開発が行えます。 

 

（３）デバイスの挿入および接触のチェック 

ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰはプログラミング前にデバイスの挿入チェックを実行します。 

これにより該当しないデバイス（実際に選択したデバイスタイプと異なるピン数）、上下反対の挿入、 

接触不良や欠陥のあるデバイスをチェックし、人的ミスや不十分なピン接触に起因する大きな障害から 

デバイスを保護します。 

 

（４）ＥＰＲＯＭおよびフラッシュメモリのＩＤ検知 

 多くのＥＰＲＯＭやフラッシュメモリデバイスはデバイスＩＤコ－ドとメーカＩＤを持っています。 

ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰは挿入されたデバイスのメ－カ－や型格を決定するため、ＩＤを読み 

自動設定する事が可能です。ただし、変換アダプタを使用する場合この機能が使用できない場合がありま

す。 

 

（５）オートセンシングとオートプログラミング 

 ＲＯＭを大量に書き込み時に便利な機能をＭＯＤＥＬ１８８１ＸＰ/ＵＸＰは持っています。 

オートセンシング機能はプログラミング前に、ソケットにデバイスが正しく挿入されればその 

デバイスに対し書き込みスタートが自動でかかり書き込み終了後、次のデバイスを入れ替えることにより 

再度自動で書き込みスタートがかかるようになっています。 

オペレータがやるべき事は、ＺＩＦソケットにデバイスを装着→ＬＥＤが点灯、デバイス書込が正常終 

了したことを表示→デバイスを外し、別のデバイスに置き換え→あとはこの繰り返しと、非常に簡単です。 

 

（６）プロジェクトファイル 

デバイス選択、マスターデータのロード及び全てのプログラムセットアップオプションの情報を含む 

プロジェクトファイル（環境設定ファイル）を作成することが出来ます。書き込み前の設定作業を 

簡略化することが可能です。 

 

（７）デバイスサポート 

ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰのデバイスサポートは、ソフトウェアのバージョンアップ（別途有償）

で 

行うことが出来ます。 

年間４回のバージョンアップを行っています。最新のデバイスサポート状況は弊社ホームページで 

確認することが出来ます。  www.minato.co.jp 
 

(８）定期校正 
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Ｐ－ＲＯＭプログラマは、生産機器であり安心して御使用頂くためにも、日頃の点検と年１回（場合

によっては、２回）の定期校正をお勧め致します。 
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 ・M1881XP/UXP Diagram（M１８８１XP の外観図） 
 

 

 

 

 

 

 

 

 

 

 

ZIF socket 
 

 

 

Power connector 
 

    Power switch 
 

 

 
 

 

 

                  

Parallel connector 
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・ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰソフトウェアの使用方法 
Menus（メニュ－） 

（１）画面上に表示されるメニュ－オプションを、マウスを使いクリックします。 

プルダウンメニュ－が表示、必要に応じたオプションを選択することができます。 

（２）マウスを使用せずにキ－ボ－ドを使って操作することも可能です。 

Ｆ１０キ－を押しメインメニュ－バ－を操作出来るようにしてから、矢印キ－を使い必要なサブ 

メニュ－を選択して、ＥＮＴＥＲキ－を押せばコマンドを実行できます。 

 

 Hot－keys（ホットキ－） 
ほとんどのメニュ－上の機能はホットキ－を押すことで実行可能です。あるコマンドのホットキ－が何 

であるか知るためには、コマンドが位置しているメニュ－を見て下さい（下図参照）。 

例：Ｌｏａｄ Ｆｉｌｅ  Ａｌｔ＋Ｌ： 

  Ａｌｔキ－を押しながらＬを押すとファイルロ－ド操作ができます。 

※以降、本書では上記のような操作を「Alt－＊」と簡略表記します。 

 

 

 

 

 

 

 

 

 

 

 

ホットキ－

メインメニュ－ 

サブメニュ－ 

デバイス
インフォメ－ション 統計 
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＜操作＞ 
 

 

（１）Installation（インスト－ル） 
 

・Minimum System Requirements（最小限必要なシステム構成） 

Ｗｉｎｄｏｗｓ９５／９８／ＭＥ，Ｗｉｎｄｏｗｓ２０００、ＷｉｎｄｏｗｓＸＰ 

ＷｉｎｄｏｗｓＮＴ４．０または最新版 

ＣＰＵ： ４８６以上 

ＲＡＭ：最低８ＭＢ（３２ＭＢ以上を推奨 ＯＳによる。） 

ＨＤ：１６ＭＢ以上の空き容量 

インターフェース：パラレルポート  ＥＰＰモード必須 

注）ＥＰＰモ－ドに設定しないと、正常に動作しません。          

 

 

・ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰハードウェアのインスト－ル 

１．Ｍ１８８１ＸＰ/ＵＸＰとＰＣの電源を切ります。 

２．Ｍ１８８１ＸＰ/ＵＸＰとＰＣのパラレルポ－トを付属のケ－ブルで接続します。 

３．ＰＣの電源を入れます。 

４．Ｍ１８８１ＸＰ/ＵＸＰの電源を入れます。 

   セルフテストを実行し緑色のＬＥＤが点灯すれば完了です。 

 

・ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰソフトウェアのインスト－ル 

ＣＤドライブにＣＤを挿入しＳＥＴＵＰ．ＥＸＥを実行していただく 

とＭ１８８１ＸＰ/ＵＸＰのソフトがインストールされます。 

Ｍ１８８１ＸＰ/ＵＸＰのソフトを起動すると画面上に本体ファームウェアのバージョンと 

パソコンのパラレルポートに接続されていることが表示されます。 

※ソフトウェアのバージョンアップについては、当社にお問い合わせ下さい。 

 

・ ＭＯＤＥＬ１８８１ＸＰ/ＵＸＰ本体のＬＥＤ表示 
Ｍ１８８１ＸＰ/ＵＸＰ本体上には３つのＬＥＤがありソケットにあるデバイスの状態を 

表示します。 

Ｂｕｓｙ ＬＥＤ ：書き込み中ですのでソケットからデバイスを取り除かないでく 

          ださい。黄色く点灯します。 

Ｅｒｒｏｒ ＬＥＤ：各動作モードを実行した結果がフェイルになったことを 

          表します。赤く点灯します。 

ＧＯＯＤ ＬＥＤ ：各動作モードを実行した結果がパスになったことを表します。 

          緑に点灯します。 
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（２）Operation（操作） 

 コマンド一覧 

System command   Operation command           Hot Key 
 

File (ALT-F) Save Buffer ALT-S 
 Load File ALT-L 
 Exit ALT-X 
Project (ALT-J) Save Project ALT-F1 
 Load Project ALT-F2 
Device (ALT-D) Change ALT-C 
 Edit ALT-E 
 Read ALT-R 
 Blank Check ALT-B 
 Program/Auto ALT-P 
 Verify ALT-V 
 Erase Ctrl-F1 
 Compare Ctrl-F3 
 Configuration ALT-G 
Options (ALT-O) Modify Programming Parameter F3 
 Device Operation Options  F4 
 Parallel Port Selection F5 
 Statistics F6 
Diagnostic Self Test F7 
Help (ALT-H) Help Topic 
 About 
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File Commands（ファイルコマンド） 
 

・Save（バッファのデ－タ保存） 
Menu ：File→Save 

Hot－key： Alt－S 

ハ－ドディスク上へバッファメモリ内容をデ－タファイルとして保存します。 

１．以下の操作で Save ウィンドウを開きます。 

Menu： File→Save 

Hot－key： Alt－S 

次のような画面が表示されます。 

 

 
 

２．保存ファイルを確定します。 

マウス： 

各ボックスをクリックし、保存するドライブのフォルダ・ファイルの種類・ファイルを選択又は入力

し、ＯＫをクリックします。 

キ－ボ－ド： 

各ボックスを TAB キ－で移動し、保存するドライブのフォルダ・ファイルの種類・ファイルを選択又

は入力し、ENTER キ－を押します。 

 

次のような画面が表示されます。 
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File Name 保存するファイル名を入力してください。 

File Format（出力ファイルフォ－マット） 

出力ファイルのフォ－マットを選択します。 

Binary、HP64000ABS、IntelHEX、MOStechnologyHEX、MotorolaS format、TektronicHEX、 

StraightHEX 

Buffer Mode（バッファからの出力モ－ド） 

バッファからファイルへの出力モ－ドを設定します。 

Normal：すべてのデータがファイルに出力されます。 

Even (1st of 2) ：バッファの偶数番地のデータ毎にファイルに出力されます。 

Odd (2nd of 2) ：バッファの奇数番地のデータ毎にファイルに出力されます。 

１ｓｔ ｂｙｔｅ ｏｆ４：１、５、９、１３．．．番地のデータ毎にファイルに出力されます。 

２ｎｄ ｂｙｔｅ ｏｆ４：２、６、１０、１４．．．番地    〃 

３ｒｄ ｂｙｔｅ ｏｆ４：３、７、１１、１５．．．番地    〃 

４ｔｈ ｂｙｔｅ ｏｆ４：４、８、１２、１６．．．番地    〃 

 

From Buffer Address  

バッファ内容の途中から保存したい場合、その先頭アドレスを入力します。デフォルトは０です。 

 ８ｂｉｔアドレスで指定してください。 

Buffer Size 

ファイルサイズを設定します。デフォルトは選択されているデバイス容量と同じです。 

変更したい場合は入力しなおして下さい。 

 

各設定の後、ＯＫをクリックまたは ENTER キ－を押します。 



ＭＯＤＥＬ－１８８１XP/UXP オペレ－ションマニュアル 

 

ＭＩＮＡＴＯ ＥＬＥＣＴＲＯＮＩＣＳ ＩＮＣ． 

15 

・Load（ファイルの読み込み） 
Menu： File→Load 

Hot－key： Alt－L 

デ－タファイルをディスクからメモリバッファへ読み出します。 

読み込み可能なファイルのタイプはそのデバイスのタイプによって決まります。 

１．以下の操作で「ファイルを開く」ウィンドウを開きます。 

Menu： File→Load 

Hot－key： Alt－L 

次のような画面が表示されます。 

 

 
 

２．読み込むファイルを選択します。 

マウス： 

各ボックスをクリックし、読み込むドライブのフォルダ・ファイルの種類・ファイルを選択又は入力

し、ＯＫをクリックします。 

キ－ボ－ド： 

各ボックスを TAB キ－で移動し、読み込むドライブのフォルダ・ファイルの種類・ファイルを選択又

は入力し、ENTER キ－を押します。 

 

次のような画面が表示されます。 
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Auto Format Detected 

ファイルを指定するとファイルのフォ－マット形式は自動的に設定されます。 

例えば上記はＩｎｔｅｌ Ｈｅｘを示しています。 

もし読み込むファイルのフォ－マットが、設定されたフォ－マットと異なっていたら、 

正しいフォ－マット形式を選択して下さい。 

 

From File 

 ファイルから M1881UXP バッファへの読み込みモ－ドを設定します。 

Normal：ファイルのすべてのデータがバッファに読み込まれます。（初期設定） 

Even (1st of 2) ：ファイルの偶数番地のデータがバッファに読み込まれます。 

Odd (2nd of 2) ：ファイルの奇数番地のデータがバッファに読み込まれます。 

１ｓｔ ｂｙｔｅ ｏｆ４：１、５、９、１３．．．番地毎にデータがバッファに読み出されます。 

２ｎｄ ｂｙｔｅ ｏｆ４：２、６、１０、１４．．．    〃 

３ｒｄ ｂｙｔｅ ｏｆ４：３、７、１１、１５．．．    〃 

４ｔｈ ｂｙｔｅ ｏｆ４：４、８、１２、１６．．．    〃 

 

To Buffer 

 ファイルから M1881UXP バッファのどこへ読み込みしていくかを設定します。 

Normal：ファイルのすべてのデータがバッファに読み込まれます。（初期設定） 

Even (1st of 2) ：ファイルのデータがバッファの偶数番地に読み込まれます。 

Odd (2nd of 2) ：ファイルのデータがバッファの奇数番地に読み込まれます。 

１ｓｔ ｂｙｔｅ ｏｆ４：ファイルのデータがバッファの 1,5,9,13,…番地に読み込まれます。 

２ｎｄ ｂｙｔｅ ｏｆ４：ファイルのデータがバッファの 2,6,10,14,…番地に読み込まれます。。 

３ｒｄ ｂｙｔｅ ｏｆ４：ファイルのデータがバッファの 3,7,11,15,…番地に    〃 
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４ｔｈ ｂｙｔｅ ｏｆ４：ファイルのデータがバッファの 4,8,12,16,…番地に    〃 

 

 

From File Address 

ファイルの途中のアドレスからデータをバッファに読み込ませるときに、その先頭アドレスをこのボック

ス内へ入力します。初期値は０番地に設定されています。 

 

To Buffer Address 

Ｍ１８８１ＸＰ/ＵＸＰバッファの何番地に読み込ませるかを指定します。 

 

Buffer Size 

バッファサイズを設定します。デフォルトはデバイスサイズと同じです。 

もし、操作対象のデバイスより大きなサイズのメモリへファイルを 

ダウンロ－ドしたいときは、サイズを入力しなおして下さい｡ 

（Options→ Operation でも可能） 

 

各設定の後、ＯＫをクリックまたは ENTER キ－を押します。 

 

Clear Buffer Options 

  ファイルをバッファに読み込むときにバッファ内の状態を指定することが出来ます。 

  初期値としては“Blank state”になっています。 

Disable 

 新しくファイルを読み込みしたときには上書きされますがデータのないアドレスには、 

 前のデータがクリアされず残ります。 

Blank state 

 バッファに残っているデータはクリアされて、選択されているデバイスの未書き込み状態になり 

 読み込まれたデータが上書きされます。 

0x00 

 バッファ内はデータ 00 になり読み込まれたデータが上書きされます。 

0xFF  

 バッファ内はデータ FF になり読み込まれたデータが上書きされます。 

 

・Exit（終了）  
Menu ：File→Exit  

Hot－Key： Alt－X 

 Ｍ１８８１ＸＰ/ＵＸＰプログラムを終了します。 

 

 

 

 

 

 

 

 

 

 

 

 

 



ＭＯＤＥＬ－１８８１XP/UXP オペレ－ションマニュアル 

 

ＭＩＮＡＴＯ ＥＬＥＣＴＲＯＮＩＣＳ ＩＮＣ． 

18 

 

 

 

Project File Commands（プロジェクトファイルコマンド） 
 

・Save Project （プロジェクトファイルの保存） 
プロジェクトファイルはマクロとして働き、デバイスの書き込みに必要な設定情報をファイルとして 

保存しておくことが出来ます。このファイルを利用することにより作業の手間を省くことが出来ます。 

 

Menu ：Project→Save Project 

Hot－Key： Alt－F1 

 

（保存出来る設定内容） 

１．書き込むデバイスの設定。 

２．ファイルデータの読み込み。 

３．Operation Option の設定と Device Configuration の設定 

１から３の設定を実際に操作し最後に上記“Save Project”を実行し 

ファイル名を付けて保存します。 

 

（読み込み） 

保存されたプロジェクトファイルを読み込みます。 

操作は以下の通り。 

Menu ：Project→Load Project  

Hot－Key： Alt－F2 

 

 Save project で作成したファイルを読み込むことで、ファイルの内容を実行します。 
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Device Commands（デバイスコマンド） 
 

・Change Device（デバイス変更） 
使用するデバイスを選択します。 

（別のデバイスを選択する場合も同様の操作です。） 

１．以下の操作でデバイス選択ウィンドウを開きます。 

Menu： Device→Change  

Hot－key： Alt－C 

 

 
 

２． TYPE  

  対象デバイスに合ったデバイスのタイプを選択します。初期値は ALL が選択されています。 

  目的とするデバイスを素早く設定するために、ここで EPROM、PROM、PLD、MPU を指定しておけば 

  Device が絞り込めます。 

マウス： 

All、EPROM、PROM、PLD、MPU のいずれかをクリックします。 

キ－ボ－ド： 

Type ボックスへカ－ソルが移動するまで TAB キ－を押します。 

上下矢印キ－で適用するタイプを選択します。 

３． Search 

  メーカ名、製品型格あるいは両方を Search ボックスの中へ入力します。 

  マウス： 

Search ボックスをクリックし、検索文字列を入力します。 

キ－ボ－ド： 
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Search ボックスへカ－ソルが移動するまで TAB キ－を押し、検索文字列を入力します。 

  Vendor Device のなかに Search で指定した該当するベンダー及びデバイスが全て表示されますので 

  書き込みデバイスを選択してください。 

   

   

 

４．メ－カ－（VENDOR）及びデバイスを、選択・確定します。 

マウス： 

各ボックスをクリックし、希望項目を選択しＯＫをクリックします。 

キ－ボ－ド： 

各ボックスへカ－ソルが移動するまで TAB キ－を押し、 

希望項目を選択して ENTER キ－を押します。 

 

 

・Auto Select EPROM（EPROM の自動選択） 
Menu： Device→Auto Select EPROM  

Hot－key： Alt－A 

EPROM、FlashRom は、デバイスの中チップのなかにデバイス ID コ－ド、メーカＩＤコードを持っています。 

この Auto Selct 機能でこれらを読み込むことにより使用デバイスの自動選択が可能です。 

マウスをクリックして表示されたデバイスの一つを選択して下さい。 

この機能は、32pin または 28PIN を持つ DIP パッケージの EPROM 及び FlashRom に有効です。そのほかの 

パッケージ（変換アダプタを使用）、ワンチップマイコン、PLD 等には使用しないでください。 

 

・ Mass－Production Mode（マスプロダクションモ－ド）  

  
 このモードを使用すると書き込みに必要な設定をした後はデバイスをソケットにセットするだけで 

書き込みを自動的に行います。書き込みが終了するとデバイスをソケットにセットし直すだけで繰り返し 

書き込みを行っていきます。 

Menu： Device→Mass Production Mode 

Hot－key： 無し 

 

１．プログラムするデバイスを選択します。 

２．バッファにデータ（プロジェクト）ファイルを読み込みます。 

３．Mass－Production モ－ドの設定 

４．必要な操作オプションをセットアップします。 

５．ウィンドウ右下の RESET ボタンを押してカウンターをクリヤーします。 

６．１８８１ＸＰ/ＵＸＰの画面上の指示に従い、操作します。 
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・Editing the Buffer（バッファの編集） 
Menu： Device→Edit 

Hot－key： Alt－E 

この機能はメモリバッファ上のデ－タを確認、編集する際に用いられます。 

メモリバッファにはディスクからメモリに最後に読み込まれたファイルが保存されています。 

画面は作業対象になっているデバイスタイプ、容量に応じて表示されます。 

  

（１）EPROM のバッファ編集 
 

 
各ボタンの機能は次の通りです。 

Radix 

メモリアドレス表示を Hex（16 進）/Decimal（10 進）に切り替えます。 

Swap 

 データをバイト単位で上位下位を入れ替えることが出来ます。“WORD width”の値を変えることによ

り 

 いろいろなデータの入れ替えが出来ます。 

 例１） 
01 23 45 67 89 AB CD EF      “ word width”を 2 に設定後 SWAP を実行すると 
バッファの内容は以下のようになります。. 

    23 01 67 45 AB 89 EF CD 
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 例２） 
01 23 45 67 89 AB CD EF       “word width”を ３に設定後 SWAP を実行すると 
バッファの内容は以下のようになります。 
45 23 01 AB 89 67 FF EF  

 例３） 
01 23 45 67 89 AB CD EF      “word width”を 4 に設定後 SWAP を実行すると 
バッファの内容は以下のようになります。  
67 45 23 01 EF CD AB 89  

 

 

Fill 

指定した値でバッファの内容を書き換える際に使います。 

バッファの開始アドレス、終了アドレス、及び書き換える値を入力し実行します。 

 

Copy 

バッファ上のデータを別のアドレスへコピ－します。 

コピーする元の開始アドレス、終了アドレス、コピ－先のアドレスを入力し実行します。 

 

Search 

指定した一連のデ－タを検索します。 

検索するデータを入力し実行します。 

 

Undo 

メモリバッファのデ－タを変更しようとするとき、そのペ－ジの変更部分は反転表示されます。 

この機能を選ぶと反転領域の変更を取り消します。 

ただし、変更したデ－タがスクロ－ルされて画面から消えたり、別のコマンドによって選択が解除さ 

れると Undo できなくなります。 

 

 CHKSum-H 
  From Address と To Address のボックスにアドレスを入力し ChkSum 
  ボタンを押すことによりそのアドレス範囲のサムを求めることが出来ます。 
  計算結果は下記 ( )のなかに表示されます。 
  CHKSum-H（ＸＸＸＸＸＸＸX） 
 
  ワンチップマイコン等の書き込みで、デバイスの書き込み範囲が限定されるデバイスの 
  データのチェックサムの確認するときなどに有効です。 
 

（２）ロジックデバイスのバッファ編集 

メモリバッファは１６進数のデ－タ値の代わりに固有のヒュ－ズマップが表示されます。 
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このモ－ドにおいて、Ｘは切れたヒュ－ズを表し、－は元のままのヒュ－ズを表します。 

各ボタンの機能は次の通りです。 

 

Radix 

Hex/decimal フォ－マットのメモリアドレス表示を切り替えます。 

Fill 

指定した値でバッファを書き換える際に使います。 

開始アドレス、終了アドレス、コピ－されるメモリブロックの値を入力し実行します。 

 

Undo 

メモリバッファのデ－タを変更しようとするとき、そのペ－ジの変更部分は反転表示されます。この 

機能を選ぶと反転領域の変更を取り消します。 

ただし、変更したデ－タがスクロ－ルされて画面から消えたり、別のコマンドによって選択が解除さ 

れると Undo できなくなります。 

 

Modify Vector ( PLD を選択時に有効) 
Menu       Device / Modify vector 

Hot Key     Alt-V 

  この機能は PLD を選択したときに有効になります。デバイスにヒューズデータを書込み後、そのデバ 

  イスの機能をテストするためのテストベクターを修正するモードです。 

 

  テストベクターは、他のＰＬＤデザインツールで書き込みデータ作成後その PDL 用に生成されます。 

デザインツールで作成された JEDEC ファイルにはヒューズデータとテストベクターがついてい

ます。このファイルを M1881XP/UXP にロードする事によりヒューズデータとともに、テストベ
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クターもバッファに読み込まれます。ＰＬＤにヒューズデータを書込後、テストを行います。 
 

デバイステストのためのベクタを変更する際に使用します。 

このテストベクタは、通常、他のソフトウェアパッケ－ジでデバイス回路設計が終了した際に作られます。

１８８１ＸＰ/ＵＸＰへダウンロ－ドされた JEDEC ファイルには、デバイスの正常なプログラミングや各

機能テストのためのテストベクタが含まれているものもあります。 

次のような画面が表示されます。 

 

 

 
 
 
Undo 
メモリバッファのテストベクターを変更しようとするとき、そのペ－ジの変更部分は反転表示されます。 

この機能を選ぶと反転領域の変更を取り消します。 

ただし、変更したデ－タがスクロ－ルされて画面から消えたり、別のコマンドによって選択が解除さ 

れると Undo できなくなります。 

 
Insert 

画面下の Clipboard の内容のテストベクターを Vector 挿入し編集することが出来ます。 

クリップボ－ドの内容が現在カ－ソルのあるひとつ前のラインに挿入されます。 

 

  Copy 

カ－ソルがあるラインをクリップボ－ドへコピ－します。 
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   Cut 

カ－ソルがあるラインをクリップボ－ドへ切り取ります。 

「Insert」と共用してデ－タの移動が行えます。 

 
Edit the test vector 
ベクタは標準の JEDEC フォ－マットに入っており、ベクタバッファは列（ベクタ番号に一致）と行 

（ピン番号に一致）に整列しています。 

次のテストコンディションコ－ドがテストベクターとして使用できます。 

0 Drive input low 

1 Drive input high 

C Drive input low、high、low 

D Drive input high、low 

F Float input or output 

H Test output high 

K Drive input high、low、high 

L Test output low 

N Power pins and outputs not tested 

U Drive input low、high 

X Output not tested、input default level 

 (The default level is set in Options| Operation options) 

Z Test input/output for high impedance 

 
 

 

・Blank check a device（ブランクチェック） 
１．ソケットにデバイスを挿入します。 

２．対象デバイスに設定されていなければ、デバイス選択をします。 

３．以下の操作で Blank check 処理を始めます。 

Menu： Device→Blank check 

Hot－key： Alt－B 

 

 

・Reading a device（読み込み） 
１．ソケットにデバイスを挿入します。 

２．対象デバイスに設定されていなければ、デバイス選択をします。 

３．以下の操作で Read 処理を始めます。 

Menu： Device→Read 

Hot－key： Alt－R 

 

 

・Program a device（プログラミング）  
デバイスのプログラムの前にデバイス情報等を含んだファイルをメモリバッファへ読み込むか 

（“Load File”）マスターROM を“READ”してください。 

１．ソケットにデバイスを挿入します。 

２．対象デバイスに設定されてなければ、デバイス選択をします。 

３．以下の操作で条件設定をします。 

Menu： Options→Operation 

Hot－key： F4 

４．３．で設定した処理に従い各処理を始めます。 

Menu： Device→Program/Auto 

Hot－key： Alt－P 
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・Verify a device（ベリファイ）  
１．デバイスが挿入されていなければ、ソケットに挿入して下さい。 

２．対象デバイスに設定されていなければ、デバイス選択をします。 

３．１８８１ＸＰ/ＵＸＰはメモリバッファの内容とデバイスをベリファイします。 

正しいファイルが読み込まれていなければ、読み込んで下さい。 

４．以下の操作でベリファイ処理を始めます。 

Menu： Device→Verify 

Hot－key： Alt－V 

 

・Erase a device（イレ－ス） 
１８８１ＸＰ/ＵＸＰによって消去出来るデバイスに限り可能です。 

１．ソケットにデバイスを挿入します。 

２．対象デバイスに設定されていなければ、デバイス選択をします。 

３．以下の操作で Erase 処理を始めます。 

Menu： Device→Erase 

Hot－key： CTRL－F1 

４． “Are you sure you want to erase the device？”のメッセ－ジが出たらＯＫをクリック又は ENTER

キ－を押します。 

 

 

・Comparing a device（デバイスの比較） 
メモリバッファの内容と対象デバイスの内容を比較します。 

全ての相違を見つけてリスト表示します。 

１．ソケットにデバイスを挿入します。 

２．対象デバイスに設定されていなければ、デバイス選択をします。 

３．以下の操作で Compare 処理を始めます。 

Menu： Device→Compare 

Hot－key： CTRL－F3 

 

 

・Secure device（デバイスの保護） 
Menu： Device→Secure 

Hot－key： 無し 

ある種のデバイスには、上書きやデバイスの読み込みを防止するなどデバイス保護に使われるセキュリ 

ティ－スイッチを持っています。セキュリティ－スイッチをＯＮにした後は、そのデバイスを読むこと 

もデ－タ比較もできなくなります。 

 

 

・Function Test（機能テスト） 
Menu： Device→Function Test 

Hot－key： Alt－T 

デバイスへテストベクタを適用させ、期待値（テストベクタを含む）と出力を比較します。 

成功したか失敗したかをメッセ－ジで表示します。 

 

 

・Configration（環境設定） 
Menu： Device→Configration 

Hot－key： Alt－G 

デバイス内の一部のアドレスのみをプロテクトする際に利用します。 

デバイスがこの機能に対応可能な場合のみ使えます。 

 



ＭＯＤＥＬ－１８８１XP/UXP オペレ－ションマニュアル 

 

ＭＩＮＡＴＯ ＥＬＥＣＴＲＯＮＩＣＳ ＩＮＣ． 

27 

・Memory Protect（メモリ保護） 
Menu： Device→Memory Protect 

Hot－key： 無し 

メモリを保護出来るデバイスにのみ使用できる機能です。 

メモリが保護された後はデ－タを消去できません。 

 

Options Commands（オプションコマンド） 
 

・Parameters（アルゴリズムパラメ－タの変更） 
Menu： Options→Parameters 

Hot－key： F3 

対象デバイスのプログラム電圧を変更します。 

（不用意に使用するとデバイスに損害を与えることがあります。ご注意下さい。） 

※ １８８１ＸＰ/ＵＸＰでサポ－トされていないデバイスをプログラムする場合は 

 次のように操作して下さい。 

１．作業対象デバイスと同じアルゴリズムを使用しているデバイスを選択して下さい。 

２．デバイスのプログラムのパラメ－タを変更して下さい。 

３．デバイスをプログラムして下さい。 

プログラミングパラメ－タは一時的に使用するものなので、保存はできません。 

新しいデバイスを選択するか、１８８１ＸＰ/ＵＸＰソフトウェアを終了すると、初期パラメ－タへ自動

復帰します。 

 

 

・Operation（デバイス操作オプション） 
Menu： Options→Operation 

Hot－key： F4 

以下のオプションが設定可能です。 

（デバイスによって設定できる項目は変化します。） 

 

 ・Number Settings 
 

Start address End address 
編集バッファの開始アドレスと終了アドレスを設定します。 

デバイスのある領域にプログラムしたい場合、それに従って開始アドレスと終了アドレスを 

設定できます。この機能はデバイスがこの方法によってプログラム出来る場合のみ表示されます。 

 

Buffer Size 
メモリバッファのサイズを設定します。 

対象デバイスよりも大きなファイルをメモリにダウンロ－ドする場合は、この値を増やします。 

 

Auto Inc.Start 
メモリデバイス専用の機能です。自動インクリメントの開始アドレスを指定することで、個別にデ 

－タバッファを編集することなしに順次連続してプログラムすることが出来ます。 

 

Auto Inc.End  
メモリデバイス専用の機能です。自動インクリメントの終了アドレスを指定します。 

 

Auto Inc.Value 
自動インクリメントの値をセットします。 

 

・Options 
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Insertion Test 

デバイス挿入テストを行う場合このボックスをチェックして下さい。 

 

Blank Check 

プログラミングの前にブランクチェックを行う場合このボックスをチェックして下さい。 

 

Verify Passes 

プログラミングが完了した後、ベリファイを行う場合このボックスをチェックして下さい。 

 

Auto increment 

自動インクリメント機能を使う場合このボックスをチェックして下さい。 

 

Device ID Check 

デバイス選択毎にデバイス ID のチェックを行なう場合このボックスをチェックして下さい。 

ID の正しくないデバイスに対してはエラ－を表示します。 

 

Program 

プログラム機能を使う場合このボックスをチェックして下さい。 

 

Memory Protected 

メモリプロテクト機能を使う場合このボックスをチェックして下さい。 

 

Auto Erase/Over Write 

旧デ－タを自動消去して新デ－タを書込む場合このボックスをチェックして下さい。 

 

Function Test（PLD デバイス専用） 

プログラミングが完了後、メモリ上のテストベクタを使用してチェックする場合このボックスをチ 

ェックして下さい。 

 

Secure aft. Prog. 

プログラミング完了後のデバイスに対して保護を行う場合このボックスをチェックして下さい。 

 

Fun Tst aft. Secure（PLD デバイス専用） 

保護のかかった後のデバイスをテストベクタを使ってテストする場合このボックスをチェックして 

下さい。 

 

・Verify Option 
Verify Passes が可能なとき設定できます。 

 

(1) Twice Vcc＝±５％ 

２回のベリファイを１回目は Vcc＋５％で、２回目は Vcc－５％で行います。 

例：Vcc が 5.0v の場合、１回目のベリファイを 5.25v、２回目を 4.75v で行います。 

 

(2) Twice Vcc＝±１０％ 

２回のベリファイを１回目は Vcc＋１０％で、２回目は Vcc－１０％で行います。 

例：Vcc が 5.0v の場合、１回目のベリファイを 5.5v、２回目を 4.5v で行います。 

(3) Once 

Vcc 電圧で１回だけベリファイします。 

 

・FunTest Voltage（PLD デバイス専用） 
Function test か Function test after secure が可能なとき設定できます。 
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(1) Twice Vcc＝±５％ 

２回のベリファイを１回目は Vcc＋５％で、２回目は Vcc－５％で行います。 

例：Vcc が 5.0v の場合、１回目のベリファイを 5.25v、２回目を 4.75v で行います。 

 

(2) Twice Vcc＝±１０％ 

２回のベリファイを１回目は Vcc＋１０％で、２回目は Vcc－１０％で行います。 

例：Vcc が 5.0v の場合、１回目のベリファイを 5.5v、２回目を 4.5v で行います。 

 

(3) Once 

Vcc 電圧で１回だけベリファイします。 

 

・FunTest Display（PLD デバイス専用） 
Function test か Function test after secure が可能なとき設定できます。 

機能テスト時の画面オプションを設定します。 

 

(1) Error only 

機能テスト中、見つけられたエラ－だけが画面上に表示されます。 

 

(2) All 

機能テスト中のすべてのメッセ－ジが表示されます。 

 

(3) Step by Step 

すべてのステップで、初めに示されたメッセ－ジが表示されます。 

 

・Vector 'X's state（PLD デバイス専用） 
Function test か Function test after secure が可能なとき設定できます。 

テストベクタ値を設定します。 

 

(1) Low 

すべてのテストベクタをロ－入力とします。 

 

(2) Hight 

すべてのテストベクタをハイ入力とします。 

 

(3) HightZ 

すべてのテストベクタを高インピ－ダンス入力とします。 

 

 

・AutoInc.data format 
自動インクリメントデ－タのフォ－マットを設定します。 

 

  (1) Binary 

  (2) ASCII Hex. 

  (3) ASCII Decimal 

  (4) Modulo-26 

 

 

・Parallel Port（パラレルポートの選択） 
Menu： Options→Parallel Port 

Hot－key： F5 

プログラマを接続するパラレルポートを選択します。 
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・Statistic（統計） 
Menu： Options→Statistic 

Hot－key： F6 

書き込みの回数や Fail の回数を設定します。 

 

・Action 
  動作状況を設定します。 

 

  Count 

  設定された項目を実行するとカウントします。 

 

  Alarm 

  設定したカウント数に達した時に、画面に表示して知らせます。 

 

・Active 
   カウントする動作項目を選択します。 

 

    Mass Production 

    Program 

    Verify 

    Blank Check 

    Erace 

    Memory Protect 

 

 ・Operation Counter 
 

   Current Count 

   現在のカウント数 

 

   Target Count 

   カウントの設定数 

 

 ・Failure Counter 
 

   Current Failuer 

   現在の Fail のカウント数 

 

   Max. Failuer 

   Fail カウントの設定数 
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Diagnostics Commands（診断コマンド） 
 

・Self Test 
Menu： Diagnostics→Self Test 

Hot－key： F7 

以下のオプションが設定可能です。 

 

・Range 

ソケットのすべてのピンをテストするときは、All pins を選択して下さい。 

特定のピンをテストするときは、One pin を選択し、Pin Number を指定して下さい。 

 

 

・Mode 

選択されたオプションの連続したテストを行うには Loop を選択して下さい。 

Cancel をクリックするか ESC キ－を押すまでテストを繰り返します。  

Single を選択すると、テストを１回だけ実行します。 

 

 

・Test Items 

 

Parallel Port 

パラレルポ－トのテストにはこのオプションを選択して下さい。 

 

LED Display 

１８８１ＸＰ/ＵＸＰの LED のテストにはこのオプションを選択して下さい。 

 

Pin Driver 

１８８１ＸＰ/ＵＸＰのピンドライバ－のテストにはこのオプションを選択して下さい。 

Driver Option で選択されているオプションが、どのコンポ－ネントをテストするか決定します。 

 

DAC Voltage Drop 

DAC とソケット上のピン間での DAC 出力低下をテストするときにはこのオプションを選択して下さい。 

電圧差は回路上のスイッチングコンポ－ネント等により引き起こされます。 
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・Driver Options 

Pin Driver が Test Items で選択されていれば、次のオプションがテスト可能です。 

 

TTL  

TTL 出力をある特定のピンに出力させるテストを行うためにはこのオプションを選択して下さい。 

TTL の、high、low、高インピ－ダンス、Z 等がテストされます。 

 

DAC0 

１番目の AD コンバ－タ DAC0 をテストするときはこのオプションを選択して下さい。 

All pins を選択すれば、全てのピンをテストします。 

One pin を選択すれば、指定したピンのみをテストします。 

 

DAC1 

２番目の AD コンバ－タ DAC1 をテストするときはこのオプションを選択して下さい。 

All pins を選択すれば、全てのピンをテストします。 

One pin を選択すれば、指定したピンのみをテストします。 

 

DAC2 

３番目の AD コンバ－タ DAC2 をテストするときはこのオプションを選択して下さい。 

All pins を選択すれば、全てのピンをテストします。 

One pin を選択すれば、指定したピンのみをテストします。 

 

DAC3 

４番目の AD コンバ－タ DAC3 をテストするときはこのオプションを選択して下さい。 

All pins を選択すれば、全てのピンをテストします。 

One pin を選択すれば、指定したピンのみをテストします。 

 

GND 

指定したピンの物理的なグランド結合をテストします。 

 

VGND 

指定したピンのシステムグランドをテストします。 

 

 

 

各設定の後、execute ボタンを押します。 
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付録：主要エラ－メッセ－ジ集 
  

・Device Code unmatched！ 
デバイスコ－ドが間違っています。正しい対象デバイスを選択して下さい。 

対象デバイスがリストに無い場合は、ソフトウェアがサポ－ト前の古いバ－ジョンである可能性があり 

ます。最新のリリ－ス版ソフトをインスト－ルして下さい。 

対象デバイスが、既にサポ－トされているデバイスと同じアルゴリズムを使用している場合、対象デバ 

イスとみなして使用することが可能です。 

操作オプションの設定により、デバイスコ－ドのチェックを不能にすることも可能です。 

 

・Device inserted backward or damaged already！ 
間違った方法で挿入されているか、デバイスに損傷があるときに表示されます。 

デバイスが正しく挿入されているか確認して下さい。 

そうでなければ、別のデバイスを用いてプログラムのアルゴリズム等が正しいか確認して下さい。 

 

・Device inserted upwards ％d slot(s) 
デバイスが正しく挿入されていません。 

デバイスを取り除き、正しく挿入して下さい。 

 

・Device insertion error or damaged already！ 
ソケットにデバイスがあるか接触不良かを判断した結果、デバイスが正しく挿入されていない又は損傷 

があることを示しています。 

デバイスが正しく挿入されているか確認して下さい。 

そうでなければ、別のデバイスを用いてプログラムのアルゴリズム等が正しいか確認して下さい。 

 

・File write error！ 
ファイルをディスクに保存している際のエラ－です。 

ディスクにファイルが入るだけの充分な空き容量があるか、また、ディスクがライトプロテクトされて 

いないかチェックして下さい。これはネットワ－ク上で、ファイルを保存しようとするディレクトリー 

の使用権利を持たないユ－ザの場合よく起こります。 

別のディレクトリーかディスクを使用して下さい。 

 

・Function code has not been initialized yet！ 
デ－タファイルが正しくないことを指示しています。 

正しいデ－タで再度試して下さい。 

 

・MODEL－1881ＸＰ/ＵＸＰ not found、do you want to retry? 
１８８１ＸＰ/ＵＸＰがパラレルポ－トに繋がっていません。 

１８８１ＸＰ/ＵＸＰの電源が入っているか確認して下さい。 

また PC と１８８１ＸＰ/ＵＸＰとのパラレルポ－トの接続もチェックして下さい。 

別のデバイスが繋がっている場合、そのデバイスを外し１８８１ＸＰ/ＵＸＰを接続して下さい。 

 

・MOS technology hex file can be 64KB maximum！ 
バッファの内容を hex ファイルで保存する際、サイズが６４KB より大きな場合に表示されます。 

それでも保存しようとする場合は、最初の６４KB のみが保存され、残りのデ－タは失われてしまいます。 

バッファ全体の保存が必要なときは別のファイルフォ－マットを選んで下さい。 
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・Manufactures Code unmatched！ 
１８８１ＸＰ/ＵＸＰがデバイス ID のチェックを行ったときに表示されます。 

デバイスコ－ドが間違っています。正しい対象デバイスを選択して下さい。 

対象デバイスがリストに無い場合は、ソフトウェアがサポ－ト前の古いバ－ジョンである可能性があり 

ます。最新のリリ－ス版ソフトをインスト－ルして下さい。 

対象デバイスが、既にサポ－トされているデバイスと同じアルゴリズムを使用している場合、対象デバ 

イスとみなして使用することが可能です。 

操作オプションの設定により、デバイスコ－ドのチェックを不能にすることも可能です。 

 

・No device on socket！ 
１８８１ＸＰ/ＵＸＰがソケット上のデバイスを認識していません。 

挿入されているデバイスが損傷している可能性があります。 

別のデバイスに変えて再度試して下さい。 

 

・No test vectors in the buffer！ 
メモリバッファにテストベクタが含まれていません。 

１８８１ＸＰ/ＵＸＰで PLD のベリファイや機能テストを試す際このメッセ－ジが表示されます。 

機能テストを行う前に、テストベクタを含んだファイルをダウンロ－ドして下さい。 

テストベクタは通常 JEDEC ファイルに含まれています。 

 

・Over current detected！ 
過電流が見つかりました。 

デバイスが損傷している又はショ－トしている可能性があります。 

チェックし、再度試して下さい。 

 

・Poor contact at pin %s 
１８８１ＸＰ/ＵＸＰはプログラミングやデ－タ消去等の前に挿入テストを行います。 

このメッセ－ジは、ソケットが汚れているか、デバイスが損傷していることを示しています。 

ソケットを清掃するか、別のデバイスを挿入して下さい。 

 

・Record checksum/length error！ 
間違ったファイルフォ－マット形式が選択されたか、又は入力ファイルに間違ったレコ－ドがある場合 

に表示されます。正しいファイルフォ－マット形式を選択するか、入力ファイルの新しいコピ－を入手 

して下さい。 

 

・The pin number of test vectors in the buffer unmatched！ 
テストベクタが実際にデバイス上で見つかったものと異なるピン番号の場合に表示されます。 

これは、対象デバイスが間違って設定されている場合や、間違ったファイルのテストベクタがメモリに 

読み込まれた場合、及び４８ピン以上のデバイスのアダプタが必要な場合に起こります。 

ファイルとデバイスが該当するものかどうか確認して下さい。 

アダプタが必要なデバイスにはテストベクタを使用しないで下さい。 

 

・The system is in demo mode！ 
ソフトウェアが１８８１ＸＰ/ＵＸＰの起動を確認出来なくて Demo mode になっています。このモ－ドで

はプログラム（のいくつかは）は動きますがいくつかのハ－ドウエア機能を実行できません。 

 

・This function is not supported in demo mode！ 
現在 Demo mode で、選択した機能が Demo Mode ではサポ－トされていないことを指示しています。 
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・Unexpected code/data/end－of－file/run－time instruction reached！ 
 入力ファイルが壊れているか、間違ったフォ－マットです。 

 

・User break！ 
このメッセ－ジは操作中、Cancel したとき必ず表示されます。 

 

・Wrong file format or file was damaged！ 
間違ったフォ－マットの入力ファイルが選択されました。 

入力ファイルの正しいフォ－マットを選択して下さい。 

 

 

※他のエラ－メッセ－ジについては、ソフト上のヘルプをご覧下さい。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


