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Preview 

 

Dear Customer, 

We are pleasure to see you purchasing Minato Gang Programmer MODEL400 Series. 

This manual explains how to use MODEL400 Series correctly, so please read this 

manual before operation. 

 

Register for Warranty 

MINATO ADVANCED TECHNOLOGIES will implement support for our products, 

please register all the information on our web. 

 

Before register please check below 3 items about the programmer: 

MODEL 

Serial Number (see Rear Panel) 

Version (see operation manual CD-ROM) 

 

The warranty does not apply to some problem, please read ”Warranty terms” for 

detail. 

 

 

MINATO ADVANCED TECHNOLOGIES INC. (Home Page) 
 
https://www.minatoat.co.jp/ 
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PC Requirements for control M400 

 

OS requirements 

 Windows XP （SP3 higher） 

 Windows Vista 

 Windows 7 ( 32bit, 64bit ) 

 Windows 8, 8.1 ( 32bit, 64bit ) 

 Windows 10 (64bit ) 

 Windows 11 (64bit ) 

 

Recommended PC requirements 

 CPU  Pentium4 1GHz or Higher 

 RAM  512MB or Higher 

 Hard disk 1GB or Higher free space 

 Interface USB2.0 or Higher 

 USB  More than 1 

 CD Driver CD-ROM 
 

 

The free space of Hard disk depends on the target device which should be 

programmed. Please prepare enough space for large capacity device programming. 

First time connecting M400 Series to PC, please read below notice items. 

 

[Notice for first time connecting to PC ] 
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Simple Guide 
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MODEL404, 404e+ 

MODEL408, 408e+ 

MODEL416, 416e+ 

MODEL400 Series Packing list 

Before installing your programmer, please carefully check that your package include 

all next mentioned parts. If you find any discrepancy or if any of these items are 

damaged, please contact distributor or Minato directly. 
 

[Packing list] 

 MODEL400 Series 

(MODEL404, 404e+ MODEL408,408e+ MODEL416,416e+) 

 

 MODULE ( SU400-48DP/3v )   

※The MODULE number for each MODEL 

 (MODEL404, 404e+ / 1pcs, MODEL408, 408e+ / 2pcs , MODEL416, 416e+ / 4pcs ) 

 

 Power Cable 

 USB Cable 

 CD   (MODEL400 Series control software, USB driver, Operation manual ) 
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Warranty Terms 

Minato gives a guarantee on programmer for one-year from the date of purchase (Just 

for customer who has registered their programmer). The warranty does not apply to 

products on some conditions, so please read below contents. 

Warranty Period 

One-year from the date of purchase. 

 

Warranty Items 

1. Less than one-year after purchasing. 

2. Having registered your programmer. 

3. Does not caused by abnormal operation. 

4. MODEL400 Series Hardware is defective. 

5. This warranty is valid only in Japan. 

 

Pay for repair 

Even during warranty period, warranty is invalid for below items: 

1. Programmer has not been registered. 

2. Have not registered the full information. 

3. Damage caused by inappropriate use. 

4. Damage caused by natural disaster. 

 

Exempt of Warranty 

Minato is not liable for: 

1. IC and data to program. 

2. Direct and indirect cost due to damage of programmer. 

3. Programmer be used oversea (not in Japan). 

4. Damage caused by using third party items(example: adapter, software). 

5. Repair or modification by unauthorized party. 

6. Damage caused by inappropriate use or handling. 

7. Version up of MODEL400 Series. 

Version-up for new device is not free. Please see ”maintainance of M400 Series” for 

detail. 

 

Special note 

1. Register will be ok after you sending all the informations to Minato. 

2. You should pay for the transportation fee from you to Mianto. 
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3. Please keep the box provided by Minato which can be reused while transportation 

for repair. Please make sure the package is strong, otherwise you should pay for 

the damage of programmer. 

4. Minato will pay for the transportation fee after repairing. 

5. This manual will be updated without notice. 

6. Any incomprehension please contact us. 
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Maintainance of M400 Series 

To ensure that your programmer continue to meet good performance and your request. 

 

Warranty of M400 Series 

One-year warranty from the date of purchase from Minato (Just for customer who has 

registered their programmer). Please see “warranty terms“ for detail. 

 

Version up for M400（IC/software support） 

New IC can be supported by updating the software of programmer. Version-up to add 

new IC support is not free of charge even within warranty period. 

If there’s defective of our software, the update is free. 

 

Calibration 

M400 Series is mass production equipment, please maintain the programmer every 

day and calibrate the programmer per year. 

 

About repair, calibration and version up 

Minato does not provide on-the-spot service no matter free charge or not. And we can 

not provide spare programmer, please understand. Customer should pay for the 

transportation fee from you to minato for repair, calibration and version up. Minato 

will bear the transportation cost for return. 
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Safety Precaution 

Warning and Cautions 

This operation manual includes safety precautions for safely use M400 Series 

programmer. To prevent the operator or others people from injury and property 

damage, please following below pictographs to operate.  

Before reading this manual, fully understand these pictographs and the meanings. 

Keep this manual at hand and refer to it while necessary. 

 

 

 

 

 

Explaination of Pictographs 

Warning 

Indicates a potential hazardous situation in which 

the operator would be killed or seriously injured 

unless this precaution is observed. 

Cautions 

Indicates a potential situation in which the operator 

would be injured or property would be damaged 

unless this precaution is observed. 
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 WARNING 

 

 

 

Making sure to follow warnings and cautions while operation the 

programmer. 

 

 

 

Do not disassemble or modify the programmer. It may cause a fire or 

electric shock. 

 

 

 

 

When finding a smoke, abnormal smell or sound, please remove the 

power plug immediately. Otherwise it may cause a fire or electric 

shock due to short-circuit. 

 

 

 

 

If the programmer is dropped or shocked, please remove the power 

plug immediately. Otherwise it may cause a fire or electric shock due 

to short-circuit.  

Consult with Minato or distributor. 

 

 

 

 

If any liquid or foreign matter enters the programmer, please remove 

the power plug immediately. Otherwise it maybe will be caused a fire 

or electric shock due to short-circuit.  

Consult with Minato or distributor. 

 

 

 

Unplug Power Cord 

Unplug Power Cord 

Unplug Power Cord 

 

Do Not Disassembled 

Compulsion 

Compulsion 
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 Cautions 

 

 

 

The operator should fully understand the manual before operation. 

Miss operation may damage the programmer or ICs. 

 

 

 

 

 

Before touching the programmer, please touch a nearby large metal to 

remove static electricity from your body. 

Static electricity may damage the programmer or Ics.  

 

 

 

Please clean the surfaces, the socket and the air filter screen of 

programmer. 

Dusts may cause a fire or breakdown, so please clean them at regular 

intervals. 

 

 

 

 

Do not program IC when Empty Socket (red LED) is indicated. It means 

the contact check is failed and programming maybe damage the Ics or 

programmer caused by the heat. 

 

 

 

 

 

Please confirm the CheckSum for PASS/FAIL. 

Avoiding NG Ics are mixed with OK Ics. 

 

 

 

 

Compulsion 

 

Compulsion 

 

Compulsion 

 

Compulsion 

 

Compulsion 
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Caution for accessories 

Standard power cable complies with Japanese regulation. 

If you will use this programmer in others country, please follow the 

local safety Standard. 

 

 

Do not execute the self-test of the programmer without removing the 

adapters or the Ics. 

It may damage adapters or ICs. 

 

 

Compulsion 

 

Compulsion 

 



Contents 

13 

M400-020A-K6 
 

 

Contents 

Contents 

PREVIEW .................................................................................................................................... 2 

PC REQUIREMENTS FOR CONTROL M400 ............................................................................ 3 

SIMPLE GUIDE ......................................................................................................................... 4 

MODEL400 SERIES PACKING LIST ........................................................................................ 5 

WARRANTY TERMS .................................................................................................................. 6 

Warranty Period ....................................................................................................................... 6 

Warranty Items ......................................................................................................................... 6 

Pay for repair ............................................................................................................................ 6 

Exempt of Warranty ................................................................................................................. 6 

Special note ............................................................................................................................... 6 

MAINTAINANCE OF M400 SERIES ......................................................................................... 8 

Warranty of M400 Series .......................................................................................................... 8 

Version up for M400（IC/software support） ............................................................................. 8 

Calibration ................................................................................................................................ 8 

About repair, calibration and version up ................................................................................. 8 

SAFETY PRECAUTION ............................................................................................................. 9 

Warning and Cautions .............................................................................................................. 9 

Explaination of Pictographs ..................................................................................................... 9 

CONTENTS .............................................................................................................................. 13 

OUTLINE ................................................................................................................................. 15 

Outline .................................................................................................................................... 15 

Features .................................................................................................................................. 15 

Specification ............................................................................................................................ 15 

MODEL400 SERIES ELEMENT AND FUNCTION ................................................................. 16 

MODULE POSITION ............................................................................................................... 17 

OPTIONAL ITEMS ................................................................................................................... 20 

ABOUT MODULE .................................................................................................................... 21 

Types of Module ...................................................................................................................... 21 

Module Position ...................................................................................................................... 22 

ABOUT VARIOUS ADAPTERS ................................................................................................ 24 

INSTALLATION ....................................................................................................................... 26 

Installation of Software .......................................................................................................... 26 

Installation for Hardware ....................................................................................................... 28 

NOTICE FOR FIRST TIME CONNECTING TO PC ................................................................. 31 

MODEL400 SERIES CONTROL SOFTWARE ( UNIVERSAL CONTROL PROGRAM ) .......... 35 



Contents 

14 

M400-020A-K6 
 

 

Outline .................................................................................................................................... 35 

Start Running the Universal Control Program ..................................................................... 36 

Description of the main screen ............................................................................................... 38 

BASIC OPERATION ................................................................................................................. 47 

Select Device ........................................................................................................................... 48 

COPY ....................................................................................................................................... 51 

ERASE .................................................................................................................................... 53 

BLANK .................................................................................................................................... 55 

PROGRAM .............................................................................................................................. 57 

VERIFY ................................................................................................................................... 59 

CONT ...................................................................................................................................... 61 

Contact check, ID check .......................................................................................................... 64 

Protect ..................................................................................................................................... 65 

FUNCTION DESCRIPTION ..................................................................................................... 66 

Load file ................................................................................................................................... 67 

Save buffer .............................................................................................................................. 71 

Buffer Editor (Edit) ................................................................................................................. 73 

Project Management ............................................................................................................... 89 

Lot Management ..................................................................................................................... 91 

Operation Status ..................................................................................................................... 94 

Auto Start................................................................................................................................ 98 

PROGRAMMER SETTING ..................................................................................................... 101 

OPERATION ........................................................................................................................... 103 

QUICK START ....................................................................................................................... 109 

TROUBLESHOOTING ........................................................................................................... 111 

TERMINOLOGY ..................................................................................................................... 120 

CONTACTS ............................................................................................................................ 124 

REVISION .............................................................................................................................. 125 

 

 
 



Outline 

15 

M400-020A-K6 
 

 

Outline 

Outline 

M400 Series are Gang Programmer which can be controlled by PC (windows OS) 

software through USB Port and supports large capacity devices. M400 Series are 

equipped with 32Gbyte（256Gbit）SD Memory or 64Gbyte（512Gbit）microSD 

Memory and provide high performance for mass programming . 

 

Features 

 Improved for Operating environment. 

 High programming speed. 

 Equipped with 256Gbit SD Memory. (M404,M408,M416) 

 Equipped with 512Gbit microSD Memory. (M404e+,M408e+,M416e+) 

 Supporting various devices. 

 Sharing the adapters with another MODEL. 

 

Specification 

Item MODEL404 

MODEL404e+ 

MODEL408 

MODEL408e+ 

MODEL416 

MODEL416e+ 

Note 

Simultaneous 

programming 

4 8 16  

Buffer Memory 256Gbit 

e+ : 512Gbit 

   256Gbit 

e+ : 512Gbit 

   256Gbit 

e+ : 512Gbit 

Option 

512Gbit(max.) 

e+ : 

1024Gbit(max.) 

Interface USB USB USB Rev.2.0 

Operating 

Temperature 
5－35 [℃] 5－35 [℃] 5－35 [℃]  

Operating 

Humidity 
   ―    ―    ―  

Power/Frequency AC100-240[V] 

50-60 [Hz] 

AC100-240[V] 

50-60 [Hz] 

AC100-240[V] 

50-60 [Hz] 

 

Power dissipation 60 [VA] (max.) 100[VA](max.) 200[VA](max.)  

Fuse 3 [A] 3 [A] 3 [A]  

Size 230(W)x260(D

)x110(H) [mm] 

380(W)x260(D

)x110(H) [mm] 

380(W)x390(D

)x120(H) [mm] 

 

Weight 2.4 [kg] 5.2 [kg] 9.0 [kg]  
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MODEL400 Series Element and Function 

In order to operate MODEL400 Series properly, please understand the function of 

each part and its name.The details are described in following pages. 

When used, MODEL 400 series of products shall be accompanied by dedicated 

control software and socket unit. Please note that the startup would fail if software 

other than special control software is used. For further information about detailed 

description of special control software, please refer to the Operation Instructions for 

“Control Software of Model 400 Series” in this manual. Please refer to “About socket 

unit” for detailed description of socket unit. 

 

Example)  MODEL404  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

START

STATUS

 

Module Position 

 

Start 

Status LED 

Rear Panel 
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Module Position 

 

Example)  MODEL404 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

SOCKET Number 

Each SOCKET has a corresponding number. And we use “#+number” to express it in 

this manual. 

Example) 

SOCKET 2 is described as ”#2” 

 

Module Connector 

SOCKET Number（#1～#4） 

START

STATUS

1 2 3 4

 

Module 
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Module Connector 

Module Interface Connector 

 

Socket LED（Indicating PASS/FAIL） 

Different color means the operating result. 

PASS  Green 

FAIL  Red 

 

START

STATUS

1 2 3 4
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Rear Panel 

 

 
 

 

 

 

 

 
 

 

 

 
 

 
 

Power Connector 
AC power supply connector with (3A)FUSE. 

 

Power Switch 
 

 

USB Connector 
 

 

Air vent 
Air vent is designed for the external air sucked for cooling the interior of MODEL 400 

series. Please keep the vent unblocked. Please use dust collector etc. to remove 

apparent dust (if any) in air filter. 

 

 

Serial Number 
Each programmer has a unique Serial Number and it will be required for service. 

 

 

Revision Number 
Revision Number of Hardware and it will be required for service. 

 

 

MODEL 404

REV.No

 
Serial Number 

Revision Number 

USB Connector 

Power Connector 

Power Switch 

Air Vent 
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Optional Items 

MODEL 400 series of products are supplied with standard socket unit. 

In addition to standard socket unit, user may optionally use the following socket units 

and adapters. 

Please make sure the socket unit and adapter are matched with the device used. 
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About Module 

There are various Modules. Here just introduce several typical modules and describe 

how to install them on M400 Series. 

For others Module installation, please contact with Minato or distributor. 

 

※Never fail to mount socket unit in the body. No operation would be activated even 

if the product is mounted when the power supply for body is turned on. 

To this end, please properly mount the socket unit before the power supply for body is 

turned on. 

Please note that the device would not run if out socket unit is not mounted when 

operating the body with our special control software. 

 

 

Types of Module 

There are various Modules for M400 Series and here just introduce below three types. 

 

 

① SU400-48DP/3v 

Special purpose module for 3V. 

Many different adapters can be used on this module. 

 

② SU400-48DP/5v (Under development, Optional part ) 

Special purpose module for 5V. 

Many different adapters can be used on this module. 

 

③ SU400-xxxx 

This Module is suitable for some special package which can not be supported by 

above modules. 

 

 

Various Adapters 

All the adapters for M1940 and M1950 also can be used on M400 Series. And above 

Modules are necessary. 

※Please see “About Module” for detail. 
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Module Position 

 

Describe the direction of Module installation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Lock lever (open/close) 
Before inserting device, push up the lever (open) 

After inserting device, push down the lever (close) 

 

IC SOCKET 
Most modules (TSOP, BGA, etc) except DIP can be opened or closed by pressing the 

socket. 
  

Gap of PCB 

To making sure the direction of adapter is correct according to the gap. 

 

  

Lock lever 

(Open / Close) 

IC Socket Gap of PCB 

PASS / FAIL LED 
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Direction of Module installation 

 

 

 
 
 

 

 
 

 

 

 

 

 

In the case of socket unit with locking rod, the locking rod shall be mounted at 

a neighboring point. 

As for socket unit with base plate notch, the notch shall be mounted at a 

neighboring point. 

PASS/FAIL indication LED shall be mounted at a neighboring point in the 

case of locking unit without locking rod and base plate notch. 
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About Various Adapters 

This chapter describes adapters for M400 Series 

 

1. Just adapters which have been supported by M400 Series. 

2. Some others adapter can be supported by M400 Series after version up. (Not all) 

3. Due to too many types adapters, we call them “Various Adapters” 

 

Notice! 

Module SU400-48DP/3v is necessary for adapters. And SU400-48DP/3v is between 

the adapter and M400 Series. 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

IC 

Moudle SU400-48DP/xx is 

necssary 

Various Adapters  

DIP IC Except DIP IC 
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About Installation 
(Software and Hardware) 

    

※Matters needing attention when connecting MODEL400 series of products to PC for 

the first time 

（Important ） 
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Installation 

The CD-ROM contains M400 Series Control software (Universal Control Program),  

USB drive and operation manual. 

In order to control the programmer by software, you must correctly install the USB 

driver and software first. 

※The software must be installed before connecting the programmer with PC. 

 

Installation of Software 

Please insert the CD-ROM to install below software. 

 ・M400 installer.exe  ( M400 Series Control software) 

 ・USB_driver.exe   ( USB Driver ) 

 

It will start to install after double click above software. 

For M400 Series, all above software must be installed before operation. 

Please follow below installation method to install software. 

 

[Installation Method ] 

 

Example) Installation for application program 

        Double click “M400 installer.exe” 

 

 
 

 

 

 

 

 

 

 

 

 

 
 

Click next [next (N) >] 
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Creating a short-cut on the desktop after selecting  
 

 

 

 

 

 

 

 

 

 

 

 

 

This screen means the installation has been fininshed. 

Please click（finish） 

 

※ Installing the USB_driver.exe by the same method. 
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Installation for Hardware 

Before start the Universal Control Program, please connecting M400 Series to PC 

by USB cable. 

 

Windows will detect new hardware, please follow below method to install the driver.   

M400 Series will be detected by windows and installation will start automatically.  

Please insert the CD-ROM. 

 

Setup1  Connecting the USB cable to programmer 

 

 

Setup2  Connecting the USB cable to PC 

（Recommand High-Speed USB 2.0） 

 

Setup3  Power on the M400 Series and make sure the buzzer and status of LED 

are correct. 

 

 

Setup4  Windows will start with “ Found New hardware Wizard” 

 

  

 

 

 

 

 

 

 

 

 

                                       

 
 

Selecting “Install the software automatically (Recommended) 
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Wizard start searching programmer and install driver automatically. 

 
 

Confirming the installation. 
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After successfully installing you will see following window: 

 
 

 

 

 

 

 

 

 

 

 

 

Click “Finish” button to finish the setup. 

 
 

※ Notice ※ 

In addition, MODEL 400 series of products will detect the new hardware in the 

connected unit (COM port), and programmers M416 and M408 will perform hardware 

installation for 4 times and 2 times, respectively. 
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Notice for first time connecting to PC 

After installing the hardware driver 

 

Please perform the following operations after hardware installation. Where the 

following operation is not performed, PC would be unable to identify MODEL400 

series of products. 

 

[For Windows XP (SP3) ] 

① Copy file “usbser.sys” in below folder. 

“C:\Windows\ServicePackFiles\i386”  

or  “D:\Windows\ServicePackFiles\i386” 

 

② Paste “usbser.sys” to below folder. 

“C:\Windows\system32\drivers” 

or “D:\Windows\system32\drivers” 

 

③ Power on the programmer. Perform hardware installation again. Check if 

programmer has been identified upon the completion of installation. 
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④ [ Start ] → [ Setting ] → [ Control Panel ] → [ System ] → [ Hardware ] →
[ Device Manager ] 

 
If you can find the the Model of M400 Series, 

it means the Programmer has been recognized 

and please remember the USB port. 

 
Please click the icon to run the control Software. 

 

 

 

 

 

 

 

 

[ For Windows 7 ] 

 

① [ Start ] → [ Computer ] → [Search] to serach “usbser.sys”. 

 

                
 

 

  

 

 

Keyin “usbser.sys” 
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②”usbser.sys” will be found and copy this 

file to below folder. 

C:/Windows/system32/drivers  

or D:/Windows/system32/drivers 

 

 

 

 

③ Power on both the M400 Series and the PC 

 

[ Start ] → [Setting] → [ Control Panel ] →  

→ [ System ] → [ Hardware ]  

→ [ Device Manager] 

 

If you can find the the Model of M400 Series, 

it means the Programmer has been recognized 

and please remember the USB port. 

 

Please click the icon to run the control Software. 
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M400 Series Control Software 

(Universal Control Program) 

Operation Manual 
 

 

 

This chapter explains how to use this Universal Control Program of M400 Series. This 

Control Software will be updated without giving notice due to improvement. Any 

effects will be fixed by new software.  
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MODEL400 Series Control Software ( Universal Control 

Program ) 

 

Outline 

 

M400 Series Control Software is suitable for MODEL404, MODEL408, 
MODEL416. 

Main features: 

 

① MODEL404, MODEL408, MODEL416 can be controlled by the same software. 

② All the informations of programming can be found on the main screen. 

③ According to the GUI, you can easily program IC, edit buffer and set the parameter 

including the Partiton for NAND. 

④ You can quickly reload all the programming settings by project file. 

⑤ You can set the lot number and get the report by lot function. 

⑥ You can clearly confirm the operation status by log function. 

⑦ With newly-developed ‘Con-current programming method’ start to program 

devices per site. Programming time is significantly shortend by this method for 

auto handler. 

 

※ Operating Environment ※ 

Please follow the “Recommanded PC Requirments” to use this software, otherwise we 

can not guarantee all the function is correct. 
 

※ Notice※ 

① Please close the control software before power off the programmer while the job is 

finished.Otherwise the communicating will be failed and maybe cause a wrong 

operation.  

② Please install the suitable Module before running the control software and the 

Modules must be same for M408 and M416 to avoid breakdown. 
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Start Running the Universal Control Program 

 

After installation was finished, please double click the icon on the desktop. 

 

 

 

And below dialog box will display. 

 
      

      

      

      

      

      

      

     

     

     

 

[ Connect a programmer Dialog box ] 

 

Automatically detect and connect the programmer (Online mode) 

On the dialog box [Connect a programmer], choose [Connect] and click [Select]. If the 

programmer already has been connected to PC correctly, it will be automatically 

detected and the main screen of software will show ［ONLINE］, otherwise it will be 

［OFFLINE］. 

 

In Demo mode, control software performs simulation operation with 

programmer not connected. Do not activate Demo mode when operating 

programmer. 

 

Demo mode for MODEL 404 
On the dialog box [Connect a programmer], choose [Model 404]a nd click [Select],the 

control software will be forced to MODEL 404 Demo mode and [DEMO] will be 

showed on the main screen of software. 

 

Demo mode for MODEL 408 
On the dialog box [Connect a programmer], choose [Model 408] and click [Select], 

the control software will be forced to MODEL 408 Demo mode and [DEMO] will be 

showed on the main screen of software. 
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Demo mode for MODEL 416 
On the dialog box [Connect a programmer], choose [Model 416] and click [Select], 

the control software will be forced to MODEL 416 Demo mode and [DEMO] will be 

showed on the main screen of software. 

 

AutoHandler mode 
On the dialog box [Connect a programmer], choose [Use handler] and click [Select], 

the control software will be forced to handler mode and the status of programmer is 

[OFFLINE] until you start the Autohandler software to control it. 

 

Do not connect programmer 
On the dialog box [Connect a programmer], click [Cancel], the control software will 

force to [OFFLINE] mode (Demo mode for M404). 
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Description of the main screen 

Here will introduce the function of the main screen and the sample is MODEL404(It’s 

the same for MODEL408 and MODEL416 except the programmer’s Model.) 

 

Description of the main screen（MODEL404 Main Screen） 

 
 

 

 

 

 

 

 

 
 

 

 
 

 

 
 

 

 

 

 
 

 

 
 

 

 

① Title bar 

Display the version of the software. 

  

①Title bar 

②Menu bar 

③Tool bar 

④Project informations 

⑦Progress conditions 

⑧Socket status ⑪Status bar 

⑨Log window 

⑩Control panel 

⑥Device information ⑤Data file 
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② Menu bar 

There are below 7 menus, [File], [Edit], [Programmer], [Device], [Operation mode] 

[View], [Help]. 

Each menu contains many functions for operation, example you can select IC by click 

[Select device...] under [Device] menu. 

[File] 

 「Load Project..」 

 「Save Project..」 

 「Load file to buffer」 

 「Save buffer to file」 

 「Config」(Initial setup for system and password is required) 

 「Control of a log file」( Setting of log file) 

 「Pass/Fail counter」(setting of counter) 

 「Verify check sum」(confirm the checksum) 

 「Deletion of the data file」 

 「Open log file」 

 「Recent File」 

 「Exit」 

 

[Edit] 

 「Edit buffer」 

 

[Programmer] 

 「Buzzer」 

 「Self test」 

 「Clear data」 (clear the BufferData of programmer) 

 「File list」 (File list in buffer) 

 「LED check」 

 「Handler position」(For Auto Hadler ：Number the programmers) 

 

[Device] 

 「Select device」 

 「Operation options..」 

 「Writing of unique ID」(For Auto Handler) 

 「Copy」,「Blank check」,「Verify」,「Program」,「Erase」,「Cont」 

 

[Operation mode] 

For mass production and the function can be changed by click [Copy], [Blank check], 

[Verify], [program], [Erase], [cont]. 
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[View] 

 「Toolbar」 

 「Status Bar」 

 「Function progress bar」(Special：Show the progress at the time point when error 

occurs) 

 「Contact check NG mark」(Show/hide error mark in the case of Contact error) 

 「Handler NG code」(For Auto Handler：OFF state normally) 

 「SUM」(Display method of SUM) 

 

[Help] 

 「About UniversalControl Program....」 

 「V_up」 (Version up) (Password is required) 

 「Choice of the language」 
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③ Tool bar 

17 tools were divided to 6 groups [Project], [Data], [Device], [Operation],  

[Connection], [Version]. 

 

[1] Project 

 

Load Project 

Open the Project file which already exists. 

 

Save Project 

Save all the setting to a new Project file. 

 

[2] Data 

 

Load file 

Load the programming file to the buffer of programmer. 

 

Save file 

Save the contents from the buffer to PC as a file. 

 

Buffer Editor 

Open Buffer Editor 

 

[3] Device 

 

Select IC 

Select the IC P/N 

 

Option 

Custom-tailor the operation of device 

 

Access Method 

 

 

[4] Operation 

 

COPY 

Copy data from IC to buffer. 

 

BLANK 

Check whether the IC is empty. 
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VERIFY 

Compare the data of IC with Buffer. 

 

PROG 

Write the data of Buffer to IC. 

 

ERASE 

Clear all the contents of IC 

 

CONT 

It’s a continuous function of ERASE, PROG and VERIFY. 

 

 

[5] Connection 

 

Connect 

Connect the programmer with to PC. 

 

Disconnect 

Force the programmer be offline. 

 

 

[6]Version 

 

Version 

Show the version and copyright of software. 

 

④ Project information 

They are useful for project management. 
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⑤ Data File 

Show the file name, size, CheckSUM and CRC. 

(CheckSUM and CRC are calculated according to the buffer not file, so they will be 

changed after loading another file or editing the buffer) 

 

 
 

 

⑥ Device Information 

Show the P/N and package of Device, and the adapter P/N which should be used. 

 

 
 

⑦ Progress Condition 

Show the counter of Pass/fail/total and all the numbers can be cleared by click [Clear 

Statistics] button. 

Clicking [lot size] button you can set all the parameter about the lot. 

 

 

 

 

 

 

⑧ Socket status 

Show the Site number and the status of each socket. 

 

MODEL404 is showed one site (4 Sockets). 
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MODEL408 is showed 2 sites (8 Sockets). 

 

 
 

MODEL416 is showed 4 sites (16 Sockets). 

 

 
 

The Progress bar shows the status of every operation. 

Example：while you run PROG, it will show PROGRAMMING 0→100%, 

VERIFYING 0→100%. 

 

⑨ LogWindows 

Log window contains the flow-control progress information about almost every 

operation and the log information will be saved automatically. (You can define where 

or how long it will be saved) 
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⑩ Control Panel 

Additionally, the in-service operation mode will be displayed in ONLINE state during 

operating process, and the normal display status would be restored upon the 

completion of operation. 

 

 

 
 

 

You can confirm whether it is running by not only the “Programmer state” but also the 

“Socket status”. 

 

⑪ Status bar 

It’s a simple description of menu or function and it will be displayed by moving 

mouse to certain button.  It also can be hided by selecting [View -> Status Bar] 
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Basic Operation 
This chapter will describe below operatios. 

 

 Power Setting 

 Selcet device  

 Copy   

 Erase   

 Blank check  

 Program   

 Verify   

 Cont   

 Contact and ID check 

 

 

For M400 Series you must use the special control software to operate. 

Here just describe the operation of M404 (It’s the same for M408 and M416 except 

the programmer model.) 
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Basic Operation 

 

Power setting 

Here will describe the sequence of power on. 

You should avoid the noise caused by other machine like electric generator  

and welding machine. 

 

 

※ Notice  

1. Making sure to put M400 Series at a level palce, no shocking 

2. Using dedicated plug seat as AC power  

3. Recommended using 3P plug seat which contains GND 

4. Making sure the power switch are off, then connect the power cable to plug seat. 

5. No IC and Adapter inserting the programmer while power on. (Avoiding be 

damaged) 

 

Power on sequence 

 

① Making sure no IC is in the SOCKET, then turn the power switch to on. 

② About 1 minute later the status LED will turn green and it’s ready for connecting to 

PC. 

③ Click the icon of M400 control software. Normally choose［Connect］ to 

automatically connect to PC. 

④ The IC which is selected last time will be called out automatically on the basic 

screen. 

⑤ Basic Screen 
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Tab ( ① All  ② Only selected type  ③ Only selected manufacturer) 

IC list 

Key in the IC P/N OK 

Title bar 

Select Device 

Click [ Select device ] to choose target IC. 

You can select device by choosing [Device] → [Select device] or click below button 

on the tool bar. 

 

 

The window for selecting device 

 
 

 
     

 

 
 

 

     

 

 

 
 

 

 

 

 

 
Show devices in order 

Clicking title bar the device will be put in alphabetical order. 

 

Scroll bar for device list 

You can find all the supported devices by moving the scroll bar on the right sidebar. 

 

Cancel selecting 

Clicking [Cancel] button to give up your selecting. 
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Confirm the device 

While you clicking the device, all the informaitons will be displayed for your 

confirming. 

 

 
 
All the informations of the device you have selected are  

displayed. 

 

 
 
 

Clicking [OK] button to confirm your selected device and then the device will be 

called out and all the settings are updated. 

 

※Notice※ 

The buffer memory will be initialized after selecting device. 

 
Methods for searching device 

 

 

 

 
 

 

 

 

 

 

 

 

 

① Key in part of the device name 

Key in the device P/N in [Search] Box, the searching will be narrowed down. 

(example： key in”29GL” then just Ics containing ”29GL” will be listed) 

 
[Search] Box is suitable for all Tabs ([All] [Only selected type] [Only selected 

manufacture]) and it’s case insensitive. 

 

 

② Only selected type 

 

 

① 

② 
③ 
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Click the tab of [Only selected type], you can more easily find the device by select the 

[Type] and [Sub type], because just the type you have defined will be listed. 

(example： Set [Type] as”Flash”,and [Sub type] ”512M-bit (x16)”, then just 512Mbit 

Flash will be listed) 

 
 

 

 

If there is no device being displayed, it means this type has not been supported. 

 

③ Only selected manufacturer 

Click the tab of [Only selected manufacture], you can choose the manufacturer of 

device, and then just devices produced by this manufacturer will be listed. 

 
 

 

 

※If there is no device being displayed, it means Device for this manufacturer has not 

been supported . 

 

④ Close the Select device window 

Click [Cancel] button or  to close this window and no device has been selected. 
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COPY 

Using the COPY button to copy data from IC to buffer of M400 Series. 

 

Notice before COPY！ 

1. Please calculate the checksum before copy to confirm whether it is correct. 

2. Just #1Socket can be used for COPY and make sure no IC in others Socket. 

3. If the direction of IC is not corrected, the device may be damaged. 

 

The operation Sequence for COPY 

Example）For M404 

1. Select the correct device 

2. Put IC into #1Socket 

3. Click COPY button 

 

 

Click START (COPY) button, then it will run and while it’s fininshed the LED turn 

green or red (Copy ok: Green; Copy fail: Red). 

 

 

 

           

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 
 

 

 

START

STATUS

1 2 3 4

 

TEXTOOL

248-1282-
00

PAT.No.3763489TEXTOOL

248-1282-
00

PAT.No.3763489

TEXTOOL

248-1282-
00

PAT.No.3763489TEXTOOL

248-1282-
00

PAT.No.3763489

 

A1

CBG176-101A

11×14

In regard to unused, #2, #3 and #4 sockets, the red LED goes ON. 
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Flow chart of COPY 

 

 
 

 

Select device 

 

Put IC into 

SOCKET#1 

Push down the Lock Lever 

COPY 

VERIFY 

PASS/FAIL LED 

Pick up IC 

Supplement 

To modify the setting in "Device operation 

option", skip the VERIFY after COPY. When 

doing so, please be sure to perform data 

validation using SUM and CRC32. 
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ERASE 

 

For EEPROM and FLASH devices, the data can be erased by click ERASE button. 

 

 

Notice before ERASE ! 

The device which is failed by contact checking or ID checking must be removed from 

the module before ERASE, otherwise may damage. 

 

 

The operation Sequence for ERASE 

Example) For M404 

1. Select the correct device 

2. Put the device into#1～#4Socket。 

3. Click Erase button  

※This function will start automatically if you have put devices into all the  

#1～#4Socket. If there is no IC in some socket, the warning message “contact fail” 

will display and the SOCKET LED turn red, the operation is discontinued. 

 

4. If you want to continue this operation, Please click Erase button again. 

5. While it’s fininshed the LED turn green or red (PASS: Green; FAIL: Red) 

6. Upon the replacement of device connected to socket, the ERASE Start button on 

screen or the START button on the body of programmer could be used in addition 

to above-noted toolbar buttons when performing ERASE operation again. Please 

use appropriate operation method. 
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Flow chart of ERASE 

 
 

 

 

 

Select device 

Put IC into Socket 

Push down the Lock Lever 

 

Fail Stop 

Fail Socket is detected through 

connection inspection. 

ERASE 

BLANK 

PASS/FAIL LED 

Pick up IC 

Empty socket is in existence. 

All sockets are connected with device. 

Supplement 

To modify the setting in "Device operation 

option", skip the BLANK after ERASE. 
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BLANK 

 

Click BLANK button to confirm whether the content of IC is empty. 

 

Notice before BLANK ! 

The device which is failed by contact checking or ID checking must be removed from 

the module before blank check, otherwise maybe be damaged. 

 

 

The operation Sequence for BLANK 

Example) For M404 

1. Select the correct device. 

2. Put the device into#1～#4Socket. 

3. Click BLANK button  

※This function will start automatically if you have put devices into all the #1～
#4Socket. 

 

If there is no IC in some socket, the warning message “contact fail” will display and 

the SOCKET LED turn red, the operation is discontinued. 

 

4. If you want to continue this operation, Please click Blank button again. 

5. While it’s fininshed the LED turn green or red (PASS: Green; FAIL: Red) 

6. Upon the replacement of device connected to socket, the BLANK Start button on 

screen or the START button on the body of programmer could be used in addition 

to above-noted toolbar buttons when performing BLANK operation again. Please 

use appropriate operation method. 
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Flow chart of BLANK 

 

 
 

 

Select device. 

Put IC into Socket. 

Push down the Lock Lever. 

Empty socket is in existence. 

 

BLANK 

PASS/FAIL LED 

Pick up IC 

Fail Stop 

Fail Socket is detected through 

connection inspection. 

All sockets are connected with device. 
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PROGRAM 

 

Write the data from buffer to IC. 

 

Notice before PROGRAM ! 

The device which is failed by contact checking or ID checking must be removed from 

the module before program function, otherwise may be damaged. 

 

The operation Sequence for PROGRAM 

Example) For M404 

1. Select the correct device 

2. Put the device into#1～#4Socket 

3.ClickPROGbutton           

 

※This function will start automatically if you have put devices into all the #1～
#4Socket. 

 

If there is no IC in some socket, the warning message “contact fail” will display and 

the SOCKET LED turn red, the operation is discontinued. 

 

4. If you want to continue this operation, Please click Program button again. 

5. While it’s fininshed the LED turn green or red (PASS: Green; FAIL: Red) 

6. Upon the replacement of device connected to socket, the PROGRAM Start button 

on screen or the START button on the body of programmer could be used in 

addition to above-noted toolbar buttons when performing PROGRAM operation 

again. Please use appropriate operation method. 

 

About the PROG operation supported by MODEL400  

MODEL400 enables programmer user to designate appropriate linkage operation 

function.  

This function could be designated with “Device->operation option” selection menu.  

Example 1: BLANK->PROG->VERIFY  

Example 2: ERASE->PROG->VERIFY  

(Initial setting of PROG operation is 

BLANK->ERASE->BLANK->PROG->VERIFY)  

Please establish the setting following the operating instruction on Page 105. 
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Flow chart of PROGRAM 

 

 
 

 

Select device. 

Put IC into Socket. 

Push down the Lock Lever. 

Fail Stop 

Fail Socket is detected through 

connection inspection. 
ERASE 

BLANK 

PASS/FAIL LED 

Pick up IC 

Empty socket is in existence. 

All sockets are connected with device. 

Supplement 

To modify the setting in "Device operation 

option", skip the BLANK and ERASE before 

PROGRAM and the VERIFY after PROGRAM. 

BLANK 

PROGRAM 

VERIFY 

 

All the devices are blank. 
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VERIFY 

 

Compare the data between IC and buffer of M400 Series. 

 

Notice before VERIFY ! 

The device which is failed by contact checking or ID checking must be removed from 

the module before verify function, otherwise maybe be damaged. 

 

 

The operation Sequence for VERIFY 

Example) For M404 

1. Select the correct device 

2. Put the device into#1～#4Socket 

3. ClickVERIFY button              

 

※This function will start automatically if you have put devices into all the #1～
#4Socket. 

 

If there is no IC in some socket, the warning message “contact fail” will display and 

the SOCKET LED turn red, the operation is discontinued. 

 

4. If you want to continue this operation, Please click Verify button again. 

5. While it’s finished the LED turn green or red (PASS: Green; FAIL: Red) 

6. Upon the replacement of device connected to socket, the VERIFY Start button on 

screen or the START button on the body of programmer could be used in addition 

to above-noted toolbar buttons when performing VERIFY operation again. Please 

use appropriate operation method. 
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Flow chart of VERIFY 

 

 
 

 

Select device. 

Put IC into Socket. 

Push down the Lock Lever. 

Empty socket is in existence. 

VERIFY 

PASS/FAIL LED 

Pick up IC 

Fail Stop 

Fail Socket is detected through 

connection inspection. 

All sockets are connected with device. 
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CONT 

 

After clicking CONT button, programmer will carry out ERASE -> BLANK -> 

PROGRAM -> VERIFY automatically. The operation flow is different between 

EEPROM & Flash and EPROM which can not be erased electrically. 

 

Notice before CONT ! 

The device which is failed by contact checking or ID checking must be removed from 

the module before cont function, otherwise may be damaged. 

 

The operation Sequence for CONT 

Example) For M404 

1. Select the correct device 

2. Put the device into#1～#4Socket 

3. ClickCONTbutton              

※This function will start automatically if you have put devices into all the #1～
#4Socket. If there is no IC in some socket, the warning message “contact fail” will 

display and the SOCKET LED turn red, the operation is discontinued. 

4. If you want to continue this operation, Please click cont button again. 

5. While it’s fininshed the LED turn green or red (PASS: Green; FAIL: Red) 

6. Upon the replacement of device connected to socket, the CONT Start button on 

screen or the START button on the body of programmer could be used in addition 

to above-noted toolbar buttons when performing CONT operation again. Please 

use appropriate operation method. 
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Flow chart of CONT（For FLASH/EEPROM） 

 

 
 

  

Select device. 

Put IC into Socket. 

Push down the Lock Lever. 

Fail Stop 

Fail Socket is detected through 

connection inspection. 
ERASE 

BLANK 

PASS/FAIL LED 

Pick up IC 

Empty socket is in existence. 

All sockets are connected with device. 

BLANK 

PROGRAM 

VERIFY 

All the devices are blank. 
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Flow chart of CONT (for EPROM) 

 

 
 

 

Select device. 

Put IC into Socket. 

Push down the Lock Lever. 

Fail Stop 

Fail Socket is detected through 

connection inspection. 

PASS/FAIL LED 

Pick up IC 

Empty socket is in existence. 

All sockets are connected with device. 

BLANK 

PROGRAM 

VERIFY 
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Contact check, ID check 

Contact check 

Contact check is to detect whether the position (direction) of device is correct or the 

device is not damaged ,and this function is carried out before others operation. Since 

there are various specifications of devices, some devices including microcontroller 

does not allow carrying out a contact check, we will define it according to IC and there 

is no menu setting or button for Contact check. 

 

ID check 

ID check is to judge whether selected device is matches the actual device. For standard 

device which has ID, this function will be added automatically and there is no menu 

setting or button for ID check. 

 

 

  



Basic Operation 

65 

M400-020A-K6 
 

 

1.Protection checkbox 

3.Select Button 

2.Setting Protection Edtor 

Protect 

The case, selected device has the lock-bit / sector-protect etc..., is able to set by 

[Device operation options].    

 

・How to use PROTECT 

[Device operation options] is opened by clicked [Device] -> [Operation option...] or 

 on toolbar. 

 

And, Display on the [Device operation options] window. 

 

        
 

 

 

 

1. Check the checkbox of [Protect/Unprotect] in Sector Protection. 

2. Write the sector number you want to protect in the Setting Protection Editor.([non] 

is default and protect sector is nothing) 

example : when you want to protect the sector number 2,3,15,16,17, you write 

[2,3,15-17] in the Setting Protection Editor. 

3. Push [OK] Button. 
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Function Description 

This chapter will describe below functions. 

 

 

 Load file 

 Save buffer  

 Buffer editor (Edit) 

 Project management 

 Lot management 

 Status of operation 

 Setting of programmer 

 Operation of programmer 

 

 

The performance of M400 Series is excellent due to below functions. 

 

Here will introduce the operation and functions of software for M404. 

(It’s the same for M408 and M416 except the programmer model.) 
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Load file 

You must edit the data of PC and programmer before operation and device must be 

selected before loading data. 

 

Load file 

Choose menu [File] -> [Load file to buffer] or click [Load] button  , then below 

dialog box will be displayed. 

Click [Browse] button, you can choose the file for operation and the file name will be 

displayed. 

The data will be loaded to buffer by clicking [Load] button. 

 

 

Operation for Load file dialog box 

 

 

 

      

 

 

 

 

 

 
 

 

 

 
 

 

 

 

 

 

 

  

②Format type 

③Additional operation 

(Swap, BufferClear) 

④Buffer offset 

①File name 
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① Select file name 

Set the file name to [File name] Box by clicking [Browse] button. 

 

※ Default folder 

The folder which you choosed last time will be set as default. 

 

② Format type 

Indicate the file format which you will load to buffer by drop-down list of [Format 

type]. 

You can choose Motorola (*.MOT), Intel HEX (*.HEX) and NO format (*.Bin). 

 

③ Additional operation 

・Swap bytes   

Before File loading the data will be swapped by bytes. (Both WordSwap and Bit Swap 

are developing) 

 

・Erase buffer before loading 

Clear all the contents of BufferMemory (PC) before loading file and you can set the 

value which you need to clear (The default value is FF) 
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④ Buffer Offset  [Default as （None）] 

Use buffer offset function to specify the offset address for adding the data read from 

the file to buffer zone. The standard setting is “None”. User needs to set the 

compensation value when in use. The following settings are available. To specify the 

start address of loading file by set the [buffer offset for loading]. 

 

None: The red file will be put into buffer memory without offset. 

Positive offset: Store the data to buffer address where the read file address is provided 

with offset.  

Buffer address = Formatting address + Offset address  

Negative offset: Store the data to buffer address where the offset is subtracted from 

the read file address.  

Buffer address = Formatting address – Negative offset  

Automatic negative offset: Offset could be detected from the read file automatically 

when this setting is enabled.  

Buffer address = Formatting address – Negative offset 

 

Additional for File Load 

After loading file, the value of SUM and CRC32 will be updated on the main screen 

and a message will be displayed for whether 69ransferred69 the data to programmer 

[Yes]/[No]. 

For SD buffer Memory, the data file can be saved as history and also can be cleared. 

So there will be 2 kinds message: 

※ Minato has no warranty for the data be saved in BufferMemory. 
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2 kinds message about Data File Load 

 

The file is not in the history(not ever be used before). 

 
The message means this file did not been used before and you want to transfer the data 

to programmer, please click [yes] button. 

This message will also be displayed while you want to clear the history. 

 

 

The file is in the history (ever be used before). 

 
The message means this file had been used before and please click [No] button 

without loading data to programmer again. So it will save the setting time. If you want 

to transfer again, please click [Yes] button. 

 

Close the Load file window 

Click [Cancel] button or  to close this window without change of the data. 
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Save buffer 

 

The data in buffer editor or copyed from IC can be saved to PC as a file. 

Choose menu [File] -> [Save buffer to file] or click [Save] button  ,then the 

dialog box will be displayed as below. 

 

Click [Browse] to set the file name and folder to save. 

 

According your request to set [ File name ], [ Fomat type ], [ Advanced save options ], 

[ Additional option ]. 

 

Save buffer dialog box 

 

 

 

 

 

 
 

① File name 

Set the file name in the [File name] Box by clicking [Browse] button to a folder. 

※The folder which you choosed will be set as default. 

 

② Format type 

Indicate the format of file which will be saved by drop-down list of [Format type]. 

You can choose Motorola (*.MOT), IntelHEX (*.HEX) and NO format (*.Bin). 

 

③ Additional operation 

Swap bytes 

Before saving File the data will be swapped by bytes.(Both WordSwap and Bit Swap 

are developing) 

 

Buffer start/end 

If you just want to save part of the buffer data to a file, you should set the address of 

[Buffer start] and [Buffer end]. And the address should be byte address. 

 

 

 

① File name 

② Format type 

③Additional operation 
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Save buffer 

Click [Save] button to save file and the （SUM／CRC32） value will be updated on 

the main screen. 

A message will be displayed for whether 72ransferred72 the data to programmer 

[Yes]/[No]. 

And there will be 2 kinds message about the history.(Refer to Load file) 

 

Close the Save buffer window 

Click [Cancel] button close or  to this window without change of the data file. 
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Buffer Editor (Edit) 

By clicking Editor button you can choose various tool including Intialize buffer, find 

text and edit, etc. 

 
 

 

Menu [Function] [View] [Help] 

Toolbar [Initialize] [Edit] [Find・Replace] [Jump] [Mode] [Check SUM] 

[Version] 

 

Notice about data transfer 

Buffer Editor is a tool of Buffer Memory operation. During actual operation of device, 

it’s essential to transfer the data to the body of programmer upon the completion of 

buffer edition. 

Please referring to「COPY」 or 「Load File」. 

 

Editor Window 

 

 

 

 
 

 
 

 

 

 
 

 

 
 

 
 

 

 

 

①Menu bar 

②Tool bar 

 

③Data area 

④ Status bar 
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① Menu bar 

There are 3 menus about Buffer Editor: [Function], [View], [Help] and each menu are 

defined as group. 

 

[Function] 

Contains all the related tools 

 

[View] 

To change the Toolbar, status bar, Byte&Word displaying status.(Toolbar can not be 

changed) 

 

 

View as Byte 

Using byte as the unit to view the content of buffer by choosing [View] -> [Byte] and 

the data will not be changed.  

The default unit of Buffer Editor is byte. 

 

 

 

 

View as Word 

Using word as the unit to view the content of buffer by choosing [View] -> [Word] 

without changing the data. It will return byte mode while you open Buffer Editor 

again. 

 

 

 

 

 

② Tool bar ( EditWindow ) 

There are total 13 tools be divided into 7 groups. The groups are [Initialize], [Edit], 

[Find・Replace], [Jump], [Mode], [CheckSUM], [Version]. 

 

[1] Initialize 

 

Erase 

The data of BufferMemory will be cleared as“FFh”. 

 

Fill random data 

To fill random data to Buffer Memory. 

 

Fill block 
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Using indicated data to fill the Buffer Memory of block. 

 

[2] Edit  

 

Copy block 

Copy data from one block to another block. 

 

Move block 

Cut data of Buffer Memory from one block to another block. 

 

Swap data in block 

Swap the data of Buffer Memory. 

 

 

[3] Find・Replace  

 

Find text 

To search certain content. 

 

Replace text 

To search certain contents and change them with other contents. 

 

 

[4] Jump  

 

Go to Address 

Jump to indicated address. 

 

 

[5] Mode  

 

Edit buffer 

The data can be changed in Edit mode. 

 

View buffer 

The data can not be changed in View mode. 

 

 

[6] Checksum  

 

Check SUM 

To calculate the SUM･CRC . 
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[7] Version 

 

About 

Indicate the version and copyright. 

 

 

③ Data area ( Editor Window ) 

Display the contents of BufferMemroy and the default unit is Byte. There are at most 3 

Tabs according to IC type. Clicking Tab to switch and the data of each Tab is 

independent. 

 

 
 

 

④ Status bar 

It’s a simple description of menu or tool and it will be displayed by moving mouse to 

certain button. It also can be hided by selecting [View -> Status Bar] . 

 

Description of tool bar 

 

Erase BufferMemory (Editor window) 

Clear the contents of BufferMemory by choosing [Function] -> [Erase buffer] or  

[Erase] button  . 

Then click [Yes] button to continue this operation and  

all the data will be cleared as FF. 

Click [No] button to cancel this operation . 

 

 

Fill random data 

Replace Buffer Memory by Random Data by choosing [Function] -> [Fill random 
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data] or clicking [RandomData] button . 

Then click [Yes] button to continue this operation and 

all the data will be replaced with Random Data. 

Click [No] button to cancel this operation. 

 

 

 

Fill block with indicated data . 

Initialize BufferMemroy with indicated data by choosing [Function] -> [Fill block] or 

clicking [Fill block] . 

button  . And the buffer memory will be initialized by clicking [OK] button . 

 

 

 

 
 

 

 

 

 
 

 

You can indicate the address and data (ASCII or Hex) for filling on the Fill block 

dialog box. 

 

 

① Indicate the address 

Key in the address at [Block start] and [Block end]Box. 

② Fill string(ASCII) 

Key in the ASCII data at [ASCII] (Max 16) 

③ Fill string(Hex) 

Key in the Hex data at [Hex] Box (Max 16) 

 

 

  

 

① Indicate the address 

② Fill string (ASCII) 

③ Fill string (HEX) 
① 

② 

③ 
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Copy 

Copy data from one block to a indicated address. 

Choose [Function] -> [Copy block] or click[Copy block] button  and the operation 

will start by clicking [OK] button. 

 

 
 

 
 

 

 

① Block area 

Indicate the address at [Block start] and [Block end] box. 

 

② Destination address 

Indicate the start address at [Destination] Box. 

Close [Copy block] dialog box. 

Click [Cancel] button to close this box without changing the buffer data. 

 

※The data beyond buffer capacity cannot be copied. 

 

  

 

① 

② 
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Move 

Cut Buffer data from one block to another block by choosing [Function] -> [Move 

block] or clicking. 

[Move block] button  and data will be moved by clicking [OK] button. 

 

 

 

 
 

 
 

 

The block area and address should be indicated before operation and the block data 

will be replaced by FF. 

 
7 Block area 

Indicate the address at [Block start] and [Block end] box. 

 

 

②Destinaton address 

Indicate the start address at [Destination] Box and the unit is byte. 

 

 

Close [Move block] dialog box 

Click [Cancel] button to close this box without changing the buffer data. 

 

※The data beyond buffer capacity cannot be copied. 

 

  

 

① 

② 
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SWAP 

Swap buffer data due to different request of byte order. 

Choosing [Function] -> [Swap data in block] or clicking [SwapData] button .and 

the operation will start by clicking [OK] button. 

 
 

 
 

 

 
 

 

① Indicate the block area at [Block start] and [Block end] box. 

② Swap mode 

Byte mode (change the byte order) 

Exchange the data in buffer memory in Byte by choosing [Swap 2-bytes inside 16-bit 

words] 

Example：[A],[B], [C],[D] →byte swap→ [B],[A], [D],[C] ：[ ]ByteSize 

 

Word mode （change the byte order） 

Change the order of data in buffer memory with 4 bytes as a unit by choosing [Swap 

4-bytes inside 32-bit words] 

Example：[A],[B], [C],[D] →word swap→ [C],[D], [A],[B]  ：[ ]Byte Size 

 

Nibble mode（Four-bit bytes exchange） 

Swap of high- and low- nibbles inside each byte by choosing [Swap nibbles inside 

byte]. 

Example：[00101101] →swap nibbles→ [11010010]  ：[ ] Byte Size 

 

Close [Swap data in block] dialog box 

Click [Cancel] button to close this box without changing the buffer data. 

 

  

 

① 

② 
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Find text 

Search data by choosing [Function] -> [Find text] or clicking [Find text] button  

and it will start to find by clicking [Find] button. 

 
  

           

 

 

 
 

 

 

You can indicate the text (Hex or ASCII) to find, direction and origin. 

 

① Find text 

Enter retrieval data. 

To Hex-side dialog box: Enter the data to be retrieved using hex data column.  

To Ascii-side dialog box: Enter the data to be retrieved using Ascii character strings. 

 

②  

Direction 

Indicate the search direction by choosing [Forward] or [Backward]. 

Forward Search from top address to bottom address. 

Backward Search from bottom address to top address. 

 

Origin 

Indicate the start address by choosing [From cursor] or [Entire scope]. 

From cursor, From current cursor to search 

Entire scope, Search all the buffer from top to bottom address. 

 

Close [Find text] dialog box 

Click [Cancel] button to close this box without searching. 

 

  

 

① 

② 
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Replace text 

Search some data and replace them by indicated data. 

Choosing [Function] -> [Replace text] or clicking [Replace text] button  and 

clicking [Replace] button to replace the text. 

 
 

 
 

 

 
 

 

 

 
 

 

① Find text 

Enter retrieval data. 

To Hex-side dialog box: Enter the data to be retrieved using hex data column.  

To Ascii-side dialog box: Enter the data to be retrieved using Ascii character strings. 

 

② Replace text 

Enter replacement data.  

To Hex-side dialog box: Enter the data to be replaced using hex data sequence.  

To Ascii-side dialog box: Enter the data to be replaced in the form of Ascii character 

string. 

 

③ Direction / Origin 

Direction 

Indicate the search direction by choosing [Forward]or[Backward]. 

Forward Search from top address to bottom address. 

Backward Search from bottom address to top address. 

 

Origin 

Indicate the start address by choosing [From cursor] or [Entire scope]. 

From cursor : From current cursor to search. 

Entire scope : Search all the buffer from top to bottom address. 

 

 

④ Mode 

Next : Display the confirmation screen once for every round of replacement. 

 

①Find Text 

②Replace text 

③Direction/Origin ④ Mode 
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The message reading “start next replacement?” will be displayed at the end of each 

round of replacement. To proceed with the replacement, click [Yes]; to stop the 

procedure, click [No]. 

All : Full replacement is to be performed without confirmation message. 

 

Close [Replace text] dialog box 

Click [Cancel] button to close this box without changing the buffer data. 
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Jump 

Jump to a indicated address by choosing [Function] -> [Go to Address] or clicking 

[Go to address] button  and after clicking [OK] button it will go to the indicated 

address. 

 
 

Indicate the address. 

Key in the address at [Current address] Box and the Unit of address should be byte. 
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EDIT MODE 

Change the Buffer Editor to Edit mode by choosing [Function] -> [Edit buffer] or 

clicking [Edit buffer] button . 

The [Edit buffer] menu and button will be locked and the data at the cursor can be 

edited. The data should be Hex (0-9, A-F) 

 

The cursor can be moved by [↑] [↓] [←] [→] button or mouse directly and the data 

will be changed directly after editing without confirming message. The default mode 

is [view] while opening [Buffer Editor] again. 
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View mode 

Change the Buffer Editor to view mode by choosing [Function] -> [View buffer] or 

clicking [View buffer] button . 

The [View buffer] menu and button will be locked. 

 

 
 

The default mode is [view] while opening [Buffer Editor] again. 
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Check SUM , CRC and XOR 

There are 7 types about SUM or CRC.(ByteSUM、WordSUM (Little endian)、Word 

SUM (Big endian)、CRC16、CRC32、CRC-CCITT、XOR ) 

SUM , CRC and XOR are useful to confirm whether the data loaded to buffer or write 

to IC is correct.  

Choosing [Function] -> [Check sum] or clicking [CheckSum] button to open the 

calculate window and clicking [Calculate] button to calculate. 

 

 
 

※ The calculate range must be indicated first. 

 

① Calculate range 

Key in the address at [From address] and [To address] Box. Default address is for 

whole range and you can calculate them directly by clicking [Calculate] button. 

 

② SUM, CRC and XOR display 

After indicating the calculate range, clicking [Calculate] button to calculate the SUM , 

CRC and XOR.  

※Default address is whole range. 

 

Close [Checksum] dialog box 

Click [Cancel] button or  to close this box. 

 

Close [BufferEditor] 

Choosing [Function -> Exit] or clicking [Alt]+[F4] button to close this window. 

 

 

 

 

 

Only Buffer Edit 

② SUM , CRC or XOR display 

① Calculate range 
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After Buffer editing please pay attention to below message: 

“A buffer memory is being updated! Do you do data transmission?”  It means 

whether you will update the data to programmer after edit. And the data will be saved 

in Editor before you load another file. 

 

Please note that the data displayed for buffer edition would be inconsistent with the 

data imported/written into the device from programmer if such data are not transferred 

to programmer. Imported/written-in data from programmer is the data acquired before 

edition (transferred to programmer). 

 

 

Save data to file 

If you want to save the data to a file after edit, please Choose menu [File] -> [Save 

buffer to file] or click [Save] button . 

 

 ((Save buffer)) 
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Project Management 

 

You can save IC P/N, data and settings to a project file for M400 control software and 

you can reload all of them for next operation.  

 

Load Project File 

Load project file to software by choosing [File] -> [Load project] or clicking [Load 

project] button . 

Then click [Open] button to load Project File. 

 

Filename extension 

It’s xxxx．Ppf for project file. 

 

 

Save as Project file 

Save all the settings as a project file by choosing [File] -> [Save project] or clicking 

[Save project] button  and a [Project information] dialog box will be displayed. 

 

The current programmer operation mode, device name, data file name and check sum 

value etc. will be displayed in “Project->Confirmation” dialog box. 

Protection of the file in the SD ： When the file is written into programmer, the 

previously read files will be deleted if there is not enough SD memory capacity in 

programmer. However, no file would be deleted if 「Protection of the file in the SD」 

is enabled. 

 
Please click on “OK” button after the confirmation of content.  

The “Project information” dialog box will be displayed.  

The procedure for operation of “Project information” dialog box screen is described as 

follows. 
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[Project information] dialog box 

 

         

 
7  Project file name 

② Project ID 

③ Note 

              

 

① Project file name 

Key in the Project file name at [Proj file name]Box and it will be saved in the default 

folder.The default folder is ”C:\programmer\m404\support\data”. And the default 

folder will be changed as you selected last time. 

 

② Project ID 

Key in Project ID at [Project ID] Box and it’s useful to confirm the project 

information. 

Max 16 Half-width characters is acceptable. 

 

③ Note 

Key in Note at [Note] Box and it’s useful to confirm the project information. 

Max 28 Half-width characters is acceptable. 
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Lot Management 

It’s easy to confirm the quantity and others status of operation according to Lot 

management and a report can be created. 

 

Lot Size 

Click [Lot size] button to open [lot information] dialog box. 

 

 

 

 

 

               
 

 

① Lot size 

Enter the PASS number of devices (target value of operation batch) into [Lot size] 

dialog box under “Lot information” dialog box. 

 

② Lot number 

Additional confirmation of Lot. Key in it at [Lot number] Box. Max 23 Half-width 

characters is acceptable. And the Lot Number will be used as the name of report. 

 

③ Operator 

Operator information for confirmation. Key in it at [Operator] Box. Max 23 

Half-width characters is acceptable. 

 

④ Note 

Additional note for confirmation. Key in it at [Note] Box. Max 35 Half-width 

characters is acceptable. 

 

 

 

⑤ Programmer mode 

① Lot size 
② Lot number 
③ operator 
④ Note 
⑤ Mode 

⑦Report 

⑥ Lot Start End 
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Choose the operation mode of operation programmer from “Programmer mode” in 

batch management mode. 

 

⑥ Lot Start & End 

[1] Lot Start 

Click [Lot start] button to begin and a message “Are you sure to rest statistics 

counters” will be displayed, accrording to you request to choose [Yes] or [No]. 

And except [Lot end]&[Report] button, all others item be locked. 

  

※Notice 

① Upon the start of “Lot Start”, the menu 

option/tool buttons would get into 

“unable-to-select” (selection prohibition) 

state. Programmer operation is 

performed through the [Start] button in 

operation board set of main screen or the 

“Start” button of programmer body. 

② All the tools button will be locked while 

the operation is running, until it is 

finished or clicking the 「Lot end」 

button. 

 

When the number of PASS devices reaches the batch size as set forth in “Lot 

information” dialog box, the operation will come to an end; in such a case, the counter 

dialog box turns pink to indicate that the number of batches is reached. 

       
 

[2] Lot End 

Click [Lot End] button to stop Lot function and a 

message  

“Do you deal with an end?” will be displayed. If 

you choose yes then a report will be created 

automatically.  

 

Close [Lot information] dialog box  
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Clicking  to close this dialog box. 

If you close this dialog box while Lot function is running, then except [Lot End] 

button all others item are locked while you click [Lot Size] again. 

 

Report 

A report will be created automatically after a Lot is finished. The data and 

programmer will be created in one report and different operation will be saved in the 

same report for same day. 

The folder for log report ”C:\programmer\m404\support\log” 

Report name ” (Lot No).Log” 

 

Single report during operation 

Clicking [Report] button to create single report. 

The folder for log report”C:\programmer\m404\support\log” 

Reprot name ”(Lot No)_repXXX.log” （XXX is consecutive numbers start from 000） 
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Operation Status 

The counter and Progress can be checked easily.You also can check the elapsed time 

of operation. 

 

Count 

You can find the PASS, FAIL, TOTAL counter on the Progress Condition Window. 

And the count will be added up. 

 

Progress Condition Window 

 

 

 
 

 

The counter shows the number of IC which have been Contact/ID check passed before 

operation, otherwise the counter will not update. And just count for indicated 

operations as your setting. 

 

Clicking [Clear Statistics] button to clear the counter and confirming information will 

display. [Yes] or [No]. 

You also can clear the counter for indicated operation. 

 

 

 

Indicated counter 

According to your request to set the counter for indicated operation by choosing [File] 

-> [Pass/Fail counter]. 

Pass/Fail counter dialog box. 

 

 Pass/Fail counter dialog box 

 

 

 
 

 

 

 

 

Operation Mode 

 

① Count 
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Select the operation mode at <Enable> bar by corresponding CheckBox. 

 

Add up the counter 

When the operation value selected in dialog box after the <Enable> operation is 

checked, the total would be displayed in both “Total” counter section and the 

PASS/FAIL/Total in main screen. 

 
 

          
 

After canceling the checkbox of BLANK Check, the [Total] quantity will be changed 

to 0 and they will be 9, 3, 12 while you choose the checkbox again. 

 

 

①Clear the counter individual 

Clicking the corresponding [Clear] button to 

clear the counter individually. 

 

 

②Clicking [All clear] button to clear all the 

counter. 

 
Close Pass/Fail counter dialog box 

Clicking [Cancel] button or  to close this dialog box and no setting is changed. 

 

  

Example: Cancel the checkbox of Blank 

 ① ② 
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Others information 

Showing on the main screen while operation is finished. 

While the PASS quanity exceed the LotSize, the PassBox will turn to pink 

automatically. And the operation still can be continued with Pink PASSBOX until the 

statistics is cleared. 

 
 

 
 

 

The progress bar shows the status of operation on the Progress Conditon Window.  It 

is composed by Pass quantity and Lotsize and while the Pass quantity equal to Lotsize, 

the percentage will be 100% until statistics is cleared. 

 

The average elapsed time will be showed at [AVG. Time] Box and the unit is（s）and it 

will be cleared while the mode is changed. 

 

Every operation elapsed time 

The single operaton elapsed time will be showed as “time: xx s”on the LogWindows. 

 

Log Record 

All the information of operation will be showed on the LogWindows and the default 

folder of saving the record is: 

“C:\programmer\m404\support\log” or ”D:\programmer\m404\support\log”  

 

① If you change the folder, the new folder will be set as default. 

② Retention period of Log file 

 

You can chage the retention period of log file by choosing [File] -> [Control of a log 

file] -> [file retention period] Box. From left to right is [Month] ／ [Day]. 

Example）you hope to save it 10days, you should key in [0]/[10]. 

 

File name, ”multp(XXXXXX).log”  （XXXXXX is 6 number of the 

year.month.day ） 

The default retention period is 7days. 
  

②Progress bar 

③Average elapsed time 

①Turn to pink 
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Close [Control of a log file] dialog box  

Choosing [File] -> [Control of a log file] and clicking [OK] button on Control of a file 

dialog box to save settings and close the dialog box. 

 

 

 

②Retention period 

①Log file path 
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Auto Start 

“Automatic startup” means that the operation would be automatically started without 

pressing START button upon the completion of device setup. Recovering the device 

without pressing START button helps to prevent such error as ingression of 

semi-manufactured goods. 

 

 
 

1. Mount adapter and choose device in the same way as routine operation. 

2. Select operation mode. Please choose operation mode from the list of [Operation 

mode] in menu. 

 

 
 

 

3. Choose auto start mode ON. Please make choice in the menu ー[Programmer] – 

[Auto Start]- [Mode] – [ON]. 

 

※Note 

Please have adapter mounted or removed after removing the device, or the 

device may be damaged. 

 

Version 

UniversalControlProgram ・・・V2.06 

MODEL400 Series Firmware ・・・V1.25 
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4. Once the adapter is properly mounted, the socket LED would flash red. The failure 

to flash red after the installation of adapter may be the result of poor contact. 

Please re-install the adapter. If it doesn’t work, please confirm version about 

“Universal Control Program” and MODEL 400 firmware. 

 
 

5. Set response time. The so-called response time refers to 「the time required to 

achieve stabilization after the loading of device」, 「the time required to remove the 

device」, and 「the time required to remove adapter」. Please make choice in the 

menu ー[Programmer] - ［Auto Start］- [Response time] – [ON]. 

 

 
 

6. Set the device on adapter. Upon the completion of setting, LED would stop 

flashing red but flash green. 

※Where auto start mode is 「ON」, the START key of programmer body is 

disabled. 
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7. Auto start would be performed if “red flashing” turns into “green flashing” for 

each site. 

8. If there are a small number of devices, please take down the adapter that is not in 

use or press the START button on screen. 

9. Upon the completion of read-in, LED would turn green (PASS) or red (FAIL). 

 

 
 

10. Remove the device. 

11. Please go back to “6.” When the following device is used for operation. 

12. Cease the auto start mode. Please make choice in the menu ー[Programmer] – 

[Auto Start]- [Mode] – [OFF]. 

 

 
 

（Flash）  Please set the device. 

（Flash）  The device has been set. 

If the device flashes red upon the completion of device set up, the cause 

may be poor contact. Please set the device up again. 

(LED ON)  ＦＡＩＬ 

(LED OFF)  ＰＡＳＳ 
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Programmer Setting 

Buzzer 

Switch the buzzer of programmer to ON/OFF and the setting will be saved. 

※ If you choose DEMO or OffLine MODE, the buzzer will not work. 

 

Open Buzzer  

Choosing [Programmer] -> [Buzzer] -> [ON] to open. 

 

 

Close Buzzer 

Choosing [Programmer] -> [Buzzer] -> [OFF] to close. 

 

Clear Buffer 

You can clear the contents of buffer (SD) by choosing [Programmer] -> [Clear data]. 

 

 
And for next operation you should load file to buffer 

again. 
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Buffer Setting of PC 

You also can change the Buffer memory 

of PC( Default driver is C: or D: ) 

 

 

 

 
 

If the space of C: or D: is not enough for IC, you can use removable device as buffer 

memory. 

（Recommend to use C: or D: as buffer memory.） 

 

 

※Notice  

① Do not remove the removable device before changing to C: or D:, otherwise the 

data maybe be damaged. 

② If you will use removable device, you must sure this device has been detected. 

 

Slave Mode 

 

Transfer data to programmer Buffer（SD）
directly (ignore Buffer Memory). 

 
Example)  

Normally we transfer data through PC Buffer to programmer buffer (SD) for large 

density IC. If you choose Slave Mode, the data will be 102ransferred to Programmer 

buffer (SD) directly.（Save time） 

(Recommend to use normal mode) 

 

※ Notice 

 The Buffer Editor can not be viewed or edited. 

 The Copy function of Buffer editor can not be used. 

 Making sure you understand slave mode before using this mode. 
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Operation 

 

① Operation Mode 

 You can check the operation mode at the box of 

SOKET Status Window. If no operation is running, it 

shows [TEND]. 

 

 

② Progress Status 

The progress status of operation is showed as % at the ProgressBar on the Socket 

status window. And last status is showed while no operation is running. 

 

 

Check operation/SOCKET Status/ End Result 

Check the operation and result by SOCKET Status and LogWindow. 

The end result also can be checked by buzzer and LED of programmer. 

※Buzzer does not work on DEMO and OffLine mode. 

※The colour of socket is gray while contact checking is ok and white contact 

checking is fail.. 

 

(Example：MODEL 404) 

 
 

 

 

 

 

 

 

 

Not connect （SOCKET colour is white）    Connect （SOCKET colour is gray） 

  

① ② 
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Green： Pass 

Red： Fail 

 
 

 

 

Check by LogWindow 

You can check the operation mode, site number, time, etc on log window. 

 

Other status 

According to the menu /Tool bar to check the status of operation. 

While operation is running the menu/tool bar is locked and will be released till 

operation is finished. 

 

   

    
 

Check by buzzer 

Using buzzing to indicate the result. 

Single long pi (─)  :PASS(Socket colour is green or gray) 

Short pi pi pi(・・・・) :Fail(Socket colour is red) 

※No buzzing on DEMO or Offline mode. 

 

 

Others operation 

SOCKET on Progress 

  

While running, the Site #1 is flashed on and off with orange color and 

baby blue while operation is finished. 

オペレーション終了後、サイト表示は薄緑色に戻ります。 
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Stop 

Clicking  button to stop an operation and below status can be checked. 

Socket colour ： All red 

Buzzer ： short pi pi pi(・・・・) 

LED cloure：All red 

Counter ： No change 

 

Recommend not to stop operation while running, because IC may be demaged. 
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Operation options 

 

It’s possible to designate the operations for “option yes/no” and “write-in” to the 

device.  

To preset the operation, please choose “Device->Device operation options” menu 

option. 

 
[ Device Address ] 

Device start Address (Word/hex) (fixed value) 

Device end Address   (Word/hex) (fixed value) 

Buffer start Address  (byte/hex)  (fixed value) 

 

[ Insertion test ] 

Contact check 

ID check 

 

Contact check STOP set 

While Contact check Fail the operation will STOP. 

The operation will continue if you do not choose it. 

 

 

 

ID check STOP set 

While ID check Fail the operation will STOP. The operation will continue if you do 

not choose it. 

 

[ Command execution ] 

BLANK before PROGRAM 

 

ERASE before PROGRAM 

 

BLANK after ERASE 

 

VERIFY after PROGRAM 

 

VERIFY after COPY 

 

VERIFY  COUNT 

Default・・・・・・・・・・・VERIFY  twice ※ Depends on the IC type 

Once・・・・・・・・・・・・・VERIFY once 
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[ Programming parameters ] 

Set the part/s which should be programmed 

 

 

[ Erase parameters ] 

Set the part/s which should be erased. 

 

 



システム関連について 

108 

M400-020A-K6 
 

 

 

Help 

Language 

You can choose English or Japanese for this control software. And all the information 

& error message will be displayed using this language. 

※ Default language is English. 

 

Set as English 

Choosing [Help] -> [Choice of the language] -> [English] and the main screen will be 

English. 
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Quick Start 

 

Install software and USB driver 

Run the installation program in the CD:  

 M400installer_vxxxx.exe ( MODEL400 Series Control Software ) 

 M400_USB_driver.exe ( USB driver) 

 

 

Install them one by one according to the prompt message. 

 

Install the programmer ・hardware 

Connect the programmer to PC by the USB cable. 

※The software must be installed before connecting. 

 

Start the control software 

Double click the icon on the desktop  and the software will detect the 

programmer.        

 

 

Change the language 

Clicking TOP menu Help - > Choice of the language  -> English or Japanese  
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IC Operation (Program) 

 
7 Select device.                 Click ---- > 

 

②Load data to buffer. 

a) From file              click----- > 

b) From IC  ----- >Put IC into ZIF SOCKET and click  

 

③Put IC into the DIP Socket. 

④click -----＞  

a) Unwritten status (BLANKING) is selected. 

b) Delete (ERASE) data from the device to which the data have been written. 

c) Write data (PROG) into the device. 

d) Compare the read-in data with buffer data (VERIFY). 
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Troubleshooting 

 

Q.1 

The programmer can not be recognized by PC or USB connecting is fail. 

 

A.1 

Confirm below items: 

① Whether M400installer and USB_driver are installed correctly ? 

② Whether the USB and power cable are connected correctly ? 

③ Whether the programmer is recognized by PC? 

④ Is it first time connecting the programmer to PC? 

 

     For WINDOWS XP 

[ Start ] →  [Control Panel  ] → [ System ] → [ Device Manage ] → [ Port ]to 

check the connecting status and if you find below item it means the connecting is ok. 

 
 

           

 

 

                                                                                                       

Example) MODEL 404  

※It’s just a example because there will be different Port number . 

If you changed the usb port number, please restart the programmer. 

Still can not be connected, please contact with minato. 
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Message 

 

Number message guide  ／error

／ notice  ／
dispose 

Note 

001 

 

C:\ no enough space 

 

Current space: ***MB 

Required space： 

          ***MB 

dispose  

The blank space of harddisk is not 

enough, please increase it. 

 

002 

 

Site # connecting fail error Communication fail 

Please close the software and 

power off the programmer. Then 

power on programmer again and 

open the software. 

003 

 

 

Communication fail 

with programmer 

error Communication fail 

Please close the software and 

power off the programmer.Then 

power on programmer again and 

open the software. 

004 

 

Communication fail 

between software and 

programmer. 

Error Communication fail 

Please close the software and 

power off the programmer.Then 

power on programmer again and 

open the software. 

005 

 

Load file fail 

 

error Load file again. 

006 

 

 

Read data from SD 

fail 

error Read again 

007 

 

 

SRAM MemoryCheck 

fail 

error Error occurred for Memory 

Please close the software and 

power off the programmer.Then 

power on programmer again and 

open the software. 

008 

 

Read CRC fail 

 

error Read CRC fail 

Please read it again 

009 

 

Clear SD fail error Please clear it again. 

010 

 

Illegal command error Command again 

011 

 

Communication fail 

between software and 

programmer.Please set 

programmer again. 

Error Communication fail 

Please close the software and 

power off the programmer.Then 

power on programmer again and 

open the software. 
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Number message Guide / error / 

notice / dispose 

Note 

012 

 

Read setting fail error Read setting again 

 

013 

 

Contact check Fail of 

Socket。 

 

SOCKET: Red 

error Please check IC. 

If you want to continue the 

operation, please take the IC 

from SOCKET. 

014 

 

ID check Fail of 

Socket 

 

error Please check IC. 

If you want to continue the 

operation, please take the IC 

from SOCKET. 

015 

 

 error Please restart the software and 

programmer. 

 

016 

 

LogFile path is 

invalid. 

Error Please check the folder  

 

017 

 

LotSzie is illegal notice LotSize setting is not 

correct,please check it. 

018 

 

 

Communication error 

and transfer bin 

data again ? 

dispose 

 

 

Communication is interrupted 

Please follow the prompt. 

 

019 

 

Overcurrent 

 

 

 

error Please remove the IC from 

socket and check it. 
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Confirm the version 

You can confirm the version of control software by clicking Help -- > About 

Universal Control Program Version. 

 

Version up 

Minato will release new version software while new device is added and you just need 

to install the new software. 

  

 

Please contact with minato for the new version M400 Control software (Universal 

Control Program.) 
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Connecting mode 
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Buzzing situation 

Buzzing situation 

 

Note 

Power ON  

UniversalControlProgram Strart finished  

Changed the device  

Operation selected  

Operation finished Different buzzing due to operation result 

 

Items saved in Project File 

Type Items description Save note 

 Project ID Confirmation of Project ○ Key in before saving 

 Project Note Confirmation of Project ○ Key in before saving 

IC IC P/N  ○  

 Package  ○  

 Adapter  ○  

DATA File path・file name ○  

 data Binary data ×  

 File format  ○  

 Buffer range Start・End address ×  

 Byte SUM  ○  

 Word SUM(Little) Little endian ×  

 Word SUM(Big) Big endian ×  

 CRC32  ○  

 CRC16  ×  

 CRC-CCITT  ×  

 SWAP  ×  

 Clear option ENA  ×  

 Cleared data  ×  

 Offset option  ×  

Operation Operation Select operation ○  

 Option  ○  

Counter Counter value Pass、Fail、Total ×  

 Setting Reacord which counter ×  

Time Average elapsed time  × Cleared by blank 

function 

 Operation elapsed 

time 

Operate once ×  

Lot LotSzie  ×  

System Data folder Browse folder ×  

 Log file folder Browse folder ×  

 Log file keeping 

period 

   

 Buzzer ON / OFF ×  

 Tool bar Lock/Unlock ×  
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 Status bar Display or not ×  

 language Displayed language ×  

 

 

Items saved in log file 

Type Item Description Save Note 

Title Version UniversalControlProgrammer ○  

 Model 404 / 408 / 416 ○  

 Programmer P/N  ×  

 Lot number Lot information ○ Key in before 

operation 

 Operator Lot information ○ Key in before 

operation 

 Note Lot information ○ Key in before 

operation 

 IC Maker IC P/N ○  

 Package  ○  

 Adapter  ○  

 Project File name ○  

 Data file File name ○  

 Byte SUM  ○  

 CRC32  ○  

 Start time  ○  

 End time  ○  

Operation mode Select the mode ○  

 Select Address range setting ○  

Counter Setting Count ×  

Time Average elapsed time  ×  

Result LotSize  ○  

 Pass number  ○  

 Fail number  ○  

 Total number  ○  

 Yield PASS÷Pass Fail total ○ Not ÷LotSize 

 

 

Main menu 

Menu select Tool button Description 

File Load project… 
 

Load Project file 

 Save project… 
 

Save Projectfile 

 Load file to buffer 
 

Load file 

 Save buffer to file 
 

Save file 

 Config  System modification (accessible only to 

designer) 

 Control of a log file  Log file management 

 Pass/Fail counter  Counter setting 

 Verify check sum  Comparison between check sum and 
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expected value. 

 Deletion of the data 

file 

 Deletion of data files for operation. 

 Open log file  Open log file 

 (Recent file)  Recent project file 

 Exit  Exit 

Edit Edit buffer 
 

Buffer Editor 

Programmer Buzzer  Buzzer setting 

 Self test  Check programmer 

 Clear data  Delete the data. 

 File list  Summary of files in buffer data of 

programmer 

 LED Check  LED check 

 Handler position  Programmer number cannot be set unless 

the operator performs the operation. 

Device Select device… 
 

Select IC 

 Operation options… 
 

Operation setting 

 Writing of unique ID  The write-in of unique ID is available only 

when operator performs the operation. 

 Access method 
 

Operation mode 

 Copy 
 

COPY 

 Blank check 
 

BLANK 

 Verify 
 

VERIFY 

 Program 
 

PROG 

 Erase 
 

ERASE 

 Cont 
 

CONT 

View Toolbar  Toolbar display／not 

 Status Bar  Status bar display／not 

 Function progress bar  Special：Show the progress at the time point 

when fault occurs. 

 Contact check NG 

mark 

 Show/hide fault mark in the case of contact 

error. 

 Handler NG code  Only when operator is performing the 

operation: OFF normally 

 SUM  Display method of SUM 

Help About Universal… 
 

Version 

 V_up  Update 

 Choice of the lang…  Set the language 

 

Main Menu(Buffer Editor) 

 

Menu select Tool 

button 

Description 
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Function Erase buffer 
 

Clear Buffer 

 Fill random 

data 
 

Clear buffer with random data 

 Fill block 
 

Intianalized the buffer with indicated data 

 Copy block 
 

Copy partial data 

 Move block 
 

Move partial data 

 Swap data in 

block 
 

Swap 

 Find text 
 

Search data 

 Replace text 
 

Replace data 

 Go to Address 
 

Go to indicated address 

 Edit buffer 
 

Edit mode 

 View buffer 
 

View mode 

 Check SUM 
 

Check SUM / CRC 

 Exit  Quit the editor 

View Toolbar  Toolbar display/not 

 Status Bar  Status bar display／not 

 Byte  View as Byte data 

 Word  View as Word data 

Help About 

BufferEditor 
 

Version display 

 Choice of the 

lang… 

 Select language 
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Terminology 

Endian 

For device which data is more than 9bit, which order will be used to write BufferData 

(Byte=8bit) to IC? 

Refer to Little endian and Big endian 

※Default is Little endian. 

 

 

<Little endian> 

“Little Endian” means that the low-order byte of the number is stored in memory at 

the lowest address, and the high-order byte at the highest address. 

※ Default is Little endian. 

 

 

<Big endian> 

“Big Endian” means that the high-order byte of the number is stored in memory at the 

lowest address, and the low-order byte at the highest address. 

 

 

SUM 

A number that results by adding up every element of Buffer data and it is a quick way 

to identify data. Below is the description of SUM 

 

 

Byte sum 

The number by adding up Byte (8bit) by byte. 

 

※ It’s a simple adding at Buffer Edit [CHECKSUM] 

 

 

Word sum (Little endian)  

The number by adding up Word (2Byte) by word. It’s a Little endian SUM. 

 

Example：Buffer Data is 01,02,03,04(hex), and the sum is 0201+0403=0604(hex) 

 

Word sum (Big endian)  

The number by adding up Word（2Byte）data. It’s a Big endian SUM. 

Example：BufferData is 01,02,03,04(hex), and the sum is 0102+0304=0406. 
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XOR  

As one of the logical operations, it is used to check if the data for which the mean 

value is the same as the value obtained from buffer data through this operation. 

 

 

CRC  ( Cyclic Redundancy Check, CRC ) 
It is another quick way to identify data. CRC is different for endian and SUM maby is 

the same for different (1+2 = 2+1).  

It will be safer by checking SUM and CRC. 

Below is the description of CRC. 

※Displayed at Buffer Editor [Check SUM] 

 

 

CRC16  

Method ：X16+X15+X2+1 

Result ：2Byte 

 

 

CRC-CCITT  

Method   ：X16+X12+X5+1 

Result ：2Byte 

 

 

CRC32  

Method  ：X32+X26+X23+X22+X16+X12+x11+X10+X8+X7+X5+X4+X2+X1 

Result ：4Byte 

 

 

File format 

MOT, HEX, NO Format (BIN) 

< Motorola (*.MOT)> 

It’s a Motorola file format containing Record Type, Address, SUM, etc. 

S4, S5, S6 have not been supported. 

 

 

 

<Intel HEX (*.HEX)> 

It’s a Intel file format containing Record Type, Address, SUM, etc. 
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<NO Format (*.BIN)> 

Just binary data. 

 

 

Swap 

Swap a high- and low- order of byte in current buffer 

 

Buffer offset 

Normal the start address of IC is 0,but some Micro tool creates a file from another 

address, so we should set the offset for some file format. 

 

One Time<ＯＴＰ> 

One-time programmable. The characteristic of device that can be programmed once 

but cannot be erased. 

 

 

<Protect> 

One function of IC to prevent changing the content by abnormal operation. 

 

<Security> 

One function of IC to avoid reading out the contents. 

 

<Configuration> 

One function of IC and You may set any options that are available for a specific 

device. 

 

<Partition> 

It’s main for NAND IC to divide the data and IC space to some parts. 

 

 

<Bad block> 

The standard specification for the NAND allows for the existence of bad blocks in a 

certain percentage.  

 

 <ECC> 

The use of an error correcting code is essential in order to maintain the integrity of 

stored code. And ECC code will be written to IC too. 

 

<Site> 

Every 4SOCKET as one site for M400 series programmer. 
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<Lot>/Lot size 

The unit for production quantity. 
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Contacts 

MINATO ADVANCED TECHNOLOGIES INC. 

 

 
 

・Headquarters 

4105, Minami Yamata-cho, Tsuzuki-ku, Yokohama-shi, Kanagawa, 224-0026, Japan 

TEL: +81-45-591-5611 / FAX: +81-45-591-6451 

URL  https://www.minatoat.co.jp/ 
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Revision 

 

Rev DATE Contents 

Rev1 2010/06/25  － 

Rev2 2010/11/01 Added & revised 

Rev3 2011/03/31 Changed the name of the manual and added & revised  

Rev4 2013/10/08 Added & revised 

Rev5 2015/07/01 Added & revised 

Rev5.1 2017/06/29 Changed the name of the business establishment. 

Rev6 2017/09/28 Added the Protect in the contents.  

Rev6.1 2018/05/07 Changed the name of the business establishment. 

Rev.6.2 2018/10/01 Changed the name of the Company. 

Rev.6.3 2022/06/08 Update the Safety Precaution. 

Changed the name of the sales office. 

Rev.6.4 2024/03/08 Support Windows11 

 

 

 


